Windows 32-Bit OS AMD Discussions 2000 XP 2003 2009

Windows 32-Bit OS AMD Discussions 2000 XP 2003 2009

Final AMD APU with XP 32-Bit drivers possibly working on these CPUs.

“Kabini” (2013, SoC) - Possible driver could work in XP.
This one uses Socket AM1 aka Socket FS1b.
Sempron 2650
Sempron 3850
Sempron 3850
Athlon 5350
Athlon 5370

To summarize:
Confirmed by EmmaRoyd
How To - Create a Windows XP 32bit Digital Audio Workstation (and installing on AMD Socket FM2+ hardware).

GA-F2A88XM-DS2P-REV-1.0 motherboard
MD A88X(Socket FM2+) motherboards

A10-7890K(Godavari) APU’s have all official AMD working Display(for the APU’s) and Chipset drivers.

List of other potential Kaveri CPUs I found:
A4 PRO-7350B
PRO A4-8350B
A6 PRO-7400B
PRO A6-8550B
A8 PRO-7600B
PRO A8-8650B
A10 PRO-7800B
A10 PRO-7850B
PRO A10-8750B
PRO A10-8850B

The next generation APU after is “Carrizo” (2016). Not sure if the FM2+ will work but seems more likely. The AM4 Socket version could work but untested. Bristol Ridge (2016) AM4 I tested but didn’t seem to work with the last drivers

[FM2+] Socket

[AM4] Socket
PRO A6-8570E
PRO A6-8570
PRO A10-8770E
PRO A10-8770
PRO A12-8870E
PRO A12-8870

You have forgotten socket FM2+. Socket FM2+ parts prices are rediculously cheap here in the uk. Motherboards from 41gbp, a8 7600 apu 55(46 at 1 supplier)gbp, 4gb ram from 40gbp and a 120gb ssd from 55gbp.

I have XP Pro SP3 32bit working with ALL drivers, including Display driver on the A10-7890K Godavari apu(and previously on the A8 7600 Kaveri apu) and A88X chipset motherboard .

As Ryzen desktop apus are not due to next year, an FM2+ XP system that will comfortably last 2 years or more, will not break the bank and be very capable and fast(if on a fast ssd) is a good choice. Yes, i know Bristol Ridge retail apu’s are due on thursday, but there are still bios issues and the lack of a suitable motherboard. I know FM2+ is stable and capable enough for my needs.

Sadly I have bad news to report. In my latest attempt I tried obtaining a 990FX motherboard which had XP support but lost the auction so it may be up to another year to reacquire this with all original equipment. The idea was to get it working onto this 990FX MB before adapting the technique to Ryzen. AMD AM4 users unfortunately have lost another XP retro OS battle. Modern Intel Coffee Lake will at this point be the only XP retro OS machine for the time being.

Good news I finally acquired the 990FX motherboard I wanted a few months ago. The bad news is due to a family illness that’s still ongoing I’ve been away focused on that even now so never had the time to test it. But I see that the new 7nm Ryzen 3000 Series chips released on 7-7-19 and I had my eye on the Ryzen 3700X.

The reason is the 8 Cores / 16 Threads and 65 Watts TDP.

Also wanted to see how it compared to the i9-9900K.

Also tested my two X370 AMD AM4 motherboards with XP.

But only one had the Asmedia 106X SATA controller which allowed me to install XP.

Also both motherboards have ACPI BSOD A5 issues so you must disable ACPI to continue the installation.

After installation it would freeze up on the XP loading screen which then requires a reboot. Every attempt afterwards the system will not get into the desktop.

Later I tested Safe Mode and I could get into the Desktop and also install the graphics card drivers and USB drivers without a problem.

But rebooting into normal mode causes the same freeze on the XP loading screen.

So XP does work on AM4 X370 Motherboards but something is causing it to freeze when booting normally. Possibly one of the drivers it’s loading that isn’t loaded in Safe Mode is the culprit. Don’t know if I can isolate this manually yet.

But comparing Intel SkyLake to AMD Bristol Ridge XP install tests I think Intel is more compatible with XP so those really wanting to install XP with less headaches even with NO ACPI should stick with Intel.

I also did try diderius6 acpi.sys mod to see if ACPI would work and it resulted in BSOD A5 errors so I’m not certain if his acpi.sys mod really is universal or limited to his motherboard?

Whereas on Intel NO ACPI XP install works in normal XP desktop and Safe Mode.

Hopefully more progress can be made to solve this.

Also need AMD SATA controller driver for AM4. Not sure if the AM3 SATA controller driver can be made to work as I haven’t tested the 990FX yet.

Test result:

AM4 AsRock X370
CPU generation: Bristol Ridge Dual-Core

ACPI.SYS modified by Diderius6 and infuscomus.

Internal SATA Blu-ray optical

Burned CD-RW

Installation attempt:
Early failure

BSOD A5 ACPI Errors:

After successful install on Asmedia 106X and only getting into Safe Mode I accidentally left the system on over 24 hours.

When I returned it was still working on desktop. But trying to do Turn Off Shutdown it would not comply so a full power down was required.

Will see if I have more time to do more testing of AMD SATA driver so I can test other X370 MB with XP install.

But compatibility so far does not look good on XP for X370. Possible differences between B350 and X570 which diderius6 states works even in NO ACPI mode.

One noticeable advantage was AMD can still use DOS Ramdrives but issues found on newer Intel chipsets.

It’s possible AMD AM4 not the best system for XP or 2000 due to differences in BIOS affects how XP seems to not boot correctly and can only work in Safe Mode. Will test 2003 Server to see if it functions better later.

I ordered another 990FX board for AM3+ CPU as a backup. Will test official AMD SATA XP drivers on it for later tests maybe 1-2 months from now if time permits and see if the same drivers work on AM4 or incompatible. Currently Intel SATA XP driver seems to work on all newer Intel chipsets which is why backward compatibility throne goes to Intel and CPU heatsink compatibility still carries over from Sandy Bridge Socket 1155 so no need to buy a new CPU cooler.


I have an ASRock X370 Fatal1ty ITX motherboard in my HTPC, so to test I booted XP setup - no A5 BSOD (maybe only ASRock boards work?)

Can you send me your XP install media to test?


It was actually your image that I tested.

But after troubleshooting the AsRock X370 MB for 3 days today about an hour ago I gave up on that MB. I noticed every time it would freeze up during the DOSNET copy process at some point. Even a simple edit and save of a text file caused it to freeze up.

At first I thought it was the CPU overheating so I down voltaged to where it was still stable to POST. Still no difference so it wasn’t an overheating issue.

Then I disconnected the SATA extension cable which made it easier to swap the SSD quickly thinking maybe one of the SATA cables was defective.
Still the same issues.

Now I switched to my Asus X370 MB which I got first long ago but it is the A model so it will not BIOS update for Ryzen 3000 CPU for testing later on even though this board is superior. Has more features to disable onboard devices and better customization of CPU Cores and Voltage settings. Not sure why the AsRock one has poor BIOS options. Maybe you need to buy the Fatal1ty version to get those nice features.

Currently no issues so far during 2003 Server installation before GUI stage. I’m hoping to see if it successfully uses STORAHCI to get to the desktop the first time since this board has no Asmedia 106x. I think all the SATA controllers (Asmedia and AMD) somehow on the AsRock X370 MB are defective???

Probably 2003 Server install will be done within half an hour to see what the result is. Using F7 NO ACPI test. Later will use ACPI.SYS mod if successful.

It’s ALIVE!!!
How to install Windows XP OS on AMD (AM3+ 990FX and AM4 X370 Ryzen 7)


Finally… Team GREEN joins Team BLUE

Windows Server 2003 aka XP’s cousin on crack has finally worked on the rival AMD AM4!

This time tested on AMD X370-A motherboard the earliest AM4 chipset with Bristol Ridge CPU / APU.

16.0GB DDR4 RAM fully detected

Now I can breathe. More tests in the future when time permits. No rush to ACPI test yet as I’m curious can AMD still run XP for gaming without ACPI compatibility just like Intel.

XPLIVES AMD AM4 Windows Server 2003 SP2.JPG


Nicely done!

The results of my NON ACPI AMD AM4 method worked after switching to my original X370-A Motherboard.
It of course operated as a Standard PC. This meant only 1 core was usable in XP. After testing it I did find issues with its performance. Since I use DVDs and Blu-rays as part of my performance evaluation I found DVDs played sufficiently even on the single core. However, on the Blu-ray’s it could not handle it without stuttering. Then I experimented with Ramdrives to access beyond the 3.25GB memory to 16GB.

This had adverse effects I did not expect. AMD’s boot up time increased the larger the Ramdrive I created. This does not happen on the Intel Coffee Lake at all.

Next I finally tested Diderius6’s ACPI.sys that I suggested as the only way for XP to fix the ACPI instead of the BIOS mod method. So I am glad he quit the BIOS mod and focused on an acpi.sys replacement method so any system can use it. But I have to report good news and bad.

The good news on the AMD AM4 it did install successfully XP in ACPI Mulitprocessor Mode. However, the performance of dual cores did not show an much dramatic improved performance playing the Blu-ray video back smoothly compared to one core. Even increasing the clock speed to max on both cores did not help.

In comparison on the Intel Z370 Coffee Lake when running XP in NO ACPI mode, it successfully installs into MPS Mode which allows it to use all the cores minus hyperthreading which is favorable compared to AMD’s single core for NO ACPI mode.

Also I feel that comparing the performance of the Intel vs AMD even at underclocked speeds and single and dual core testing I found the Intel CPU superior to AMD when using XP 32-Bit overall.

If you have to choose one or the other I still choose Intel as the better, more compatible, CPU.

AMD suffers from some kind of CPU performance hit which I can’t explain. It feels laggier and less responsive. It could be I’m using a Bristol Ridge which is the earliest AM4 CPU generation but compared to even an Intel Sandy Bridge from 2011 the dual core cheap Celeron outperforms this and includes the Intel HD Graphics driver which works in XP as a bonus.

Bristol Ridge APU has no XP driver so you are forced to use a graphics card and Ryzen 2 + Navi APU will not support XP on top of it so wasted.

One issue that I did find with the diderius6 ACPI.sys patch when tested on my Z370 Coffee Lake. While it will install in ACPI Multiprocessor Mode there is still an issue. My video card does not show up in the Device Manager so I cannot install the driver for it. So without the Graphics card it is pointless to use XP in that situation. I think the Diderius6 ACPI.SYS is not complete or ready for all Z370 MB. Since I know I had successfully installed in NO ACPI mode and could see the graphics card show up this tells me something is wrong. I tried reinstalling two times to see if any chance it was a bad installation but the same result. Then migrating the same XP install to Ivy Bridge I see my graphics card shows up there in Device Manager.

This leads me to believe either something is still buggy in the diderius6 modded ACPI.SYS that is missing or not providing all the resources so all the devices onboard and internal cards can be used properly.

However my USB card does work in the slot and is detected so USB mouse and PS/2 keyboard still can function. USB audio also worked for sound but without a graphics card showing up in Device Manager is the biggest problem.

Unfortunately I do not have another Z370 or Z390 MB to test if the same issue happens to isolate whether it is a MB issue or BIOS update needed to work properly.

I don’t know whether or not can the IRQs be assigned or changed for the devices. If I can remove some devices I don’t need from not getting assigned an IRQ then this may fix the problem. It seems to be an issue of too many onboard devices on the MB hogging up too many resources. If unnecessary onboard devices can be disabled somehow in the registry or hidden in the ACPI.SYS upon booting into XP might fix the problem. There are some onboard devices detected which we could neuter such as the FDC for IRQ6.


I have two 990FX MBs but will test later. But for the moment AMD AM4 Bristol Ridge CPU installed on Server 2003 32-Bit and this means while it is possible to use XP 32-Bit on AM4 but with sacrifices in CPU performance and hotter CPU temps that I noticed compared to Intel. When dealing with large amounts of RAM used as a Ramdrive I encountered boot delay times. Especially noticeable when underclocking the AMD CPU down to 800 MHz to match Intel’s underclocking and the effect almost led me to believe the OS froze and wasn’t bootable. Luckily later on when maxing out the CPU clock speeds I noticed it booted into the OS faster which confirmed that I mistook the boot time delay as being frozen was incorrect. On the Intel side large amounts of RAM used as a Ramdrive had no effect on the boot up time.

I would say given your experience on the AMD AM2 socket and a working integrated graphics driver that the AM2 might possibly be the best all in one AMD chipset for XP 32-Bit. But the last generation truly compatible looks to be the AM3+. The AM4 certainly has issues. If using XP with just 3GB or 4GB of memory max installed it probably will be fine and the delay not noticeable. I can imagine a 124GB Ramdrive causing a huge boot delay on AM4 that would be very annoying.

Thanks very much for doing all this extensive testing @XPLives it’s appreciated.

@diderius6 did you encounter any issues with the graphics card not detecting on Z370 when using patched ACPI driver?

Yes used the Diderius6 Acpi.sys file in that test. The graphic card works as in you can use it boot into the OS. The problem is in the device manager the graphics card is not listed there so you can install the driver for it. Strange eh?
Never seen this happen before.

In the NO ACPI install that I did ages it does show up in Device Manager. And I did manage to get that card installed and working and played Blu-rays on it while underclocked just beautifully.

I even swapped the GT 710 and installed my fanless GTX 750 into the AMD AM4 and even with the ACPI functioning for dual cores the same stuttering lagging issue and near 100% CPU utilization occurred. It could be the Bristol Ridge is underpowered but even with dual cores working and maxing out the clock it didn’t make much of a difference compared to my single core NO ACPI test. I think there’s something wrong with AMD AM4 running XP 32-bit as there should be plenty of power in that CPU to do the job unless somehow the CPU is underpowered. The only good thing is the graphics card does show up on the X370-A so I was able to test both AMD and nVidia graphics card on it. The APU doesn’t work in XP even with modding. So it doesn’t appear to be related to graphics card version that does work in XP.

In my older GT 710 tests it is plenty powerful enough a card to play Blu-rays even on dual core Ivy Bridge celerons. In fact probably over powered for the job. So disappointing. I’m not sure if going to a R7 3700 will even rival a i5-2500K if there’s some compatibility issue going on here. I might have to do some tests again on an Ivy Bridge celeron dual core to see if it works fine as I don’t recall it being an issue and see if 800 MHz is enough or running on 1 core.


I have not tested any Bristol Ridge CPUs for myself -
wow! Bristol Ridge is 28nm from 2016! - old Bulldozer design from when AMD were way behind intel (intel were on 14nm by 2016)

have you had any chance to test any newer Ryzen CPUs?

Most of these tests were done about 2 weeks ago or so. Finally had time to post the results.

The AMD USB driver worked on one USB controller like yours while the other did not.

Copied large Video file from USB source to SATA hard drive.
Transfer rates:
1.77->1.82 GB per minute
29.50->30.33 MB per second (no where near USB 3.0 theoretical speeds, and closer to USB 2.0 speeds)

During copying files off the USB source it can cause the USB mouse to lag.

When using USB audio on the USB port and playing a video file off a USB storage device on another port will cause the video to lag.

Playing the video file off the internal SATA hard drive does not cause a problem while playing audio off USB Audio.

So do not use USB Audio and playing a video off the USB storage device.

USB Webcam has an issue streaming over 940x544 resolution at 15fps.

Even on standard USB 2.0 port it can stream 1920x1080 at 10 fps normally.


which AMD USB driver did you use?


I think it would be fair despite 2011 Intel vs 2016 AMD technological differences. A 32nm Sandy Bridge dual core celeron vs a 28nm Bulldozer dual core I could perform if Ivy Bridge has you concerned. Both both chips are similar in performance despite die shrink. In some cases some would prefer Sandy Bridge since you can overclock them higher than Ivy Bridge.

And after using the ACPI.sys to get the dual cores working on the Bristol Ridge it still didn’t show any real improvement. You’d expect at least double the performance or a drop in CPU usage from 100% down some even 10% or more. If I had a quad core or octa core AM4 CPU test I would have done a comparison to see if it was still stuck at 100%. Even playing a DVD file it seemed overly taxed. But again changing to a more powerful GTX 750 didn’t show any change in performance and was still laggy. So either the CPU itself is pure crap or there is a compatibility issue even with the ACPI.sys mod.

Unfortunately unless you can donate a R7 3700 to test I’m not sure whether it’s really the CPU holding it back.

I just checked the BIOS updates and it just got Ryzen 9 3900X support added!
Looks like X370-A MBs are getting 12 Cores which means the monster 16 Cores will be supported in September/October since it’s been 1 month after 7-7-19.

I used the one you referred to me. I think it was an unmodded standard AMD USB driver.
Was this originally from AMD’s own website?