Windows 7 on an HP omen 17 x

as this is my first post please tell me when im doing anything wrong.

I am trying to install Windows 7 on my HP omen 17x (ap006ng) and Im running into multiple issues.

But first some info on the notebook:
It has a legacy support mode, which can be assumed to be on all the time

- When I just try to install a drive with windows 7 installed into the notebook it gives the errorcode 0x000000A5 “Your bios is not fully acpi compliant”
- When I try to install windows 7 via a usb-stick it gives the error 0xc000000f The bcd cant be read

So the things ive tried so far:
- Having windows 7 in gpt mode
- Disabling vga.sys and all the steps linked to that
- Trying to enable the advanced mode with amibcp in my bios for more settings (which doesnt work, when I try to flash a modded bios via afuwin it gives 4f - Error: Block size error when trying to run the program and when I flash a modded bios via an CH341A it says the bios is corrupted and flashes the old one by itself (I know tho that the bios flashing with the CH341A works just fine on this board as I deleted the chip and reflashed the unmodded bios and it just worked))

What Ive found so far is, that the problem might be linked to a form of fast boot, as the bootdrive ive created does work without legacy support (tested that on my Z97 testing pc), but it gives the exact same errors and behaviour as the notebook when I enable MSI Fast boot (a windows 8.1 / 10 feature).

Link to my bios:…weAFEfWIbZNAuR_

Does anyone have suggestions on what I could try to make windows 7 or my bios working for me? Thanks in advance

Another thing worth mentioning might be, that with the bios flashing tool, when I create a recovery USB stick, there is a .sig file nexto the bios, that contains the following:
“Tº5ì»x›„*ÉÁkó$B‚”ûºcUû‹ÌÔJѱ›"B}K¶ö h9FJ?2DïÇÆP;´4òUâ

@Kuhman - CH341A doesn’t know, or check, if BIOS you give it is corrupted, nor does it automatically re-write any other BIOS than what you give it. It does however, verify if what is writes matches what you give it, if not then it will give a non-verify message (I forget exact terms, data doesn’t match etc)
That simply means you need to use another version of the software, or pick correct BIOS chip ID etc. Not all versions of software can write properly, even if they dump the BIOS OK. What is your BIOS chip ID? Sounds like the Chip ID and software version you are using is OK though, since you’ve erased and wrote back original dump OK
So I’m not sure what you mean at all with your CH341A comments. But, sounds like your mod BIOS is probably broken (I don’t say this due to anything CH341A related), usually a lot more than AMIBCP is needed to mod a BIOS anyway

Fast boot can only be enabled if BIOS is set to Secure Boot mode (UEFI Mode), and that means you can only install windows from a GPT partition to a GPT partition.
Legacy mode means you can install from MBR partition to a MBR partition.

As for your last comment, that probably means this is a signed BIOS, and may not be able to be modified, or it could just be normal signature that is used when stock BIOS is flashed

Please link me to the BIOS download page at HP for this system. Your google link doesn’t work anyway, but I prefer to have the stock BIOS directly from manufacturer and FPT BIOS region dump if it’s an Intel CPU system (If AMD CPU, ignore below, does not apply)
* Edit - Is this your download page (BIOS F.21 Rev A May 2019)? I could not find your model as mentioned, only Omen X 17-ap000 - If this is your system, then you have Intel CPU, and all of below applies…top-pc/16851401

And then, also do the following if you have an Intel CPU - Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

@Lost_N_BIOS -

I dont think the bios I flashed was broken, as I litteraly just changed one setting with AMIBCP and it still read fine with any bios editor.

If this was the case, could this be circumvented?

The link you have is the same series but a different model, here is the download link for my model:…/model/20283621

Ive fixed the download link in my Original post, hope it works now.
This is the bios dump:…mgx1OCcCevjMsH/

I am stuck on windows 10, but this is the message Ive gotten:

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2018, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q64FV ID:0xEF4017 Size: 8192KB (65536Kb)

Error 368: Failed to disable write protection for the BIOS space.
FPT Operation Failed.

Ive tried your guide on fixing that error, but that gave me:
Successfully obtained "Setup" variable from VSS (got 6 (0x6) bytes).
error: Offset is out of range

@Lost_N_BIOS - Thanks for the help mate, but as you told me to do this on my post “Windows 7 on an HP omen 17 x” where should I upload the error messages in the future?
For now ive put them up here:

For completeness sake this is where the bios can be downloaded:…/model/20283621


@Kuhman - No need to post in multiple places, I’ll move this over to your thread

* Edit - @Kuhman - Any change with AMIBCP can break a BIOS, any time. Reading fine in BIOS tools means nothing when it comes to BIOS validity, this is just one simple way to check if maybe it’s OK but not trashed.

If the BIOS is RSA signed, no, and the only way to check that for sure is if you have a flash programmer like CH341A + SOIC8 test clip with cable, make a backup and make sure it’s valid, then test a mod BIOS that you know will not be a brick.
If it bricks, likely RSA signed. Some models you can look around in google and someone has already confirmed if RSA Signed BIOS. Some BIOS You can tell from stock BIOS contents.
From extraction of the stock BIOS exe, I see signature at each type of flash package (Shell, DOS, and windows), but BIOS image itself is not encrypted, so that is a good sign

Thank you for the link to your exact model BIOS, it’s same as one I linked. What did you create this backup with, is it your programmer dump?
If yes, OK, no need for FPT backup then (See sorry below )

I will give you info on possible ways to edit BIOS Lock shortly, inspecting your stock BIOS now. You will have to either use another grub version and setup_var2 or setup_var3, or Intel H20UVE if that will work on this system.
There is also another tool that may work, lets check that first, please download this package…949525802284751

Run command from txt from each versions folder (run both 32 and 64 from each version) > Select that Win folder, hold shift and press right click, choose open command window here (Not power shell)
Leave all files in place, so we know what version did what, in case it works and you use it to write back. Once done, zip the package back up and upload a copy for me to inspect

Never mind, none of this is needed, but I’ve leave in case it helps someone later >> Sorry, I keep forgetting you have programmer, used to people not getting until later or forced to get due to brick, so good on you for getting in advance

This system was made for Win10, so aside from boot/install issues, it may take you 1000’s of different edits to try and make this BIOS win7 compatible, we have a whole section for that here on the forum, and I see some success and a whole lot of failure after weeks of attempts by pro’s in this area
So, don’t get your hopes up too high on this, Microsoft has pushed manufacturers to prevent this kind of thing best they can now

I do see legacy support enabled, so that is a good sign for Win7, it even mentions win7 in the help text for this setting.
Secure boot (UEFI Boot) is disabled by default, thus Fast Boot even if enabled would be automatically disabled, so this has nothing to do with any of the current issues.
CSM is disabled though, so this is a poorly configured BIOS, I guess that should be expected from an OEM At least they left boot filter option on UEFI & Legacy, but Storage, Video, and other PCI set to hard UEFI (more poor BIOS engineering)
They have EFI and legacy RST roms, so BIOS is ready for booting from either, only orom vBIOS, so secure boot can’t be properly used even if enabled (more poor BIOS engineering, especially since this is geared to and sold with Win10)

Sorry I didn’t think of this when you first mentioned “Auto-Recovering” at first thread, and I think of that and HP now, this system may have HP SureStart, if it does then no modifications can be made, it will always auto recover from a hidden onboard chip
I’ve dealt with this plenty and we’ve never been able to beat it or find the source of backup Sadly, googling HP Omen 17 brings up SureStart results, first complaint is at Crucial forums about a SSD replacement causing him to have to disable Secure boot to use the SSD at first, exact model is not same but it’s a Omen 17
Here’s general info about this terrible monstrosity -

Here, please test, this edit is not possible to brick, but if auto-recovers after you program it in then SureStart is the cause and no amount of edit can remove that (For customer security and quality, you know)
This BIOS has unlocked FD only, made with your backup above, simple edit that will never be something that causes a BIOS to brick -…814151669217271

Yeah, this sure start is implemented on my laptop, so nothing on the bios that I can do.
But thanks for your time

Fast boot isnt disabled, even if I enable Legacy support, which struck me as kind of stupid

So, BIOS I posted above, after programmed in, auto-recovers? If yes, sorry to hear it, but HP SureStart sucks!

Yes, it’s a very poorly engineered BIOS, fast boot should automatically disable if you have Secure Boot / UEFI mode disabled (ie Legacy mode).
It may be visibly still enabled in BIOS, but can’t be enabled/actually turned on, or you wouldn’t be able to enter BIOS, so yet more poor BIOS coding.