X99Z V102 Inserted .FFS driver doesn\'t work

Hello. I have LGA2011-3 motherboard named x99z v102. So I want to unlock TB.
First I tried fpt:

Platform: Intel(R) C610 Series Chipset
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q128BV ID:0xEF4018 Size: 16384KB (131072Kb)

Lock Settings.
Host CPU master: 00 00 0B 0A
ME region master: 00 00 0D 0C
GBE region master: 18 01 08 08
FPT Operation Passed

Then I tried afuwin and did bios backup (but just 8mb).
I followed the guide on this forum and removed 306f2 microcode.
Then converted v3x4-0.10b-i306f2-rc9 into .ffs using pbatard's efifs and inserted using UEFITool.
After all I flashed modified bios using afuwin again and did reset BIOS to defaults. TB unlock doesn't work. I also tried to load .efi driver from UEFI Shell and this method works but I want to do this from BIOS.

backup_orig.zip (2.88 MB)

without_microcode_with_ffs.zip (2.85 MB)

@pesoja - After you flashed in mod BIOS with ffs inserted, did you dump it again to look at the file to be sure your mod BIOS with ffs actually flashed in? If it is flashed in, then great, you know it works and you can ignore the FPT spoiler below
If this is the case, and you want, let me know and I will make you two BIOS one with only 306F2 removed and one with all microcodes removed, both with properly fixed FIT and non-UEFI-Pad file NOT removed.

FIT is not correctly reconstructed in your mod BIOS (ie bad edit by MMTool) - This needs fixed properly and manually via direct hex edit of that padding which contains FIT.
Make it laid out exactly like the original, with ucodes up top and large section of FF between the lower area, and put the last 5 lines back at the same original lower location

Also, non-UEFI Pad file is removed on rebuild, lucky this did not = brick for you!!
This is bad, you MUST work around that, do edit with other tool instead, actually since this is PEI region, do direct hex edit on entire BIOS instead of MMTool, or use correct/other version of MMTool possibly may be OK (which did you use?)

V3x4 looks inserted correctly, but maybe you made the ffs wrong, I am not sure? Maybe better to use one that is already made (attached in this guide -[GUIDE] Haswell-E/EP Xeon CPUID:306F2 Turbo Unlock)
Or, maybe, you need to remove ALL microcodes, not just 306F2? I am not sure, still waiting on test results from many BIOS I sent user at this thread, before I know answer to this question - Asus X99 WS/IPMI - All Core Turbo
Or, all your issues may be due to the reasons I mentioned above, FIT not done correctly and non-UEFI padding file removed

Sometimes AFU can look like it’s flashing/flashed, but nothing actually flashed in (ie not always reliable method to flash mod BIOS).
You mentioned FPT, but did not mention results of your attempts there?? This is much more reliable method, but you may need to disable some locks first.
Please do below, and tell me what error you get, if any, at step #2

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

@Lost_N_BIOS , first of all thanks for answer :slight_smile:

Yes, when I flashed mod BIOS I did dump again and ffs was there. I will also attach this dump here

I though “non-UEFI data found in pad-file” is okay because it was already in UEFITool NE alpha 57 in adufos dump of original BIOS. I will be glad if you make fixed BIOS

For removing 306F2 I used MMTool_v5.02.0025 and UEFITool 0.28.0 for inserting .ffs driver
I made .ffs by using GenMod.cmd in pbatard’s efifs from cmd (GenMod v3x4-0.10b-i306f2-rc9.efi), also will try that already made

I tried FPT and got “Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.” and didn’t try to unlock that. So I can ignore FPT spoiler, right?

afuwin_dump_after_flashing_w_microcode_w_ffs.zip (2.85 MB)

@pesoja - Good you checked and ffs was there after flash then dump and look, so that means your mod flashed in correctly.

Non-UEFI-Pad file IS OK, but is is REMOVED/missing from your modified BIOS, that is the problem.
This most likely happened with your MMTool edit of the microcodes, try with 5.02.0024 then check, if it still happens, then try with 5.02.007, then if it still happens, you will need to do the microcode edit manually via hex to avoid loosing that file

What FPT commands did you try though? You only need to dump and write the BIOS region, this may not get error, but you don’t know until you try bios region only (as shown in spoiler). But, since you confirmed AFU is flashing in the mods, no need for FPT for now.

I will make BIOS for you as soon as I know if it’s OK to remove 306F2 only, or all microcodes need removed.

@pesoja - Here, please test both BIOS, if #1 does not work for you.

1. = 306F2 only removed >> 306F2RemMM52V3x4.rom
2. = All microcodes removed >> AlluCodeRemMM52V3x4.rom
V3x4rc9 FFS inserted to both BIOS + Fix FIT

@Lost_N_BIOS , I checked 5.02.0024 and getting the same and 5.02.0007 just giving error while saving

I tried both of your BIOS and TB still not unlocked for all cores :\

@pesoja - This is not all core turbo unlock, just max turbo on some cores, I think anyway (I’ve not used myself) Have you read the huge thread at Anadntech? If yes, is it supposed to be ALL Cores at a max turbo?
Did you set all BIOS settings you can like this guide - [GUIDE] Haswell-E/EP Xeon CPUID:306F2 Turbo Unlock
Specifically #3 >>
3) BIOS Settings to improve performance
- CPU Core Ratio > By Core Usage
- Set individually every Core Ratio Limit to max value, example 38

Did you dump BIOS region after flash, to confirm the FFS is in there, so properly flashed in?

I did edit with 5.02.0024 and did not have the issues I mentioned to you initially, about the padding and MMTool (But FIT, yes, always have to fix manually)