Xeon E3-1240 v5 working with MSI Z170-A PC MATE but with bios reset on boot

When I flash rom after me cleaner it works with my Pentium without any problems.
When I use Xeon E3-1240 v5 bios resetting to default on every boot -> xeon_error.jpg.

The VGA LED of EZ Debug turns on for 3 second with Xeon during startup.

Xeon booted with ME and clean with me_cleaner with small letter s option (-s)
The problem with bios reset only occurs with Xeon.

1. Is the problem occur due to the lack of a built in CPU graphics card?
2. Is there a way to stop the bios reset on boot?



Try ME - after your flash of current BIOS/ME, did you reset the ME via fpt.exe -greset or power drain completely for 1+ minutes? Seems like something wrong with the BIOS if board is resetting every time.

Also, when we had success here on MSI/Xeon using my BIOS mods, I did not use ME cleaner when original user did use ME cleaner both ways and had no success, so maybe best to not use ME cleaner but do manually
Trying to boot a Xeon E3 1270v5 on Asrock z170a-x1/3.1 (Help) (2)

For cleaning ME manually, all I did was settings transfer via the guide following it completely and setting the reserved bit to “Yes” was the only change I did
Trying to boot a Xeon E3 1270v5 on Asrock z170a-x1/3.1 (Help) (3)

I tried by fptw64 from Windows with -greset option or by M-Flash and power & battery off for 3-5 minutes.
If I boot first time there wasn’t any message.
But when I’m now only set Reserved bit in tab ME Kernel FIT on some old bioses and when I boot bios & save settings I’ve got message ME FW was abnormal and try to re-flash.
When I used ME Cleaner with -s option there was only message about bios reset every 11.0.xx boots Xeon with MSI.
I will try go to the iGPU settings in FIT, I think no iGPU in this Xeon could cause problems (maybe Bios reset with unknown error)

If you want me to try build mod BIOS for you let me know, all attempts other user in above made failed too until I fixed a set of BIOS for him.

Please, if you want to build a BIOS, do it for me
Thanks in advance!
I tried with some old BIOS from MSI page and all non k (A6T, A91, AE0).
AE0 (with ME: won’t run Xeon after any patches (Reserved bit or me_cleaner by corna).
Alll other boots Xeon with BIOS supplied ME or change to
I found MEInfo command is not working.
Is it possible that ME has been overwritten by me_cleaner?

I will do, but will take me some time, maybe day or two, trying to catch up on some things here.

If you cannot run MEInfoWin, then either ME reserved bit is set = ME disabled, or ME is currently in a corrupted state

I found when I flash whole rom with:
fpt -rewrite -f file.bin
There are some differences between dump and input file.
Could you build BIOS to flash via CH314A programmer?

You can program file.bin with programmer too, if you do not like what FPT is doing. But yes, I will send a .rom file you can program.

In between your ME change tests, are you properly clearing ME state via total power drain for 1+ minutes, or FPTw -greset? If not, this could be leading to some of the issues too

I discovered that the flash image tool (recent FIT with ver. building wrong BIOS files (with wrong ME).

1. Is there an folder on mega.co.nz with older versions of System Tools?

2. Maybe you have link for System Tools on Intel page?

What do you mean building wrong BIOS, it only builds as you instruct it to via config file and it definitely only uses the ME you insert/swap-in during the process. I only have links you find here
Wait, I found in my HDD from r6 package - - https://www.sendspace.com/file/5oiqnz

However, the above version you mention (Current) has been in use for a long time way back in 2017 at least, and no issues reported I’ve seen. And I’m sure @plutmaniac would have updated or removed it or put certain warnings if that version was problematic.

Do you have BIOS dump from before you started doing any of this? if yes, please upload here so I can use to create mod BIOS for you.
I will make four BIOS, using AD and AG BIOS versions, one each with ME reserved Yes and 506E3 rev 74 microcode and one each with ME Reserved Yes and 506E3 rev C2 microcode

Did you do the PCIE Patch or no?

I changed CPU to Pentium G4400.
This dump is weird. There are no sources on Internet.
But that’s newest bios for non k oc on this board from my motherboard after return, it may be helpful. This is version AE0.

I did backup before and this is dump.bin before changes.

I successfully flashed this old non K (A6T) bios, but FIT don’t recognize it:

And i’m now on this bios (A91) without errors. FIT recognize this BIOS properly. This is link for it:

In dump may be PCIE Patch.

I mean, in your mod BIOS, do you patch PCIE before testing?

Do you have your own personal BIOS dump or backup, before you started doing any of these modifications?
If yes, please upload, I do not need links to any other mod BIOS or old BIOS etc, only your old original dump BIOS if you have and I will use stock BIOS from MSI

Under is link for dump on Pentium G4400 pcie 3.0 works, but I’m not author…


It have 16MB I upload to onedrive, it’s before all my changes. This is dump from the board and was stable on the board very long with my old cpu.

When I say dump, I mean a backup from your own PC using FPT, AFU or flash programmer. Sounds like the onedrive file you mention, yes I wanted your BIOS backup before making any changes.

This bios is from my board I dumped by fpt -d. This is first bios when board arrived to me.

Where is link to the BIOS dump you mentioned in post #15? Can’t be post #13 link, you said you are not author?

Yes it’s my BIOS.
It’s motherboard after return and someone patched bios for non k OC and it was flashed to my motherboard…
I checked BIOS process clean CSME patch in three steps:
1. flash A91 BIOS (no BIOS reset, OC works)
2. only add clean ME with the same version included in BIOS
no BIOS reset after save of settings, OC not works, not enabled BCLK OC option in BIOS.
Version of ME in BIOS is showing.
3. change variable in FIT in tab of ME Kernel to Reserved.
Motherboard starts up with message ME FW is invalid.
Version of ME in BIOS is showing as N/A
1. It is possible MSI is checking ME deeper than Intel Tools?
2. Is that variable (ME Kernel - > Reserved) is needed to run Xeon?

Maybe you are not building ME via FIT properly? Did you compare XML with before and after and see only 3-5 changes at file/data locations only not settings?

As far as I’ve seen, and made BIOS for this, yes reserved was required and that was the only change needed (Plus certain older ME versions)

Patch for non-K overclock likely involved ME changes, I will not use that file then, thanks. I’ll just build from stock BIOS, sorry I’ve been behind, hopefully will try to get made tonight.

You never answered my question in post #8 - are you properly resetting ME state between BIOS/ME flash tests (ie greset or full power drain for 1+ minutes)?

I use -greset on Windows.
CMOS battery is out and I’m waiting about 2 minutes and discharge capacitors (many times hit power button without voltage).
I checked binary difference between file form step 2 (clean ME) and reserved yes in step 3 it has only changed 4 hex values and the rest is identical.

Thanks, good you are resetting ME state. I am not sure what your last sentence in about, changing one setting is probably correct to only see few bytes difference.

Do you have flash programmer? If no, how are you sure ME is being written? E
specially now that you said ME shows N/A or does not give MEInfoWin, this means corrupted and can only be fixed if FD is unlocked to write to ME (via FPT), or with flash programmer, since if corrupted and FD is locked, FW Update tool can’t write to ME

I am working on BIOS now for you x4 (2 old BIOS + 2 new BIOS each with same ME version and ME Reserved Yes and No), all with single 506E3 microcode that I know works with these CPU’s (74, I know C2 works too but we try 74 first)
Maybe reserved yes and no both work, but only with reserved NO you can bclk overclock (Possibly, depends on board)