z490 msi bios brick

Hi everyone
I need a bit of your knowledge to try to solve my problem with my motherboard bios.

A few weeks ago I updated the bios of my MB (MSI Z490 GAMING EDGE WIFI)
To my bad luck MSI uploaded a corrupted bios that basically causes brick on several z490 models
MSI support does not reach my country I had to use the CH341A tool to try to solve the problem
At first the MB turned on but marked CPU error (Error caused by the corrupt bios that MSI uploaded)

After using the CH341A tool, the MB does not give a sign of life, it does not turn on any LEDs or the fans turn
The bios flash process was achieved without errors with the CH341A tool so I have no idea what could have happened

*My English is not good , sorry :frowning:

Edit by Fernando: Thread title customized

Dump the firmware again with your programmer, save it and post the file.

Whcih file did you use to flash?

Did you dump the spi before overwriting it (= did you back up the contents of the bricked bios)?

Use the bios that is published on the msi page

Before writing to the bios make a backup copy of the content

I have tried to write the firmware in the bios again but the result is the same

lfbe Asked u to share here or in a sharing host service the 2 files, the original corrupted backup and the a new dump of the new current flashed file.

I have used the “CH341A MINI” software, it is the only one I could find that works with the “MX25L25673G” chip.

All the processes the program performs without errors

I don’t know what the problem could be, before using the CH341a tool the motherboard turned on the LEDs but after trying to write to the bios the motherboard is completely dead, it does not give any signal

He also tries to change the CMOS battery but still does not give a sign of life

Here I leave the backup of my bios and the current bios of my motherboard:

***Backup bios motherboard MSI MPG Z490 GAMING EDGE WIFI BIOS VER. 19


Current Bios:


The BACKUP (u named Backup bios corrupted) bios is v19… the last bios update on site is v18… and i dont see any mentions around the web about a beta or non-public version v19.
The dump (u named Current bios) of the current bios is v17…
Where did u get the v19 bios file?
U sure the SPI is an MX25L256(73G)?

This is from latest v18 from MSI page product support of the MPG Z490 GAMING EDGE WIFI:

Flash chips in VSCC table:
EF4018 (Winbond W25Q128)
C22018 (Macronix MX25L128)
C84018 (GigaDevice GD25x128)
EF6017 (Winbond W25Q64)
C22017 (Macronix MX25L64)
EF4017 (Winbond W25Q64)
C22016 (Macronix MX25U16)

The v19 MSI removed it because it was corrupt, the people who updated with that bios gave him CPU LED error and the board did not respond

I decided to put v17 because there are also reports that v18 gives some problems

But the result is the same, the plate still shows no sign of life

I leave an image of my bios chip


Strange… i read a bit about exactly the same issue u have in ur motherboard model with v17 only… but never found a user talking about a v19 bios… have u found any user with a v19 bios???
A lot, really a lot of MSI Z40 broken like urs… my only advice is to try other software for programming, theres plenty that works with that USB CH341A (Black one i presume…)
Flashrom, Neo programmer, Colibri…etc.
Search on the web or in the next 2 threads:

[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)
[Guide] Using CH341A-based programmer to flash SPI EEPROM

Good luck.

The bios V19 was online for a short time because it was a bios with errors, in the official MSI forum there are several people affected so many with the bios v18 and v19

This is the link to some reports


I have tried using other software but have not found any that support the "MX25L25673G" chip specifically

Only recoverable option here would be a bad flash. Therefore I asked for a fresh dump from your board to know what’s inside this SPI chip right now. Don’t rely on ‘verify messages’ ot that you ‘think’ you did the flash properly.

- Backup bios you linked is a stock bios, not a backup of a machine that has run before (NVRAM empty/ just standard setting, no machine specific data)

- Bios you claim being current bios is 100% identical to stock v17. If you really read it back (and did not just post stock bios V17) then reason for brick is no longer the firmware and we’re finished here.

Use the CH341A MINI software to read the stock bios and then hit the “save” button and create the .bin file that I uploaded.

To write to the bios chip I am using the bios that is on the official msi website

I don’t know what I can be doing wrong, it’s the first time I’ve tried something like this

Did you now again put the SOIC clamp onto the SPI chip and dumped its content?

I bought a bios backup in vinafix thinking that my backup could be with some problem

But the result is the same, the motherboard is still completely dead, it does not give any sign of life

This time use the software "neoprogrammer"

-Is it possible that the bios chip has been damaged?

If so, is it possible that the motherboard does not show a sign of life?

When you can read/dump the content of the chip with the programmer in a separate process, save it to a new file and this file is a 100% identical to the original file you programmed, then the programming process is OK and the chip is OK, too.

Apparently the data is the same

The bios chip when connected, the programmer receives and writes data

What seems strange to me is that the board does not turn on any lights, the fans do not turn


-buy a new CMOS battery

-Test the power source by bridging

-Test the font on another PC and it worked

The board turned on before using the programmer but after using it it no longer turned on

Are these symptoms possible due to a damaged or badly programmed bios?

Usually not… even a board with no CMOS or spi attached can psw for a sec or two, check stand-by 5v, cmos 3.3v and 12v on vrm, if u have the tools.

EDIT: New bios 7C79v1A Release Date 2021-10-18

Same thing here…

@MeatWar @CodeRush @Lost_N_BIOS @lfb6 I’m in desperate need for help for someone to guide me how to do it properly and not to fry the chip and not to flash it and loose UUID or motherboard serial.

I’m completely noob and doing this for the first time in my life.

Product detail:

My motherboard stop working. When I turn on the PC it’s just stuck in POST and I can’t get in to BIOS.
I updated my motherboard with bios release asked me to do from official MSI Center (Win10).
After updating the bios (process went all the way to 100%), the PC will not start at all. I can’t even get in to the bios.

Date of failed flashing: DEC/18/2021
Affected board model: MPG Z490 GAMING CARBON WIFI (7C73-001R) V1.A BIOS Release
Flashing method used: MSI Center
Attempted update to BIOS version: from 7C73v19 to 7C73v1A
Result: Stuck at EZ Debug LED “CPU” after update.
BIOS Chip: MACRONIX MX25L25673GM2I-08G (MX25L25673G)

Monitor Black screen
Try reset on JBAT1 - no success.
Try removing battery and wait for 1 hour - no success.

@MeatWar @CodeRush @Lost_N_BIOS @lfb6

What I plan to use:
Programmer - CH341A green (3.3v). The one I order from Amazon “CH341a BLACK” and it came broken and not working. Also it need to be modified for correct voltage.
Clip is also so so bad, but at least I can use adapter.
Better clip - SOIC Test Clip 8 Pins 2.54mm, Pomona
Jump wires - Female to Female
or in case clip cant reach: Mini Grabber Test Clips

Software & computer:
MACBOOK PRO: (Terminal Homebrew - flashrom)
Win10: AsProgrammer (Version 2.0.3a - with support for MX25L25673G)
Latest CH431a driver for Win10: CH341PAR.EXE (ver. 2.2 - 2021-10-16)

What is the plan for getting my 4500€ machine run again:

TRY 1 (Mac or Linux):
1. Disconnect everything on the motherboard and pullout the battery
2. Connect properly wires to clip and over adapter connect to CH431a
3. On the MAC install flashrom and try to read bios and backup in to .bin file for couple times and compare with files with hash.
:~$ sudo flashrom --programmer ch341a_spi -r backup1.bin -c “MX25L25673G”
:~$ md5sum backup1.bin
4. Send to someone from this forum to prepare the BIOS for flashing. Cos I don’t wish to lose UUID and serial. Using the stock BIOS file (7C73v1A):
5. using flashrom try to install prepared bios
:~$ sudo flashrom --programmer ch341a_spi -w bios.bin -c "MX25L25673G"

TRY 2 (Windows 10):
Same steps as for TRY one except using Win10
1. Disconnect everything on the motherboard and pullout the battery
2. Connect properly wires to clip and over adapter connect to CH431a
3. Install latest driver for CH431a
4. Install AsProgrammer 2.0.3a
5. Read the BIOS and save it to file couple times
6. Compare md5sum
7. Send to someone from this forum to prepare the BIOS for flashing. Cos I don’t wish to loose UUID and serial. Using the stock BIOS file (7C73v1A):
8. Flash the prepared bios to chip and verify

I hope, with help of all you guys, we can fix all the boards that MSI bricked with they irresponsible behaviour giving publicly BIOS update that breaks motherboard.

Looks like you did some reading already- very good. The plan looks OK, but I can’t comment on the commands- no experience with flashrom software.

Storing machine specific information is done very differently by the different vendors. It will take you some reading to find out how this was done for your bios, how to repair you dump or how to prep a stock bios with your machine specific data. It might be a good idea to attach the bios dump of the bricked bios or a link to it here.

Hi there,

hopefully someone can help me.

I did Dump my Bios and uploaded it here.

This happend when i was Updating to this Bios: 7C9v1A in the attachment.

i would be soooooooo thankfull if someone can help me to insert the Correct MAC Adress and UUID.