Acer VN7-791G Advanced BIOS

Hello! please i have acer vn7-791g and
Advanced and Power menu are hidden.
I need access to them.

vars.txt (54 KB)

any one ?

@megan - Sorry I missed your post until now!

Please do the following and send me file from step #1, and also please link me to your stock BIOS download page (not the BIOS, the page to download BIOS from)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

everything is ok until step 2



i forgot to ask you you said : Please do the following and send me file from step #1

and you said again: Please don’t send PM’s for help on BIOS edits, I can’t help with BIOS in PM’s. Please make a thread and I will try to help as soon as I can - thanks!

so where i can send you the files ?

@megan - Yes, this is expected error, thanks. Error 28 may be an issue though, you may need flash programmer to get past this, but we’ll try without first.
You can attach file in thread, or upload to any free file host and post link here. If you want BIOS hidden from public, you can send me link in PM, it’s OK.
I just have that in my signature because I get lost instantly trying to help with BIOS in PM’s due to no information and previous replies are not there every time we reply back an forth

Error 28 is a major pain, there is a few possible programs you can use to bypass, but it’s risky and not ideal to try without flash programmer in hand and backup made, so then once you have those you wouldn’t need to try that method anyway, so kinds pointless then
For now, please try this and see if you still get error 28. Put system to sleep (S3), not hibernate, for one full minute or longer, then wake it up and step #2 from windows again and see if you still get error 28 or not.
This is BIOS sleep bug, if you still get error 28 then your BIOS does not have the bug

i think it worked ?


@megan - Yes, nice! You’re BIOS has the S3 sleep bug, so no programmer needed

So now, send me the original FPT BIOS region dump you got from spoiler at step #1.
If you want this kept private, and you send me in PM, remind me of this when you send the download link, so I don’t post the mod BIOS here

ok check you pm please

Mod BIOS sent in PM, please report back here success or fail etc, thanks
If you cannot enter BIOS it’s OK, we can fix via FPT reflash from windows with your original dump. I only say this because I’ve not unlocked BIOS like this exactly, so maybe did 1-2 more bytes than necessary, but I think it should be OK
* Edit - Wow, Tinyupload slow today! If you need mirror let me know!

omg!! its working with 0 problem thank you so much



can i unlock 135 mhz limits?



i tried gpu-z but i get error message


i also tried nvflash but no luck


I thought if i unlocked the bios i can access to vbios

@megan - Thanks for quick test and report back! Good to see all unlocked
You should have mentioned to me sooner that you wanted to edit vBIOS
No, getting unlock on BIOS has nothing to do with vBIOS access. When you can’t dump vBIOS via NVFlash or GPU-z, that means vBIOS is part of the BIOS.
Here is your vBIOS, rename to .bin, sorry I forgot. You can edit with Maxwell II BIOS tweaker -…118434182843205 >> Mirror, since Tiny’s been down all week (@ ket) -
Send back to me when you are done I will put in mod BIOS for you

Also, you can bypass 135 limit with MSI afterburner program -…rburner.338906/

oh…he needs a KeplerBiosTweaker…also he needs to understand what he is editing

i’m a beginner im afraid to edit something bad will happen


i don’t know how to apply the voltage and core clock

this is the stock settings


@megan - Here is some guides on how to use Maxwell BIOS tweaker…-guide.1590562/ << This was a good one, but now images missing, even in google cache
See also >>…axwell.1522651/…i-bios-tweaker/…)-vBIOS-Modding << Thanks @ket…=search&pto=aue
^^ In-depth, google translate link for this thread, in case you know German -…weaker.1445972/

Thanks @Black_Raven - Maybe you can make the desired changes for megan is she does not get it with the guides above

Or megan, you can leave vBIOS edit alone and do what you need via unlocked MSI afterbuner? This is MUCH safer thing to do!

Seems to be whenever someone needs a good technical guide my name pops up @Lost_N_BIOS lol.

msi afterburner still locked

didn t work for me


help please hhhh

@megan - Please edit your posts if no one replied yet and you need to add more info, other questions or thoughts etc - thanks
Please explain your goal, what you want set to what etc, so that @Black_Raven or someone else can help you. On Afterburner, you may need to try an older version or something, I’m not sure, I don’t mess with any of this myself.

i just wanna increase core clock more than +135mhz

msi afterburner didnt work im using the latest version.

i think It is standard NVIDIA limit for GPU core

Thanks! So you’re stable now with 135Mhz added? If yes, you can directly set whatever speed you want via the tool, if you want 200Mhz more add that to the speed and save

ok i can do the normal 135 core on msi afterburner

now i did 300 with MaxwellBiosTweaker and i didnt change voltage is that ok ??

this is the modified vbios :