I am using afudos to update bios in several computers, all are asus z87 or z97, no bios flashback button on these so I can either do the switch file with ai suite or after updating bios with UBU, I remove body using uefi tool, copy to a rufus usb stick with an older copy of afudos that supports /gan option and flash seems successful. Only thing I noticed on the 2 that I have done so far is that when I reboot, windows starts doing a "setting up devices" as if I had swapped motherboards or something. To be exact, this is what I have run:

afudos z97p.rom /gan

I assume I am losing something? Is there another option that will update bios and keep equipment ids such as mac addresses? Seems like network adapter still has same mac address but it takes a bit longer to come up on the network (5-10 seconds). Aferwards it works fine

@billydv - This due to you shouldn’t do that, AFUDOS w/ GAN made for BIOS type decade+ old, and 1-2 BIOS series types older than Z87/Z97 BIOS. The actual cause of what you mention is due to NVRAM not being programmed back in properly.
Do this, if you must continue to use AFU >> AFUDOS.exe biosname.bin /P /B /N /GAN

The proper way to do this instead of using AFU, would be use FPT but only if you are modifying the BIOS would any of this be required. Dump the BIOS region from target board, modify that if then flash back to that same board only using FPT.

If you are simply updating the BIOS, without modifying it, then use UZ Flash and stock BIOS as it is from Asus, nothing special needed except to rename it to USB Flashback name and put on FAT32 USB and then enter EZ Flash from within BIOS.

Do you mean a flash programming tool like something with a raspberry pi?
Just to be clear, I am updating bios using UBU for CPU microcode and sata orom modules so EZ Flash does not work because bios is modified.
If I flash back stock bios and then flash nodded bios like
Afudos Z97P.rom /P /B /N /GAN
it would work?

FPT is Intel Flash Programming tool, it’s software from the ME FW tools packages. Since you didn’t know, I will mention now >> DO NOT Flash stock or modified stock BIOS with FPT, or you will loose your serial, UUID, possibly LAN MAC ID too depending on how you flash.
FPT is per ME FW version specific, you can get all the versions here in section “C” inside each ME FW System Tools package - Intel Management Engine: Drivers, Firmware & System Tools

Great, thanks for clearing up the fact that you are using mod BIOS here, I wasn’t sure.
For this, on a per system basis, if you wanted to not use AFU (Suggested), you need to dump each boards BIOS region with FPT, check for BIOS/SMI Lock enabled, if enabled, disable that, then do a new dump, then modify that, then reflash it.
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

To continue doing what you were doing, on current boards or future boards, no you don’t need to flash stock BIOS before mod BIOS with AFUDOS. I just gave that as the command you should be using “In general/always”, so you don’t run into the issues you mention.
AFUDOS with use of GAN is highly suggested against on modern systems.

Here is a better way, that wont mess up the BIOS and cause other future issues (main thing here is like you mention, flash stock BIOS first then without reboot flash mod BIOS)…r-motherboards/

I personally suggest the FPT method for anything Intel and modern that does not have USB Flashback. But that is a little bit more work for you, once you get used to doing it though it’s easy and only takes a few minutes

I will try it. Thanks

so although the computer I had flashed with afudos is working correctly, I do have another problem. The network adapter mac address changed so I had to go the the office and enter a locally administered address since everything at the company relies on ip addresses. Can I use the rufus disk to return the original mac address to the Network adapter like this?

afudos /M 004r6j3y59

Or am I doing this wrong?

Yes, it always “appears” to be working fine, when AFUDOS actually flashes the BIOS and doesn’t brick the board. Sometimes it doesn’t even flash the BIOS, only looks like it does.
The issues you may see will appear later, when trying to do other things with BIOS updates, mods, flashes etc.

Soudns like you erased your MAC, usually that is on a sticker on the board, you can fix this by flashing with FPT or with AFU too, depending on where in BIOS the MAC is located
Yes, that will work in some instanced (the AFUDOS /M macaddress) However, in order for any edit to the MAC address to work you have to use the correct original MAC Address, you can’t get a “New” or “Random” one, it must be original or it wont work no matter how you put it in there.
This, is one of the lesser reasons I suggest against using AFUDOS /GAN, aside from it being made for BIOS decade older than current generation BIOS, and 2-3 BIOS series/types older than current.

So I tried your method last night and indeed it worked but just like with afudos, both system IUD and motherboard serial number was erased. I used amidmied and returned the info, after all seemed fine. Is there some reason why /R option cannot be used to preserve smbios info?
I have done 2 out of 20 motherboards where I needed to fix uUiD and serial number, I’d like not to have to redo on the rest.