AMD and Nvidia GOP update (No requests, DIY)

It may be the author’s negligence, or it may be that the unpublished specifications are not followed in the subsequent secondary development, or the data structure and parameter definitions have changed. Anyway, GOPUpdate doesn’t handle this.


Thanks, so last question, for a noob like me, it’s better to stay on previous GOP version and wait for a new correct version? For me it’s very difficult to modify this GOP files ahead of GOP update tool

The wait is long, if you need, send me your original firmware and I can do it for you.


Hello all,

I have a RX 480 and i want to update the GOP.
Firstly I want to ask what is the difference between a “Magic GOP” and a normal one?

Secondly i see the latest magic GOP is from AMD and Nvidia GOP update (No requests, DIY) - #834 by hellm
(origin is from here i guess, 3rd post on the bottom: [BIOS Mod] RX480 -> RX580 Conversions + How-to RX470/RX480 -> RX570/RX580 | )

but the latest GOP available is
can we maybe do some magic with that one also?

Hi there,

could someone help me out with a Quadro P2200. It looks like the GOP file is not present in the DB :wink:

Here’s the message from GOPupd:

***                Extracting with Python...                ***

Nvidia GOP 0x30010  Variant 0x0000000000000007 = GP1xx

Dated: Jan 28 2019  Changelist 25681180

Most likely signed by: Microsoft Corporation UEFI CA 2011

Machine Code   = x64

Checksum CRC32 = E72436FC

Note: The GOP file is not present in my database.

Rom file is uploaded here

thanks. cheers

Download latest tool version: GOP_Updater - pCloud

Latest available GOP is 0x30013
(GP1xx - 0x30013 - May 22 2020 - 28441822 - CDDB7BDF)

1 Like

Hello all,

I have an ASUS TURBO GTX 1080ti. I am trying to patch the GOP to work with DP 1.3/1.4 for my new display (to do 4K@120Hz). I initially tried to use the NVIDIA firmware displayport tool, but it errors out. I get an error: “The GPU firmware could not be updated” with no error code. I am on latest driver and bios of the card to my knolwedge, I have tried rebooting. This patcher does not work. BIOS: [UEFI]. Driver: (GeForce 526.98). GOP: 30006. I am dual-booting Windows 11/Ubuntu (UEFI). Tool downloaded from NVIDIA Graphics Firmware Update Tool for DisplayPort 1.3 and 1.4 Displays for Windows 11.

I then tried to do it manually following: Display Port GOP Updater Guide: Fix blanking screens and improve monitor compatibility | guru3D Forums

The tool exited succesfully, and then when I dumped my BIOS using GPU-Z and put it into GOPupd it says GOP is up to date. However DP 1.3/1.4 still doesn’t work and my mobo bios says the card GOP is still the older version 30006.

Mobo readout: imgur .com/a/A9gAVH6 (I can’t put more links)

The NVidia tool is only valid when it finds that your GPU hasn’t the fix in the vbios original from the card vendor, if your Asus card already has it implemented by ASUS the FW fix in their vbios released vbios with the shipped card, the tool will report it as not needed.
Share your untouched vbios if you want and share a screen of the motherboard identifying the gop.
I have successfully updated the GOP with this tool on many GP10x, as well on my GP106 (With current 30013 fw)

Now… i really dont know what code is inside the NVidia tool that we can relate it to this utility here and i doubt it that its gop fw related…or at least this specific part because:
I can say that, in my case, my card never needed this back from its original vbios and 2 more updated ones that i flashed plus all the gop fw revisons i updated with this tool and still doesnt need it.

My motherboard doesnt post the GOP, only reports the card model, but im running a PURE UEFI system environment, i believe, if not mistaken that you cant use the tool in Legacy/CSM mode.

Running the tool in root drive as adm:
Captura de ecrã_20221120_002716
Captura de ecrã_20221120_002739

Also this could be a typo in stored NVRAM on the motherboard, a cold reset usually does the job

It did not have the patch applied since DP 1.4 did not and still does not work. I did share a picture of the mobo, I do not have the untouched vbios anymore.

I am running a pure UEFI system as well. My understanding is that the tool patches the GOP to enable DP. I don’t have easy enough acess to my MOBO to use CMOS pin but could try it eventually…

“My understanding is that the tool patches the GOP to enable DP” …not following you here, dont we have DP signal out, we do dont we… my understanding is that the tool/patch (NVidia) corrects newer than DP 1.2 revisions only, implemented in cards and monitors as well, in the UEFI portion of the vbios but where exactly i do not know, in the image code itself OR in GOP revision FW… really dont know, thats why i shared my card example with you…
A cold reset: CMOS battery off, PSU unplugged from wall, draining the system 10 to 30m off.
I saw your screen cap after i posted.

Your Asus 1080ti card is native DP1.4 and HDMI 2.0b… just like my MSI 1060.

EDIT: Presumably you have a good cable 1.4 Bi-directional? Because the card is 1.4… assuming your display is also. Im almost sure that the GOP updater has done is job…im going to assume that the GPU post driver is reading it wrong or from another part of the code in the Asus rom. Other than this i can only see trying other 1080ti ROMs moded to the same DEV ID.

Or before getting into new flashs, if possible some tests with internal iGPU is available or another GPU, just testing display/cable outside of the 1080ti issue.

EDIT: Can we know what is the exact model of your monitor? What is the mobo model, cpu model and what other GPU model do you say that you have as spare?
Is this Asus GTX1080 ti a used mining card?

Did a CMOS reset, reads the same GOP. We do have DP signal out, but not over DP 1.4 it seems (i.e. when I set display to DP 1.4 I don’t get boot logo, and can’t do 4K120Hz, system resets to 60Hz).

I made the following modifications, which may not work but you can try:

· Use raw GOP header information
· Modified the device GOP representation information

1 Like

I am indeed using a DP 1.4 cable which came with my monitor. I do have acess to an iGPU or second GPU.

When I flashed my card with the ROM given by wudimobile my mobo did update it’s reading to “Please select a valid GPU” (even before/after CMOS reset). Windows now doesn’t even let me set the refresh rate to 60Hz and doesn’t detect that my display has HDR for example.

I am flashing back to ROM download from TechpowerUp modified with GOPupd.

Flashing back mobo again reads 30006. I did notice the warnings GOPupd gave when updating GOP of downloaded ROM. Had these the first time too.

Sorry I forgot to fix the checksum, please try again. (156.4 KB)

1 Like

That flashed. Same behaviour as using GOPupd, clear CMOS mobo still reads GOP 30006.


When uploading GOP to vbios GPU Radeon WX 4100 (0x1002 0x67E3) I received the following information:

Therefore, do I have to do something additional, is everything ok and can you go ahead and blend the topic?

Baffin[WX4100] (229.6 KB)

AMD GOP has two different versions
Which file is the latest version?

AMD GOP (88.2 KB)

Vega??? What i see is RX5700 vbios image and the 2nd vbios image an unidentified 0210-1F73 Vendor/Device ID, the GOP Driver is the same and nothing to do with the offsets of the vbios EFI images as it seems that it maybe not from same family of devices.
But you can wait for Ruin…

My Vega Frontier Edition vBIOS
Updated GOP version to with mod v0.4.8
But I use v0.5.2 version to open vBIOS file
Display “Note: The GOP file is not present in my database, You can help me by reporting it.”