ASUS All In One: Intel ME Firmware needs to be Repaired

Hello. I have this error while I start my pc everytime, saying "Error sending End of Post message to ME: HECI disabled, proceeding with boot. " it has another one, saying something about being unable to upload something, but I’m not sure, I can’t never catch it.

Then, after it, the sytems boots as always. But everytime I start it, it shows it. I tried to re-install the BIOS as some suggest, but nothing happened. I dont know if I should install an old version? I just don’t know if this is necessary, cause the BIOS was never updated since 2016.

I have an ASUS All-In-One from the 2017. Windows home 10.

I wanna know if my motherboard is just gonna die, or is there any kind of solution.


I used a CSME System Tools v11 from Intel Management Engine: Drivers, Firmware & System Tools and runed to see the info, but it tells me this error: Error

86: Communication error between application and Intel(R) ME module (FWU client)

Error 81: Internal error (Could not determine FW features information)

I also tried to re-install MEI driver but, it tells me there is an error and it can’t do it.
People also have told me to change the battery of the motherboard.
I really don’t know what to do.

Thank you for your time.

Edit by Fernando: Thread title shortened

Usually ME Cleaner/Disable tools do this… have you used any related to?
If bios shows ME then the ME FW is corrupted.
In both cases the error you got is correct, no driver or bios update will fix it.

If it shows then it needs repair

Last resource, full SPI programing by CH341A or similar programmer.

1 Like

Hello! Thank you so much for you answer.

To be fair, I never do any of that, and the message just appeared 4 days ago, without me doing anything with any driver, so I’m afraid I don’t know how it happened.

But yes, I just checked and its corrupted. It shows all 0.

I will try to repair it and come back after I’ve done it, hopefully with good news. THANK U SO MUCH!

That’s the original guide for cleaning / reinitializing the Intel ME properly:

(MeatWar gave you the link already but linked to the last post, the guide is in the first two posts, normally no need to read more)

The needed ME firmware you might find here:

Intel ME tools you found already, the latest ME firmware can be found in the same thread, first post. (The mega area with latest versions is updated!):

Feel free to post your possibly fixed firmware image if you want someone to have a look into it! (Unclear which version or type your machine are!)

1 Like

Hello! Im trying to do this to repair my IMEI driver that its corrupted. Now, I finally got the ME Analizer working, but when I open it, says File: None.

Why is this happening? Am I doing something wrong?

I desesperately need help, bc I really wanna solve this problem alredy. Thank you for reading me.

The guide/tools ARE NOT to repair any DRIVER, it is forum user helper tools for re-initialization of a system Intel ME Firmware, part of the whole BIOS/EFI firmware of a system.

Read the guides and learn the tools before posting, rushing takes you no where faster in this forum because this is a user own operation to deal with it.

Hello again. Okay, forgive me, but I posted here about this and this is where they sent me. I’m sorry if I did something wrong, but this is the post where they sent me. I’ll leave you the link just for you to see.

Thank u anyway.

I’ll try to explain mysefl again, cause I think I said it incorrectly. My ME Firmware appears on the BIOS as

I was directed here, to repair it, as I understood, using the tools here. That I did, using the ME Analizer to see the versions, but as I said, it appears as File: None.

That’s why I’m asking for help. I’m sorry if Im disturbing or anything at all.

Well… with all this here, already answered to you and still no clue how to proceed, then i advise you to leave this to a repair shop or a friend that can help you with the guides and procedures.

Some procedures/repairs/mods here present n this forum requires basic/bit advanced knowledge of some technologies/tools used.

Thats it, we point the correct way to users and they do their part and follow procedures/tools, with a very high rate of success.

You’re sent to the other thread, NOT to post the same issue, but to follow the guide.

Nothing more to add and do NOT make new threads about the same issue.

Excuse me now, but I didn’t post the same issue.

I’m asking, bc Im using the ME Analizer and its not working, error which I alredy adressed twice. How can I procced with the guide, if the first step its not working for me?

Guide is telling me to use ME ANALIZER to know which are the files I need to this Firmaware in particular. I did that, and this is what it shows to me.

I’m completely able to follow a guide, I’m asking for advice/help bc I stumble into this problem. And I have no one else to ask, thats the reason I’m here.

platomav/MEAnalyzer: Intel Engine & Graphics Firmware Analysis Tool (

B. How to use ME Analyzer

1 Like

One more ‘Enter’ would’ve given you the complete syntax (might look a little different if working with python version):

Again: It might be easier to help you if we’d know what machine precisely you’re working on and where on the guide you’re getting difficulties…

1 Like

Hello! Thank you for your answer.

First, I will adress my machine so maybe it will be easier:

Asus All in One ZN220IC

Windows 10 Home x64
Firmware version 0208
Intel-core I5-6200u CPU @2.30 GHZ
Intel HD Graphics 520
Nvidia Gforce 930MX
8 ram
Hard Disk Toshiba 1TB

I hope thats the correct information and I’m not messing it up again.

To the second point, is that I kept reading, and the thing I don’t know how to do is to get the Dump image (the bin file) of the BIOS. As I understood, by reading every single word in the guide, and outisde of this forum/page, It seems that I have to do it externally (? Or that its dangerous cause I could lock something in the bios/firmaware.

That’s what I got from all my reading.

Thank you again for your time.

Did you find your Intel ME main version?

Did you try the corresponding Flash Programming Tool (fpt) from Intel CSME tools (can be found here) to dump your firmware?

Yes, I did tried the Flash Programming Tool, but everytime I try to write or paste the Comand to dump it, its says this:

Error 365: Invalid parameter value specified by user. Use -? option to see help.

Even when I use de -? it does exactly the same.

Well, with the information you provided one just can say that you most probably did something wrong.

A screenshot with the command windows where one could see both the typed command and the output of the program might be helpful here, maybe?

Hi, I’m an amateur on this topic, but If you could post your:
-CSME tool version
-ME version
-and the command that give you the error
than it would be easier to track down the problem.


Based on the bios .CAP for ZN220IC you should have something like this:

║         ME Analyzer v1.307.0 r346         ║

║           ZN220IC-KAS0501.CAP (1/1)           ║
║             Family            │     CSE ME    ║
║            Version            │  ║
║            Release            │   Production  ║
║              Type             │   Extracted   ║
║              SKU              │  Consumer LP  ║
║            Chipset            │  SPT/KBP-LP C ║
║  TCB Security Version Number  │       1       ║
║     Version Control Number    │      118      ║
║        Production Ready       │      Yes      ║
║     Power Down Mitigation     │       No      ║
║      Workstation Support      │       No      ║
║       OEM Configuration       │       No      ║
║              Date             │   2016-09-08  ║
║       File System State       │   Configured  ║
║              Size             │    0x1BF000   ║
║        Flash Image Tool       │  ║