Asus G751GT 213 bios NVME modification.

Hi all, making this thread as per requested by @Lost_N_BIOS to try something out.

I’m hoping to enable nvme support on the m.2 port on my laptop, however this isn’t for use with a boot drive but rather I want to try a riser/extender and see if an external GPU will work. From what I found searching, people seem to think there are four pci express lanes dedicated to this port. Not sure how much it will affect performance but it should, if it works, give me a nice performance bump for relatively cheap.

My machine is updated to bios version 213, and once lost replies here with the instructions I’ll dump the bios. I read some writeups on the procedure, but this is something fairly risky and I’ve never poked around at a bios before.

If you are not going to boot from this device, you do not need BIOS modification. NVME BIOS Mod is only required if you plan to boot system from the device.

Ah, so from what I understood the m.2 port on this device runs SATA natively, and the nvme modification to the bios enables PCI-E lanes on the port.

Perhaps I was mistaken, or maybe the laptop shipped with some m.2 drives which were sata but people upgraded to nvme based ones.

Basically I want to use this adapter toe an egpu on this port.

Sounds like I need to look into this further, maybe I got confused vs what the shipped ssd was vs the actual port’s capabilities, though if there are pcie lanes mapped to this port, and it’s not just running sata, it seems even stranger to me that nobody has tried this yet.

The adapter already was ordered so I’ll be able to test in ~a month.

NVME Mod is only for booting to the NVME device, PCIE Lanes on whatever port are already laid out in the BIOS/ME FW by default
Yes, I would assume your second line there, and then they would NVME Mod BIOS because they’d want to boot to those devices

Well, this was one good day and one really shit day.

Basically, I got the adapter in and my old 660 oc actually worked and I got really excited, and got my hopes up.

Picked up a 2060 super today though and a new power supply, and it’s just dead. The 660 works fine, but the 2060 shows bad gpu artifacts on the laptop display and nothing if I hook a display up to the external gpu.

I don’t know if it’s because of different architectures that the 2060 doesn’t like the 970m in there, or or if it’s because it’s only four lanes, idk. The 2060 fans only come on with the laptop while the 660 ones are always on, but slow down with the laptop on. Maybe the 2060 is trying to draw power from the laptop as well and not just the floppy connector on the riser.

Idk, this just sucks, would have at least liked to see if it had a bottleneck or how bad it would be. I could have used a win :confused:


@Lost_N_BIOS I just saw a post where someone used an expresscard adapter and the bios couldn’t handle it, so they had to hot plug it. Do you think it’s possible to enable hot plugging in the bios with a modification for this port? I don’t want to just try it and risk damaging something.

edit: Huh, looking at this… maybe it does support hot plug. I need to get the 660 in there again and check to confirm it’s on this bus. Unfortunately, the wireless card port is only a 1x link so that rules that out.

@XOIIO - Sorry, I’m lost with all those model numbers, I assume you are talking 2-3 different graphics cards, in a laptop? If yes, you can’t simply switch out models like that, without modifying the BIOS and inserting a properly configured (For this laptop model) vBIOS for the card.
And yes, some architecture isn’t always going to be compatible with the chipset and or other BIOS modules (mainly Intel’s vBIOS it all routes through as it goes out to the displays)
All those cards may work, if you update their vBIOS (on board if they have) and in BIOS if you can find one from same exact model laptop. I’d also update the GOP module of the vBIOS themselves to latest version too for best chances of success.
I know only a little on this, so I can’t help too much with that, but I can update GOP in vBIOS and or swap vBIOS into/out of BIOS if you need

Hot plug is always a risk with this kind of connection, even when hot plug is allowed and enabled. But yes, it can possibly be enabled, and or BIOS unlocked so you can enable/disable for all ports as you wish
It’s already enabled on PCI Express Root Port 1, disabled on PCI Express Root Port 3/4/5


If you want me to enable for all slots, you’ll have to do the following so I can get you mod BIOS and tell you what you need to do if anything before you can flash it

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Sorry about that, yes the 660 and the 2060 are what I’m currently testing with. The 660 works without issue, but the 2060 does not, maybe due to a chipset issue.

I checked with my 660 installed, and it turns out that it’s a different pci bus that it’s on, and that one does not support hot plug, as you can see here:

So I think that you could just make this single section hot plug? I don’t know if that will improve my chances of success much. I wonder if there is a way to check if a mainboard chipset is compatible with specific gpu architecture.

Here is the ME info from hwinfo, faster right now than rebooting, in case the hot fix matters.

Looks like the bios dump worked, in case there’s any relevant info this is the command prompt window:

and lastly, the link to my biosreg.bin

I’d greatly appreciate you unlocking hot plug on the needed ports, but maybe not all of them in case it could cause issues.!uFEmnAxR!7I1Y3ypkwwB_c…BB5u64ZqaJ59kSo


Checking section 5 here, there’s mention of PCI whitelisting in the bios causing issues:…ility-problems/

Now, not sure why the 660 would pass the whitelist but not the 2060, if there is one, but perhaps you can tell if there is some sort of whitelist situation going on in there?

Those series are VERY different, I think you’d have plenty of luck with same chipset type cards as 660 whatever that is, such as 680 or 695 etc.
Sorry, just random model names as example there, big difference between the graphics chipset of 6xx and 2xxx is my main point, so yes, may not be compatible at all with the BIOS or chipset, even with a modified vBIOS on the card.

I can make them all hotplug enabled as I mentioned, to avoid hassles and re-edits, I would do them all at once.

Sorry, I don’t know anything about graphics compatibility, only I’d never expect you can do what you are trying to do, you need a vBIOS from this card ran on this same system, from the manufacturer, just for starters.

Yes, BIOS dump always works, what’s important here is for you to do the rest of what I said and then let me know what error you get if any, then we can proceed.

No whitelist for this kind of thing, all the incompatibilities I mentioned above is the issue with what you are trying to do.
You need card from same graphics family/architecture at the very least, unless this card was originally sold with your exact laptop model in some configurations, if it was then you need a vBIOS dump from one of the cards on that system

Ok, enabling hotplug for all probably will be fine.

Looking at the specs now the 1080 I was looking at is an oc one, and has a decent core speed bump, and the 1080 is probably closer to the 970 though they are different, maxwell vs pascal (and turing for the 20 series). The gtx 660 is an older architecture, so maybe they are backwards compatible on the motherboard side.

I didn’t get any errors with my bios dump, that mega link is to my bin file, for some reason I can’t upload it here, it fails and gives me an error in german.


@Lost_N_BIOS if that download doesn’t work for some reason I can shoot you a pm to trade emails or if there’s another site you like to use I can try that.

Anyhow, time to get some rest. My mind won’t shut off, but there’s nothing I can do so meh.

edit that nvme modification wouldn’t enable gen 3 on that slot as well, would it? I still don’t know for sure if it is stuck at gen 2 or not.

@XOIIO - That is what I’m talking about, Maxwell, Pascal, Turing, you can’t just drop these all into this system and it will work. Only same ones this system originally could be configured/sold with, otherwise major BIOS edits to the vBIOS on card and internal vBIOS would be required, if that would even work/be possible etc.

What I meant about BIOS dump, after command to dump the BIOS I gave you another command to write it back immediately after you dump it. Did you do that yet? If not, do that now, and if any error show me.
We need to do this, in case I need to help you unlock BIOS or SMI lock before you can flash in mod BIOS (Looks like both are enabled, but I can’t tell for sure if that is how it’s set in your BIOS until you test, you should get error 280 or 360)

Gen3 is a PCIE setting, I will look at BIOS when I modify it for you and see if your BIOS has these settings. If it does, do you want all set to Gen3? You can check speeds/gen etc with CrystalDiskInfo, or maybe even HWINFO64 (not sure)
Yes, your BIOS has controls for this for PEG port 0, 1, 2, all set to Auto by default. I think I will just unlock BIOS menu for you, then you can play around with whatever settings you want!
Don’t disable graphics or try to switch main graphics though, unless you have flash programmer in hand and backup already made and confirmed OK, otherwise you can end up with black screen (no display output) and only way to recover is blind flash or flash programmer.

Yes, MEGA is an issue for me almost always, but I finally got the file after a long fight

Also, please link me to the BIOS page you download from at Asus, I can only find G751JT or JY and zero results for G751GT search at Asus
Oddly, your BIOS shows as JT, and the BIOS download from Asus JT site shows as JY. Not a big deal, I’m editing your dump anyway so BIOS will only be that version, but it is strange!

Please show me an image of your BIOS main page, scroll down to bottom, i need to see what it shows for “Access Level” if that is visible to you.

@Lost_N_BIOS Ah, I completely missed that second command, I tried it and I did get error 280 about failing to disable the bios write protection.

Also, I made a typo, I do in fact have the G751JT, not a GT. The G751JY has a 980m and a different cpu as well, here is a link to the page for bios version 213 for the G751JT…/HelpDesk_BIOS/

If you can enable pci gen 3 that would be awesome as well, and help a lot with the performance bottleneck.

I recall seeing something about nvidia disabling gpus if the hot swap option isn’t enabled but that’s a driver error 42 usually, and not sure how the bios would be locked out by that. Does seem odd that I’m just getting graphical artifacts though.

I think on monday I’ll return the 2060, maybe have them test it in case I managed to get a bad one, and order the refurbished 1080, and failing that test the 980 ti locally.

I was also wondering, what tools do you use to do this? I have no intention of modifying a functional bios and trying to use it, but I’m super curious to see how it’s actually done and how the information and settings are presented.

@XOIIO - Thanks for the BIOS/model info and link.

About error 280, and 368 you would get if you removed 280 only, we need to do this first so you can flash mod BIOS.
I made a guide for this, here, you can start at step #6 since I’ve gathered the info for you below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename your .efi file to >> Shellx64.efi

SMI Lock >> 0xA2
BIOS Lock >> 0xA3

So, once at grub prompt you will type the following to disable these locks, one line at a time, enter between each
setup_var 0xA2 0x0
setup_var 0xA3 0x0

Then boot into windows, dump the BIOS region again with FPT (And send me this if next flash successful), then write it back with FPT and it should succeed without error.
If there is still error, show me the command entered and error on image, and do not send me new dump yet

Yes, YOU will be able to set Gen3 once I am done unlocking BIOS for you
Now, that depends on if CPU can do Gen3, and chipset is ready for this too, but now I think it’s mainly CPU thing.

Graphic artifacts usually GOP or vBIOS issue, try an older or newer version of both of those. Or yes, it could just be a bad/semi-faulty sample too.

BIOS unlock/editing like this, or simply looking at your possible settings can be done many ways, using UEFITool and extract setup module, then output a textual IFR file (This can be edited via hex, not the test IFR but the module you extract that from).
Or BIOS settings can be inspected or changed in another module with AMIBCP which has a GUI and BIOS-like layout structure. Making actual changes is done several ways, sometimes with combo of all the above and hex edits.
Here is example of one of the Gen3 settings area in setup’s extracted IFR output and in AMIBCP


So, I got error 280 again, my bios didn’t have anything specific for secure boot keys, or an option to clear then but has four different sections, they were all empty except for one that I deleted, then disabled secure boot.

I did get these errors from grub when setting the variables though.

I did have to name the efi file I downloaded to shell.efi and not shellx64, as that wouldn’t boot.

Tried it again with a new copy of the efi file, and named it Shellx64.efi and it booted this time. I got those same errors, but now when I dump and flash the bios with fptw it seems to work.

I think we’re good to go. Here is the new bios dump.!SAVCEYZS!QtZJ2NC9ApJcl…0XvOvi4UWnCvjm0

@Lost_N_BIOS derp, forgot to tag you.

@Lost_N_BIOS GTX 1080 came in today, unfortunately exact same symptoms. Sadly didn’t get lucky.

My only other theory is that if the custom bios doesn’t work it’s maybe trying to draw too much power from the slot, idk if the newer gpus have power pins aside from the first finger, that plugs in with the floppy drive connector to the psu.

If the custom bios doesn’t work I guess I’ll probably try with a desktop, wanted to get back into desktop gaming with a nice custom water cooled build or something but a 1080 for $530 is a good deal even though it’s a refurb. Kinda hard to resist.

Going to be a pain when I’m missing files or something from my laptop and whatnot since I’ll still probably use that most of the time, if I have to get a desktop setup.