ASUS P7P55D-E PRO BIOS update problem


So, I found a modified BIOS on the forum, flashed it and now it seems the Marvell controller doesn’t work.
I have attached the zip with the BIOS.
This is the description that was in the BIOS text.

Intel Rapid Storage Technology
Modded: (TRIM mod by CPL0)

JMicron RAID Controller
Original: 1.07.13
Modded: 1.08.01

Realtek PXE Boot
Original: 2.29
Modded: 2.64

Marvell Edition
Marvell AHCI Controller
- Bootloader: unknown
- Firmware: unknown
- Bootloader:
- Firmware:

Connected a hard drive to the Grey Marvell SATA ports, the system does not detect the hard drive.

Please can someone assist or advise?

Thanks (2.2 MB)

@rylan74 - Marvell ports on these boards are terrible, why do you want to use them anyway? Do you have Intel RAID enabled, or not? This is known issue with certain orom updates (Sometiems), you may need to use an older/smaller one, if you really need to use the Marvell ports.
Or, this could also be due to an incorrectly inserted Marvell rom, if they didn’t put in the correct code for your DeviceID (9123 or 9120 etc), but it’s more likely the above is the issue - commonly affected/noticed on X58 when people insert too new/large of orom for Intel there same happens.

Or, it’s also possible that the Intel rom used is OK, but modified with an older method that can also cause this, you’d have to test with the same orom modified the new way and see if the issue persists or not.
This is discussed Here and Here in this thread too

If you need it done, I can make you BIOS with different Intel orom, or try to properly update the Marvell one again for you. If you want the latter, look at the chip on your board and tell me it’s actual ID.

Please link the thread where you found the BIOS, so I can ask the creator if he updated the device ID and which ID he put, so I don’t have to dig around myself if it’s already correct ID for your device then we know the Intel rom version is the issue
And, so I can ask him which Intel rom exactly he used (old TRIM mod method, or new one)

@Lost_N_BIOS - Thanks for your reply.
I am actually not using on-board RAID configurations.

I am using Stablebit Drivepool to pool the data drives into 1, and snapRAID for parity.
I have the following storage setup:

Intel Controller: (AHCI with Universal Intel RST Drivers+Software Set v11.2.0.1006 mod+signed by Fernando)
1x SAMSUNG 250GB SSD 860 EVO - Windows 10 Pro OS

JMicron Controller: (JMB36x/37x Drivers Version
1x Kingston 64GB SSD - Cache Drive (to be replaced soon)

Marvell Drivers - Marvell 91xx-92xx AHCI & RAID Drivers v1.2.0.1049 WHQL for Win10
I want to use the Marvell controller SATA port to add another hard drive.

I just figured that, to update the BIOS with newer version would have some sort of performance/ stability improvements…

This is the thread I found the BIOS in:
ASUS P7P55D-E PRO – Intel P55 Chipset, Windows 10 clean install GUI/Driver question

I flashed the BIOS without the Marvell update and it is working now, it was downgraded back to, Marvell - OROM:
I’m not sure if there would be any other benefits to try and update the Marvell controller again…


If you are not using onboard RAID at all, then no need to update Intel RAID rom, except maybe for TRIM pass-through but for that you can possibly use same exact version stock BIOS has (Unless we find Intel rom isn’t causing all this, then it don’t matter and you can update it anyway).
On the Marvell, you can try the standard FW update package to update it, but that may fail too. Once I have more time tonight I will rip apart that mod BIOS and see if it was updated properly for your board, but I need to know the ID of the Marvell chip (or device ID from device manager)

Updating to latest BIOS is always good in my opinion, unless there is known issues with some BIOS. I’ll check the mod and Marvell again once you get me your Chip ID off the chip and or device manager device ID for that controller.
I’ll also check that Intel rom in the mod, I should be able to tell if it’s using current method or the older method for TRIM mod, if it’s the older one that may be only reason the Marvell issue popped up on you.

@Lost_N_BIOS - Thanks for your help.
I cannot seem to find the standard FW update package for Marvell 9123. I have checked on, those don’t look compatible with 9123.

Please see attached images for device ID’s according to AIDA64.







@rylan74 - Thanks, all I needed to see was Marvell DeviceID - but also, please show an image of the chip, or inspect yourself and verify it’s 9123 and not 9128.
Due to see last post on this thread, device manager shows him 9123, but actual chip is 9128 - [Discussion] Marvell 91xx/92xx SATA3 Controller BIOS modules
See also, page #2 - post #27, this is what I meant, about certain Intel RST roms can cause issues with Marvell even if it’s working correctly otherwise (new or old Marvell FW)

Also, please show me the Marvell Controller in device manager, where I can see it similar to how it shows in AIDA64 image, but select the hardware ID’s tab

Keep in mind, during any of these processes (BIOS Update, or direct Marvell flash), remove all hard drives from the Marvell controller, and make sure it’s the Marvell one not J.Micron one (Or remove all from both if you aren’t 100% Sure)

I checked that mod BIOS you linked, and it has incorrect ID’s for your controller in the “BootLoader Module = ID E6” is has 9120 instead of 9123, so this may be all or some of the issue. Same issue for the actual “Rom Module = ID 20” has 9120 instead of 9123
So, per the guide/info here, this is incorrectly done Marvell mod for this board - AHCI & RAID ROM Modules
Doing it correctly may fix the Marvell issues, if not then you may need to go back to 10.xx Intel RST modules. These errors were probably done due to the stock BIOS modules not being properly setup either
Stock ROM has 9120 too, and not correctly set at all in the E6 module), so user doing the mod probably went off what was there for stock on the rom and then carried that into the E6 module to correct it based on what the other one had for stock

Give me an image of your controller chip, I will make you proper mod and then we can see if it’s a Marell issue due to these errors, or a Marvell/RST issue - he even had issues with Marvell due to this, thus provided his Non-Marvell update in same package knowing the Marvell one didn’t work


I have checked the chip on the board it is 9123. Windows device manager shows HW ID is also 9123.

See attached images.



Attached zip file is original BIOS ROM from ASUS website. (1.05 MB)

Are you sure that says 9123 on the chip itself? I can’t tell, the image is too edited, hard to tell is 3 or 0
I already have original BIOS, as mentioned previously the original BIOS has some of this info all setup incorrectly as well (9120 instead of 9123, missing in other locations entirely)
I’ll try to do this for you tonight, maybe in an hour or two I will have time (heading out shortly for a little bit, but will be back)

Yes, I am sure it is 9123.

I will do the following

Realtek LAN PXE Boot rom 2.29 >> Update to >> 2.66
J.Micron v1.07.13 >> Update to >> 1.08.01 or 1.07.28

See this post about J.Micron and 1.08.01 vs 1.07.28 and let me know which you want, I will be building from stock BIOS
[Guide] AMI (non-UEFI) BIOS Modding (2)
And - [Guide] AMI (non-UEFI) BIOS Modding (2)
And - AHCI & RAID ROM Modules (30)

Marvell same as other, except I will set 9123 instead of 9120
- Bootloader:
- Firmware:

Also, did you already try this Marvell FW installer (First one on top left), run Go.Bat and type go (If asked, choose 9123 not 9120)…014229B9E752333


I have not tried it yet, I will try it and see it works.

Just to confirm…

I am currently using 10.8.01 as per the previously modified BIOS.
From the links you shared regarding the versions, I gather that the 1.08.01 was a test version that was pulled by JMicron, and 1.07.28 was last official release. I have tested a (AHCI) Hard drive and SSD with CrystalDisk mark and performance was bad.
Perhaps I should try with 1.07.28 and see if it makes a difference in performance.

Intel RST:
Currently using (AHCI); Modded: (TRIM mod by CPL0) as per the previously modified BIOS.
Will the Intel Rapid Storage Technology ROM be stock version from ASUS original BIOS? Original:
If so, will the Universal Intel RST Drivers+Software Set v11.2.0.1006 mod+signed by Fernando be compatible with the Original:

Update as you said, 9123 to
- Bootloader:
- Firmware:

I have tried to run the Marvell FW installer, the program just flashes black screen…

j.micron is never good for performance, it should only be used for storage where speed doesn’t matter much.
I was reading here, you can edit it and lock it to a certain function, but that really isn’t going to help much as you can already set AHCI instead of IDE -…comment-page-1/

Sorry, I forgot to add that in the notes, yes I will put same RST

I just tried to run go.bat on my end too, and I get CMD window, with popup error telling me it can’t be ran on x64 OS, and then I noticed this is probably DOS Package.
Try running it from DOS Bootable USB, they should put that in the readme!

Okay, I ran the update in DOS and it said update successful, when it rebooted and completed it still shows, not It did not ask for a model number.

Regarding the J.Micron controller, I will use it for storage drive.
But if it is not too much trouble to ask, if you can compile 2 BIOS versions please?; 1 with 1.08.01 and 1 with 1.07.28 to test.
I saw one post where it was noted that 1.07.28 had better performance than 1.08.01…

@rylan74 - OK, maybe “go” only updates one or the other of these (additional options) from the go.bat file -
echo type ‘go -a’ Flash only autoload
echo type ‘go -b’ Flash only BIOS on MAGNI
echo type ‘go -x’ Flash only Firmware on MAGNI

So, do go -a and reboot, then do go -b and reboot, then do go -x and reboot (This makes more sense, due to there being three parts and I can’t see exactly what “Go” alone does except invoking mvf_Mag via MVM.bat)
Then check all details in the Marvell web based RAID tool or Marvell Driver app thing in windows (Check both of those first too, so you know before/after)

Also, that package contains (but this is good to check and see if this method can update the three parts or not, if not we’ll do in BIOS)

Yes, I’ll make you two BIOS with different J.Micron’s


I have checked on Marvell RAID Utility, it does not detect the device.
I have installed this mrvl_utl_msu_4.1.10.2046_windows_x86-64 found on
I tried MarvellCLI Utility and it shows No Adapter Found.
Which Marvell Driver app are you referring to? I cannot find it.
I cannot check the detailed version numbers.

It may only be for Marvell 9128 boards, sorry for any confusion, what I meant is usually posted on the motherboard driver/utility download pages. Sometimes that may only look like a “driver” package, I’ll check your boards download page.
I don’t see it, but I do remember the name now Marvell Storage Utility, it’s like Intel’s RST software, shows you info and can build RAID on 9128 I know because I’ve used it there, but unsure if it’s for or compatible with 9123
Yes, here from your boards page, it has a console in one of the folders -…

Did you try the DOS package again, using the three commands I showed? Or were you wanting to check before/after as I mentioned?
I guess that may not be possible if there is not a utility for 9123, and there may not be since the one I was thinking of was for RAID/9128, not sure if 9123 can even do RAID

I think I have a P7P55D-E (No PRO) here I can setup and figure this all out on my end if you want, at least that way I can figure out the BIOS before I send it to you

I know with the DOS FW update tool you were using and MVF_Mag inside there, you can dump the current FW to file, and maybe w/ -v (verbose) it will show you info
But I’ll have to figure out how to dump the chips FW on my end because the stock BIOS only has complete orom (not the other two parts Bootloader/FW, they are partial in the stock BIOS)
Go.bat can be used in that way too, but I don’t think it will fully show what we want to check (I think it’s for checking info on the input file
go -v Show verbose message
go -r Read back binary file, no flashing

* Edit - ahh yes, this post shows what I was thinking, user read back info from the onboard chip using Go.bat -v -r
[Discussion] Marvell 91xx/92xx SATA3 Controller BIOS modules

I’ll figure this out on my end, give me some time (Sorry for the delay, but I’d rather get it right than hand you another improperly functioning BIOS)

@Lost_N_BIOS - I have not run the update with the three commands yet, I wanted to see the version info first.

I ran GO.BAT -v -r and it displayed the following info:
Adaptor Info
DevId: 9123 DevFunc: 00 Bus: 09
ClassCode: 0106 RevId: 10 Ver: 00
FlashCount: 01 SubVer: 00

Incoming Image Version is
Incoming Autoload Version is 200060c - CPU_AHCI_9123_NDO
Current Image Version is
Current Autoload Version is 1001802 - PT_AHCI_9123_NO_MATH

I am going to run the DOS update with the 3 commands, will post back later once done.

@Lost_N_BIOS - I’ve run the DOS FW update with the 3 options and it shows update successful but when it boots up it still shows OROM

When I ran go GO.BAT -v -r its displays the same info as before;
Adaptor Info
DevId: 9123 DevFunc: 00 Bus: 09
ClassCode: 0106 RevId: 10 Ver: 00
FlashCount: 01 SubVer: 00
Incoming Image Version is
Incoming Autoload Version is 200060c - CPU_AHCI_9123_NDO
Current Image Version is
Current Autoload Version is 1001802 - PT_AHCI_9123_NO_MATH

It doesn’t seem to work.

Thanks, seems that is only checking the autoload and FW image, not the rom itself. I guess this probably is one of the boards mentioned in the main thread that can only be updated via BIOS mod, I’ll have to see what I can figure out on my end.
Or, if you don’t want to wait, I can go ahead and do the marvell mod by itself, first using 10.8 RST and secondary with 11.2 and you can test if Intel and Marvell work on each or not.

I initially suspected either the Marvell mod is not done correctly (due to his comments and non-Marvell BIOS included as if he already knew or hadn’t tested and didn’t trust), or Intel RST version caused the issues.
But, after reading more about the Marvell mod, seems maybe the Intel RST isn’t such an issue once Marvell is done correctly (and this BIOS all messed up anyway, stock is set for 9120 and so he did mod to 9120 too, surprised both don’t fail)

What I don’t like, and what caused me to pause and dig deep into all this, aside from the stock BIOS having 9120 as an ID in these files, is the stock BIOS E7 module (FW Image) is 3kb, while replacement/update is 200kb
However, this may be due to BIOS only holds small portion and rest was already programmed in chip by Asus, or is larger in BIOS when they update within BIOS at certain BIOS versions.