Asus P7P55D motherboard intel P55 chipset


I’m trying to install Windows 10 onto a RAID 0 disk created with the Intel RAID Utility.
Anyway, when I get to the point Windows setup asks for the RAID driver I always get an error message saying that unsigned driver are bot suitable for this device and setup can’t continue.
I already tried with your modded and signed drivers but still no use.

Could you please advice if there is any solution?

Thanks a lot

@durius :
Welcome to the Win-RAID Forum!

There is no need for you to integrate or load any modded Intel RAID driver, because Win10 has an in-box Intel RAID driver, which supports your P55 Chipset Intel SATA RAID Controller. Once the OS is properly installed onto the freshly created RAID0 array and running fine, you can import the Win-RAID CA Certiuficate and then install the desired mod+signed Intel RAID driver.
At which point of the install asks the Win10 Setup for an Intel RAID driver?

Dieter (alias Fernando)

Hi Fernando

Windows 10 asks for a driver at the point where I have to choose the drive onto which Windows is to be installed.
I cannot get past this point without installing a driver.

Thanks for your help

@durius :
Which version has the Intel RAID Option ROM module, which is within your in-use mainboard BIOS, resp. which version shows the Intel RST RAID Utility?

The utility shows Intel (R) Rapid Storage Technology - Option ROM

@durius :
It is not easy to understand, that the Win10 in-box Intel RAID driver is not used by the OS Setup and that all other Intel RAID drivers are not accepted as well.
Maybe it will help, when you update the Intel RAID ROM module of your BIOS to v12.9.0.2006, flash this modded BIOS and retry the Win10 installation.
If the RAID array should not be detected by the OS Setup, I recommend to loading the Intel RAID driver v12.9.4.1000 WHQL, which is the last one with native support of Intel 5-Series Chipsets.
Please report about your test results.
Good luck!


Thanks once again for your reply
Could you please tell me where can I find the modded BIOS?
Is it available or do I need to make it myself.
Sorry if this seems strange but I’m not very familiar with BIOS modding.

Thank you

If you shouldn’t find an already modded BIOS for your mainboard within >this< Sub-Forum, you will have to do it yourself.
Please read as first step the start post of >this< thread. Depending on the platform of your specific BIOS (either AMI or Phoenix/Award), you can find a detailed guide >here< for AMI BIOSes resp. >here< for Phoenix/Award platform BIOSes.

Some years ago I started as a Newbee as well. I haven’t written all the BIOS modding guides with the intention to do at least everything myself.


Already managed to update the Intel RAID ROM module of BIOS to v12.9.0.2006.
Not so hard to make the modded BIOS if you read a little bit…
All wen t ok.
Anyway when I retry to setup Windows 10 it still asks for the RAID driver and when I point to the folder where the Intel RAID driver v12.9.4.1000 WHQL is it tells me that no suitable driver is found.
Already happened this with previous Intel RAID ROM module of BIOS.
If I try with different drivers it still tells that I must use certified Signed drivers and setup does not continue.

Could I be doing something wrong