[BIOS] Flashing modded bios issue - Motile 14 - M141[BIOS]



Yes the RGB’s I’ll make a light show if it really supports RGB haha and then post picture here

@drmusama - Here is your unlocked BIOS
2x ADV, Chipset, 2x Boot, Switch Exit/Save&Exit + make visible hidden stuff in orig ADV - Anything you still see missing in ADV/Chipset/Boot vs what you see in AMIBCP, show me image of that BIOS page and I will make further edit for you to unlock
http://s000.tinyupload.com/index.php?fil…402845869845753 << new Link/Edit

*** WARNING - To ANYONE with laptop and unlocked BIOS!!!
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

WARNING ** - This BIOS is user specific! If you are not user drmusama at Win-RAID.com forum, DO NOT USE THIS BIOS!!
If you do, and you are not drmusama, then you will loose your serial, UUID, OG NVRAM, and possibly LAN MAC ID as well.
You have been warned!!!


------------------------

@Dorin1996 - looking at your BIOS, this is Intel BIOS, so you don’t have to use flashrom, and it’s better if you don’t anyway, but if you want to we can continue using that, let me know?
Ideal method to dump, edit, and flash your BIOS would be using FPT - method below to get started, unless you want to carry on with flashrom?
And, correct compatible FPT version is already included in your stock BIOS package, so adjust below info and carry on from the stock BIOS package folder instead

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below ).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )


Edit - Actually, never mind, I can just edit stock BIOS and send to you to FPT flash, since stock package flashes entire BIOS directly with FPT anyway, so serial, UUID, MAC ID etc for this system is not stored in BIOS
So, I will check about unlock and get back to your soon! Disregard above, it’s not needed, we can just edit stock and I’ll show you how to flash BIOS region only (it’s above anyway), once I make unlocked BIOS for you
But, for safety reasons, please go ahead and use the stock included FPT and make a complete backup to stick somewhere safe >> FPTw64.exe -d SPI.BIN

Unless you prefer using flashrom/linux? If so, let me know, and if you want to keep using that then I’ll edit your backup, up to you

Edit 2 - @Dorin1996 - Please zip for me one image of each main BIOS page you can currently see. Then also, please show me entire root of Advanced, so I can see what all submenus in there you can see now

*Unnecessary quote removed to save space - Lost_N_BIOS

I already actually flashed it haha… Most things are there just missing under north bridge tab => sub tab “Memory configuration” isn’t there for some reason:

https://i.ibb.co/RcqWCgP/North-Bridge.jpg

I can only see “Socket 0 information” there tab - in AMIBCP shows there is “Memory configuration” tab beneath this one xd Can you mod it so I can see the “Memory configuration” tab as well please?


Edit: See here in “AMBCP” it shows it:

https://i.ibb.co/GV8WKZz/Capture.png

But on the modded bios it isn’t there xD

@drmusama - You should have told me this previously, since I unlocked chipset for you yesterday
Fixing, please wait



Haha I completely forgot… I just checked if there is “Chipset” tab

I’m surprised you didn’t mention, since you were focusing on memory
@drmusama - See original post #22 for new edit unlock



@Lost_N_BIOS I would like to keep using flashrom. Also I will send you a zip with pictures of each BIOS page right away.

Sorry all, but I have to leave shortly, will be back tonight in about 8 hours or so



Yesss worksssssssssss thanks !! haha It seems there is memory overclock options as well!! :smiley: I will check :smiley:

Memory Overclock? Not shown in AMIBCP? If yes, show me, I didn’t dig too deep into setup, so maybe only in setup not visible in AMIBCP

Here are pictures with my BIOS.
http://s000.tinyupload.com/index.php?fil…842611531724646
Please ignore Intel RC ACPI Settings and ACPI Setting form Advanced menu from my pictures. Those two are enabled by me using AMIBCP.

YESSSSSSSSSSSSS IT WORKED HAHA! I overclocked this puppy from 2400MHz CL14 to => 3200 CL 16 HOLY FUCK WHAT A DIFFERENCE IN PERFORMANCE Sorry for the cursing but im so darn happy hahahha

OMG check this out: https://i.ibb.co/vQxxkwv/Capture.png

I cannot actually believe it can run @3200MHz on ZEN + architecture, this is just nuts… haha
Memory throughput went from => 19.2 GB/s to => 26GB/s
FREE PERFORMANCE YESSS TY SO MUCH!!!

P.S. I had to swap out the RAM stick from 16 GB to 8GB sadly … The 16GB stick just wouldnt boot with 3200MHz setup… I tried to downclock memory to 2933/2866 but 16GB stick is just piece of crap so I had swaped it for 8GB but running at 3200 Mhz :smiley: :smiley: :smiley:

@drmusama - Nice! So, where was the memory OC stuff located? Or, do you just get auto XMP enabled from that single 8GB stick?

@Dorin1996 - Please test in the following order, if you see chipset with first one, no need to test or use second one
1. SetAMIT.bin
2. SetAMITSD.bin
http://s000.tinyupload.com/index.php?fil…941729760677333

I just checked in AMIBCP - the options isn’t visible through there… It’s weird… I can only see now this option in BIOS but not in AMIBCP haha… I will post few screenshots here where the option is - it is hidden deep in “Advanced” tab- If I didn’t went thoroughly through the bios I probably wouldn’t be able to find it haha

P.S. Look what I just found another tab in “Chipset” section - in GFX configuration - subtab - I notice there is subtab called “GFX Configuration” - In bios I cannot see it - Only the “Video bios revision” - I suspect this subtab holds the options for GPU overclocking and voltage regulation Can you see if this last "GFX Configuration’ subtab is visible on your bios mod?

Here is picture: https://i.ibb.co/mDsb8wB/Capture.png


Ive flashed the first one, the Chipset tab is now visible. Thanks for that! <br />But the problem is, even though I set &quot;State after G3&quot; to &quot;S0&quot; under PCH submenu, the system itself wont power on automatically after a power failure. That`s sad. :frowning:
ttp://s000.tinyupload.com/?file_id=19050207122209143863

@drmusama - show me image of the memory stuff you see in BIOS
ON GFX config, are you using onboard vBIOS, one in CPU or some other add-in card like Nvidia/AMD but not in CPU? I can make that visible for you in BIOS if you want. It looks like it only shows vBIOS revision inside there.
Hey, so what about the Light Effects at Root of Advanced, did they let you change KB LED behavior at all? Change both to something and test

@Dorin1996 - Please set this in BIOS to the option you want applied, save and reboot to windows. Once in windows make a new FPT BIOS region dump and send to me (name BIOSregset.bin)
I will check and be sure it’s being applied. Then, I will make you new BIOS with the setting you want hard set in all possible locations, so you can then test that instead.

You may need to enable “Sensor Standby” at Intel RC ACPI, not sure, test and see if this helps
Or “Enable ACPI Auto Configuration” at ACPI



@Lost_N_BIOS I cannot enable “Sensor Standby” at Intel RC ACPI and “Enable ACPI Auto Configuration” because menu is locked as stock BIOS.
Here is my FPT BIOS Region dump(extracted with UEFITool from FTP dump) with the option I wanted to apply (State after G3 = S0):
http://s000.tinyupload.com/index.php?fil…610354182484939
Also here is my bios dump made with FPT in case you need it:
http://s000.tinyupload.com/index.php?fil…322315408720266

@Dorin1996 - Go ahead and edit the BIOS I sent you, to enable those ACPI menus like you did before, then do as I mentioned
Anything you want me to edit needs to be FPT dumped from current BIOS, so not sure what your first link is about above?
Anyway, before I do anything more about the G3 setting, please edit the BIOS I sent you so you can access those ACPI menus like you did before, then test what I mentioned, if no changes then dump current BIOS with FPT and send to me and I will hard set G3 setting in all locations.
If that fails, then there is nothing we can do, some other setting must be causing it to not work. Maybe Wake on LAN needs enabled too, so standby power remains always, that way it can be resumed?

@Lost_N_BIOS In the BIOS that you recently sent me, there is only “Chipset” tab unlocked. “Sensor Standby” is under Intel RC ACPI submenu (not visible) of “Advanced” tab.
My Advanced Tab with the BIOS you sent me:
http://s000.tinyupload.com/index.php?fil…654232588744073

Yes, I know I only unlocked chipset tab… You said you edited Advanced before and made those ACPI sections visible, I meant for you to do that again on the BIOS I sent you.
I could make the edits, but you already know how to for that, so that’s why I said for you to go ahead and make those visible, then test, then dump again with FPT, once done testing, and send to me for further edit

* Edit - Or sorry, did you not make them visible to yourself before, but only directly changed them with AMIBCP? If yes, OK, sorry for confusion, I will make them visible, hold on