BIOS Mod Requested for HP Z420 with LGA 2011 Socket, Intel C602 Chipset and HP Motherboard

I have HP Z420 Workstation which came with traditional BIOS but it has some UEFI capability too (I think as I saw in BIOS). I want to install Samsung PM981 Nvme SSD as boot device. It has an empty PCI-e x16 (ver 3.0) slot and I have the adapter. Can you please help me with BIOS mod so that I can install it with full Nvme support for booting. Here is the link to BIOS exe file download on HP site:

https://support.hp.com/us-en/drivers/sel…station/5225033


The older BIOS settings can be seen in this video:

https://www.youtube.com/watch?v=GOsaR8S35mg&t=264s

I am a newbie and will help if you please give clean instructions as what needs to be done later.

Many thanks in advance

It’s easy to mod but flash
You must to flash it by a hardware programmer

Thanks for your post. I need some clarification.

It is my understanding that the current version of HP BIOS is an exe file which can
be simply installed by double clicking it. If the modified BIOS needs some other method
then can you please point me to a guide for it. I may be able to do it.

Hoping for your answer.

I’ve tried many ways to solve it but only using programmer.
Although I did the trick once through the “fpt”,but,you see, only once~~~~It’s not worth

@gloobox - what stops FPT from writing BIOS region here, something other than BIOS lock? BIOS lock we can get around, and FPRR (protected range register) I know how to get around too (but need programmed in without that lock first, unless PRR/PRR2 works for this system)
If this system has "Sure Start" then nothing will help anyway, BIOS will be auto recovered to stock BIOS if you modify anything inside certain regions of the BIOS (mainly the one needed to be modified here)

bios lock and smi lock
prr
prr2
the three things I’ve tried but it still failed
I tried it in several borads of HP,but no board was OK
So I think the only way to flash it is by programmer

@gloobox - BIOS lock and SMI lock easy to change via grub using setup_var or via H2OUVE vars edit.
If you are getting FPT error 28x (protected range register lock) and PRR/PRR2 fail, that can be fixed easily via assembly/hex edit, but the unlocked BIOS needs to be programmed in or otherwise force flashed before that unlock is live onboard (Force with H2OFFT command line options, or simply flash normally with that tool via command line)
Those only apply for certain HP BIOS too. Ans, some HP boards can be flashed via AFUxxx tools as well, or winphlash, depending on stock BIOS package or actual BIOS type.

Do you have this model? If yes, show me error you get in FPT when trying to write BIOS region before and after BIOS/SMI lock removed.
Dump BIOS using H20FFT-W via command line >> H20FFT.exe backup.bin -g
& do this one too >> H20FFT.exe backup1.bin

With this tool, you can also put in manufacturing mode and that may allow reflash anything or change some protected settings such as PRR option to disabled in the BIOS and SMI/BIOS Lock while you’re there too
H20FFT-W.exe /mfg

Download V1.1 package here, has all the H2OFFT versions
https://github.com/mikebdp2/Insider_BIOS…rchive/v1.1.zip

@Lost_N_BIOS

I have a programmer and a Z620 if this helps. I can play on the weekends and would love to get the Z420 and Z620 tuned up to use these NVME drives.

I have a v1 board and have updated the boot block date to match the v2 boards for future CPU updates. :wink:

@jetman6 - send me some dumps and I can mod for you


I’ll have to dump the latest revision 3.94 as I only have 3.86 moded with the boot block date. I could send that one, But worry a update to 3.94 will wipe out the mod.

I’ll dump it this weekend and send it. Can I attach to a PM??

@jetman6 - If you dump with updated boot block or microcodes, then it will remain no matter what I change. I mean, any changes I make would not affect this, even if it’s included in a dump, so your fine to send dump with any updates you made.
Unsure what is your goal, what do you need changed? Or were you only sending a dump for me to locate and test removing the PRR lock? If yes, are you willing to test mod BIOS after that to see if you can then FPT reflash (ie lock removed)?


Its not what you change, Its what HP might change on the next update. :slight_smile: So I’d like to do the latest 3.94 that’s current on the HP z620 I have. I can post the last dump I did(i’ve since did the latter hp bios updates) when I moded the boot block date for V2 series CPU support?

What I’d like to see is a bios we can let others patch their zx20 systems with if that’s possible! :slight_smile:

I can mod the bios with the tools here, But I can’t get past a checksum error when I inspect the mods. I guess unlocking PRR and doing the mods and then re locking it might be a solution so it might then let it flash the update??


You must explain or link to guide.

Should I unlock the bios before I read the chip?


Here’s the chip dump. :slight_smile:

I would like to see NVME support and maybe more memory. I already have the CPU microcode since the bootblock update. TYIA

Yes @jetman6 , any time you reflash stock BIOS it’s going to re-write whatever microcodes are in there. Checksum error? What gives you that?

Unlock BIOS Lock via grub guide is here - [GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash
Alt boot to grub when no boot to EFI on exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

This only needs to be done to flash via FPT, you can do it before you dump if you want, then it would be unlocked in the dump. This will also be reset any time you flash in stock BIOS, unless you unlock it in the BIOS first.

Is the above a programmer dump? When you do try to flash BIOS region via FPT, you get error 368 correct? If yes, unlock BIOS and SMI lock, then try again with FPT, and then show me new error.
Since you have programmer none of this applies to you directly, you can program in any mod BIOS I make you, but this will help me determine the exact issue causing others to not be able to FPT in a mod BIOS region (or reflash FPT dumped and then untouched BIOS region)



Yes, The above is a programmer dump. Same way I used to update boot block date for V2 CPU support. I was afraid to try reflash due to checksum error from EUFITool when trying to mod for NVME support. But the OEM bios was locked.

I’ll try the guide for grub fix

The Checksum error I get from EUFITool is attached as screen capture. I’m nervous to try flash or even chip program due to error!!

Thank you!

EUFITool error.PNG

Thanks for all the clarification and info. Hard to know what that checksum error is until you double click on it, often you can simply choose rebuild after clicking and it takes you to the checksum problem file.
Since you have programmer you should never be nervous to test, even something you know will brick, you can always recover. But yes, this checksum should probably be fixed if it’s not present in your dumped file.

I’ll do the mod now, NVME and unlock BIOS lock/SMI Lock. Then please program it in, go into BIOS, load optimal, make any other changes you need, then using included BIOSreg file flash via >> FPTw.exe -bios -f biosreg.bin and show me image of error given and command entered all in same image.
Please refresh page in a few minutes if you are reading this now, I will edit into this post the mod BIOS mentioned above.

Pre-post edit, I see this same checksum error in the dump you provided, so it’s not caused by any edit you made. Since this is in stock BIOS it can be ignored, or you can correct if you want to test with it corrected (click rebuild on the item double-clicking it brings you to)

Checksum-Error.png



Mod BIOS coming shortly! * Edit, I see no BIOS or SMI lock, so don’t waste your time trying via grub/setup_var, please wait until we confirm this is what’s shown with FPT BIOS region flash attempt

** Edit @jetman6 - here is NVME Mod BIOS, program that in, then try to flash included BIOS region via >> FPTw.exe -bios -f biosreg.bin
http://s000.tinyupload.com/index.php?fil…225153346449473

Then show me error given, thanks.

Error 367?

error 367.PNG

@jetman6 - Looks like you have the wrong FPT, and or also your command is incorrect. Proper command is as follows >> FPTw.exe -bios -f biosreg.bin

Open the command prompt from the files location, not how you have it, although that may work if FPT and biosreg.bin are both in the root of C drive (Except for the filename at end of command can’t be how you have it, it must be name of file only)
Proper way would be to put BIOS files and FPT in same folder on desktop or something, then back out of that folder, select the folder that contains the files, hold shift and press right click, choose open command window here (not power shell)
Then run the command as shown above.

If you don’t already have correct version, you need V8 ME system tools package from section “C” in this thread, FPT is inside flash programming tool folder
Intel Management Engine: Drivers, Firmware & System Tools



@Lost_N_BIOS Thank you for your extreme patience!! My syntax skills are lacking!! So I try to adjust to make easier. :frowning:

I again received an error with the tools. I did not write or screen capture it. Frustrated!! There is one sure way to jam this upgrade down the chips throat. :smiley:

I will mod the chip read and program it with my flashcatusb once I get a more reliable chip test clip or mount a header. My test clip slips off and its nearly as frustrating as typing the syntax for dos. My main worry was the checksum error, But now notice its in all the previous bios files as well??

I also want to Thank all here for the help and awesome guides!! You all rock!!

I’ll keep you posted, But I’m sure it will work with the chip reprogram! Thank you very much again!! :slight_smile: