Bricked Acer PH315-51

Hello Guys… @Lost_N_BIOS
i flashed using ezp2010 modded acer ph315-51 which i edited using H2OEZE , Anyhow laptop accapted modded bios and start updating bios and turned off and unable to turn it on again. i opened it and have full access on motherboard . i tried to reflash using acer web bios v1.26 ezp giving too long file. I really need help here and doono actually how to make it working again.
If someone can advise on steps to do tro rewflash bios and i guess EC as well will be highly appreciated.


@KAL - Please dump current BIOS contents and send to me. Do you remember what BIOS version you were using? Also, do you know your BIOS or family ID, like 1A or 10? Stock BIOS contains 2 BIOS images
What was your goal of editing BIOS with EZE? Often that can break BIOS, and you need to fix it after it’s done, before you flash it.

If you need unlocked BIOS, I can unlock it when I fix the BIOS for you, let me know

Hello, Man
I admire your quick response. i was using v1.26 and 1A (nott sure though). Edited setup utility to have more options in bios settings so i replaced setup utility module with one i found here in the forum.
Thanksssss really appreciated…

Thanks, I try to help when I can!
EZE is not ideal to replace modules, next time use UEFITool 25 and you should be good to go
You also need to be sure the module you replace is from your same BIOS version first too, not sure if BIOS version was mentioned in that thread, if it’s the one I’m thinking of.

I don’t see the expected issue in your BIOS dump. Maybe was just bad flash??? I see only stock setup module in there, from 1A, so it may have not even flashed, just bricked for some reason.
I will rebuild for you with 1A and unlock BIOS

* Edit @KAL - Please upload your mod BIOS that you flashed, I want to check vs what was dumped. I’m wondering if you even flashed anything.

v1.26 i guess mentioned it before

Thanks Man you are the HERO here in the forum

See my edit above. Sorry for any confusion, I wasn’t asking you about BIOS version again, I meant in the other thread I wasn’t sure if they discussed BIOS version or not.
I think you meant you used file from this thread, correct? Acer Predator Helios 300 (PH315-51-78NP) - Unlocked Settings
If yes, what did you use from this thread exactly, and what did you do in EZE?

You’re welcome!

i downloaded acer v1.26 bios(From Acer Website) extracted and modified 1A WITH EZE REPLACED MODULE (from forum ) saved and i used H2OFFT from original bios after editing platform.ini and flashed it back. laptop started updating bios and turned off before EC update and never turned on again.


What BIOS exactly did you extract module from? Either BIOS was not flashed at all, or module was not replaced in your mod BIOS properly. That’s why I said please upload your mod BIOS, so I can check.
Setup module is 100% hex match to stock BIOS 1A in your dump, so above = true and I wanted to check why (mod not done properly, ie EZE didn’t replace anything, or BIOS was never flashed as it appeared to be)

What did you edit in INI?? EC Flash sounds bad, it shouldn’t have happened, unless that is normal for this BIOS type even if EC/BIOS already same, and it sounds like that may be where it died, dump EC FW chip too so we can check and see what it looks like.

I opened DH53F_1A.fd in H2OEZE and went directly to replace module and selected setup utility at the end and downloaded thread edited ffs and replaced it in the fd file, saved i8t as on desktop. i then open platform.ini and adjusted flags to 0 checking rom version, verifying versions hthat’s it. and cant upload my modded since it is on the hard disk and laptop is not turning on (used h2offt to flah it and was saved on the desktop). spi had it saved on external hard disk before i did all that.
Can i access EC fw chip on deal laptop? can you please tell me how to dump it.

File you sent me (read.bin) is hex match to stock BIOS, so nothing flashed in, or it’s a failed edit or nothing was changed using eze. BIOS does not look obviously broken, so we need to check EC FW chip contents first, to be sure that is not blank or corrupted, before I attempt to fix a BIOS for you
So, SPI was some dump you made before you flashed? If yes, what software did you make that with, or programmer? Either way, SPI.bin and read.bin have 100% hex match setup module to stock BIOS, so no edit was applied to current BIOS Contents (at least not at the setup module)

Yes, find other chip that looks like BIOS and dump it, it will look physically same but content size will be much smaller, usually 128KB-1MB

SPI.BIN WAs dumped by fwpt.exe and read.bin by ezp2010 spi programmer. there is one 8pins labelled alp584b and another HO809A03 which one exactly if you know.



Neither of those, check more and or other side of board. If you can’t find, give me image of both sides of the board (if you have it removed). If you do not have it removed, hopefully it’s on the side you can see!

Hello Again,. and thanks in advance.






Please put in zip or rar w/ max compression, I’m on limited internet, thanks

Good Morning,
Please find attached…

PH315-51.part1.rar (5 MB)

PH315-51.part2.rar (5 MB)

PH315-51.part3.rar (5 MB)

PH315-51.part4.rar (2.92 MB)

Please upload here, I can’t stand downloading split files from here it’s a HUGE Mess due to how files are renamed when downloading from here

Here It is :slight_smile:

Pictures.rar (2.7 MB)

YOu already sent to me in PM now

Hello Man,@Lost_N_BIOS
please can you advise on the reason to get MEI disabled and how to repair it… and how to stop windows from reverting to originally installed bios after flashing with spi programmer?

lOST_N_B u r the big boss please help on that and if there is a way to revert to the flashed bios without dismentling again the laptop…
Thxs in advance

MEINFO.txt (1.2 KB)

@KAL - Sorry, you may have explained more IN PM, but I don’t have time to reply to all those PM"s right now, I will tonight!
But, to answer above. I don’t know what you mean, about Disabled ME, please explain? I don’t disabled it ever, unless someone asks me to.
Did you ask me to disable it? If not, and you now need it repaired, I will fix for you later tonight, just let me know which BIOS worked OK for you and then I will clean and update the ME FW in it for you and then you program back in.
Also, in that BIOS, I will unlock FD for you too, that way later you can fix BIOS or ME with FPT instead of having to fix with programmer. For now, since I did not unlock FD for you initially, and you have ME Disabled, you will have to fix with one more programming

"Windows" can never revert to original BIOS after you program in any BIOS, however, windows updates can “Update” your BIOS during normal windows updates if Acer is partnered with windows for such updates.
And that, you can stop in advanced update options, by disabling “get drivers from manufacturers” during update, something worded like that.