Bricked Bios Asus Sabertooth Z77


I used AFUWINx64 with the oldest bios version (0801) for this motherboard downloaded from Asus using the parameter /MEUL or /ME or /MER can’t remember which and now my PC doesn’t post.

This motherboard has a Bios Flashback function but it’s not working and never worked for me before even before I flashed the ME…

My questions:

1- I would like to know if the Bios Flashback function was working would it even be able to fix the parameter I used to flash?

2- I’m currently using my older Sabertooth P67, does anyone know if it’s possible to hotswap this bios chip with the one from the Z77 and do a AFUWINGUIx64 Program all Blocks with a downloaded BIOS from Asus website for the Z77?

If possible do you think it would even possibly fix the kind of flash I did with the AFUWINx64?

Thank You

Get yourself a CH341 programmer, those aren’t too expensive. All other questions- maybe, maybe not.

There’re at least some reports of having successfully used flashback:

But if this will write bios region or complete firmware?

1 Like

I have one of this and and M5F, using USB BFB, at least for me, it doesn’t overwrite ME region, mod or original bios files, it always stays the higher version, contrary to SPI programming with CH341A.

The Asus USB BFB can be very picky with some usb drives in certain motherboard models, but it does recover if the ME FW is ok.
Had them working with FAT32 and even with FAT only, but always with old and small USB drives 4/2/1G/512/256Mb…while they’re still alive…

1 Like

I didn’t really wanted to buy the programmer or the chip and would like to fix this fast :frowning:

I never had luck with this crap Flashback, I tried 2, 4, 6, 16 and 32 GB Pen drives, even tried with old mSD and SD on a USB card reader all tested at both Fat16 and Fat32 as MBR.

I renamed the bios to Z77ST (CAP file) and put it on the root of the USB. Then connected the USB drives to the Flashback port and maintainted the flashback button pressed but it always blink like 3 or 4 times and then always turns solid blue and only with very small Unit allocation size partitions it flashes for a few more times until it always turn solid blue grrrr :rage:

I have also tried with nothing attached to the PC and no PCI-e cards and just 1 ram dim and tried each single ram slot and even tested without RAM or CPU and it’s always the same god damn blue light.

Anyway the AFUWINx64 parameters specify the following:

  • /MEUL: Program ME Entire Firmware Block, which supports Production.BIN and PreProduction.BIN files;

  • /ME Program ME Entire Firmware Block;

  • /MER Flash Entire ME Region.(*1).
    (can’t remember which one of the three I used).

ps: I really wouldn’t mind hotswaping the bios chip and do a “program all blocks” with AFUWINGUIx64 if I knew it would not damage anything at least (though this is such a pain job since I would have to remove the plastic shield covers on both motherboard and I’m already tired of disassembling the whole PC a lot of times :sleepy: :pensive:)

After the initial blinks when it turns solid blue, something is not ok with the file/usb or port.
But the function seems not death at all, still it uses a dxe in bios for this and if the fw is corrupted…
I wouldn’t try and lose time with AFU and swaps, these tools will not do a full programming/repairs, the chip its easy to program as its SOIC8, just get an CH341A and you’ll have success on it.
Transfer the motherboard original data with FD44 editor to the extracted bios image, using the UEFI tool (Removing it from the CAP) and use the file on the programmer. Its safer to wait a week or two for the programmer than do any more damage to the motherboard, good luck.

1 Like

The Flashback was always like this even when my motherboard was working fine and with latest bios, never worked, always solid blue and the USB port I know is fully working too :(.

I have the following questions:

1- About the hotswap does anyone know at least if the Sabertooth P67 Bios chip and Z77 have the same exact pin-out like voltages and so on?

2- Anyway what if I go for the easiest way of buying the bios chip already updated, is it too bad not having my original Z77 settings?

I don’t have any kind of knowledge on Bios recovering, only have been doing bios update since ever but the original way by the manufacturer (or already modded bios) and other than that only been modding GPU Vbios but never had a problem with them, that’s why I’d like to avoid going the programmer way if possible :confused:

I wont loose my time checking both chips, but they work in same range voltage.
Search data from them on the web, must be correctly visually identified, use smartphone cam magnifier or similar.
Each bios file as its supported chips on the Flash Descriptor…swaps dont work so easy as you think from different motherboards models, so death end here.
Kill the P67 programming and then how do you recover it without a programmer?
The programmed P67 chip, as it is now, most likely wont even boot the Z77…again death end.
Buy what you want, spi or programmer, theres no easy fix (as you want) for this kind of situation.
No earlier dumps/backups, then only recovered information from motherboard stickers as last option, SN and MAC and no more miracles i can add to your ideia… a couple of days waiting for the package for the spi or CH341 and your issue is solved, over_n_out.

1 Like

@MeatWar He means hot swap:
booting the P67
yanking out the P67 firmware chip while machine still running
putting inn the Z77 firmware chip while machine still running
programming the Z77 chip with a Z77 bios

Might work if the complete firmware gets written, might as well end up with a dead P67 chip in addition.

1 Like

Didnt even remember the hot swap method… thats because was never an option of my taste.
Even so…damm, too much work for 12-15€ CH341 and yes maybe a dead P67, his choice…cheers.

1 Like

EDIT: THIS POST IS MOSTLY OFFTOPIC, don’t read it all if you don’t have time, sorry (I put the important stuff in bold)…

Yep, that was my plan for the hotswapping, I have done many other stuff, but never BIOS, but at least seems to work pretty fine for old BIOS types, don’t really know with UEFI type…

If it wasn’t for the thermal plastic shield I would have already tried it right away, but I would have to disassemble my whole PC again for like the 20th time and for a few days I already wasted enough thermal paste for many years, MX-5 and Kryonaut gone (I went for full 3770K die-to-cooler with intel locking mechanism removed and didn’t worked as amazing as I thought and went back and forth with this)…

Also my P67 has almost all the pins by a thin hair and one broken pin which I managed to solder with just a crap iron and the more I remove the CPU and mess with it the more scared I am to even think about soldering a motherboard CPU socket pin EVER again, specially with only a 11W JVC iron and not even a damn zoom lenses and to remove a pin from other motherboard I literally tried everything, my 45W desoldering iron, even burning the whole motherboard with jet flame and couldn’t desolder 1 single pin LOL, had to break a old 775 in half, just so I don’t have to buy a heat gun :yum:

I will try contacting a friend that fixed my old laptop for a damn nice price, like 20€ for a complete repair with many small SMD’s burned in the motherboard, maybe he could have bios programming tools and maybe even do it for free, however his phone was OFF today…

Also in the meantime I will give one last chance to Bios Flashback garbage with my oldest 256MB usb pen drive which is the only one I haven’t tested, however I don’t have a 2nd power supply and I’m way too lazy at the moment to remove my Corsair AX750 all over again :scream:

ps: But I’m still thinking on the god damn hotswap maybe to add another thing to my list of crazy stuff, It wouldn’t even be something high on my list :grinning: (but would still kill my heart as it’s the only PC I have since 2011 with a I7 2600K. The Z77 + 3770K I bought recently used at a good deal, however it disappointed me so badly to learn the hard way that this 3770 doesn’t OC a single crap above 4.5 it needs above 1.4V :frowning_face: and I’m thinking if intel CPU microcode is the problem here, it also works the same on my P67, 4.5ghz is the max :face_vomiting:).

The hotswap might work if you do know the chip orientation (if both chip are similiar brand then it should be able to, just make sure to check the schematic of each bios) since once os loaded bios is not needed. i just did this with my jank h61m hvgs, boot to os, take bios chip (its a zif package like yours), flash H71M DGS bios on the programmer, put back the bios chip in place, reboot, and walla, the board is now H71M DGS (both boards have similiar schemes). so yeah i think it could work on yours if you’re that lazy to flash that bios chip.

idk abt the limitation tho since the p67 use 4MB bios chip, and the z77 use 8MB bios chip. Maybe IntelFPT would detect the bios 8MB chip and you could flash it (after extracting the .cap using Uefi Tool) using intelfpt rather than AFUWIN. Just make sure make a backup of your bios (z77 bios chip) before doing so, since other info such as Mac address and stuff might be there.

But tbh, it’s waaaay more easier to take your Z77 bios chip and plug it directly to the programmer and backup your bios and flash it directly like this (this is my H61M HVGS bios chip, taken off while using the board, and flashes the H71M DGS bios and put it back):

1 Like


Asus Sabertooth P67:

(winbond 25Q32BVAIG 1104)

Asus Sabertooth Z77:

(winbond 25Q64BVAIG 1219)

From what I searched it seems they are exactly the same except 1 is 32MB and the other 64MB…

After the hotswap, what should I do to fix a bad flash with the AFUWINx64 /MEUL or /ME or /MER parameters?

I was thinking to just try AFUWINGUIx64 program all blocks with a latest Z77 bios from Asus…

EDIT: I just tried AFIWINGUIx64, but the app always close before starting to flash and only reads 4MB. I also tried AFUWINx64 but it only reads and doesn’t write. Really need some instructions on what to do (kinda for dummy since I have 0 knowledge in bios modding\flashing) :face_with_spiral_eyes:.

Also for now P67 is fine if I don’t keep bending the pins until one breaks… :upside_down_face:

Try Intel FPT.

Information here

I’m kinda blind here, I have Intel FPT V. I tried “fptw64.exe -I” on my P67 with it’s original bios just to test, but it just throws a error.

I think I have intel ME V9.5.10.1658 installed from Asus website for P67. HWINFO64 says I have ME 8.0 build 1410 Hot Fix 2 and report it’s normal and active and it’s FW is 1.5 MB…

P67 Bios reports EC V. MBECE-0018 and ME V8.0.2.1410.

Also can anyone check this programmer if it has everything I need to fix my Z77 bios:

I think I will sadly have to buy the programmer because I still don’t know how to flash the Z77 bios in my P67 board if it’s even possible that is…

FPT writing a 8Mb FW on an 4Mb SPI… FPT tool v16??? wtf… use your brain, no just stop using the brain, buy the damm programmer and dont waste your time and ours.
Now reversing the Z77 8Mb SPI and running the fpt tool…ask who told u this, in how to fool the tool about the system running in it… gonna be honest never tried in DOS, who knows…

Im not even gonna mention "that SMART ideia " and the suggestion origin, still i know from where it comes so ask him to do it with his mboard.

Can you check amazon link in my previous post and see if that one’s good. (I will buy it if it’s good for the task)

Also I just tried with a older version of the tools now for ME8 and the ME is now reporting data, will still try later with the Z77 bios chip to see if it reports 4 or 8MB.

Also this kind of stuff really need to be done on DOS? If so do you know if the latest version of FreeDOS from like RUFUS would work for it or are you really sure its impossible to flash the full 8MB from this board to a Z77 bios chip and it’s even pointless to try it?

ps: At least I have the first 4MB of Z77 bios saved even though it’s pointless :stuck_out_tongue:

Yes the linked product will work.
You have 4Mb of the Z77 bios… sorry my friend, i tired of brainless situations, good luck on your endeavor and all the best when you get it finally fixed by the programmer.

1 Like

Thank you so much, I already ordered and will update here when it arrives, though I don’t know how to use it as I never did BIOS MODS\PROGRAMMING.

However I’m still open to ideas as long as you give me clear instructions to try for the Bios chip hotswap until the programmer arrives or I break a leg of the bios chip :grinning:

ps: At least now we all know Sabertooth P67 bios chip hotswap with the Z77 bios chip at least doesn’t harm and maybe someone with knowledge perhaps could make it work, but I’m completely noob on this :partying_face:

the intel me tool you should use is ME System Tools V8 (LGA 1155 use either ME 7, 8, and 8.1), and it seems you know the command for the fpt.

-d to dump the whole bios
-f to write the chip

adding the filename.bin if you dont forget for either flashing the bios file or assign a name for the bios you dumped.

You could try it yourself if it’s even successful, Prolly extract the .cap bios using uefi tool, copy the .bin of the extracted bios to intelfpt folder (the x64 one iirc), and flash it using fptw64 -f biosbinyouextractedfromthe.cap.bin, and see if it’s working. be sure you do back up the bios of corrupted z77 chip using -d biosname.bin using fpt if it’s successful.

before doing so do the -i and see if your Z77 bios chip is detected. if so and correct, experiment is yours :smiley:

dont worry if it got a bad flash, as long as your p67 bios chip still intact, you could uset he ch341a programmer and use the ch341a programmer app v1.18 or 1.29, and use it like what i did (watch the correct direction to put your chip, its on the programmer pcb if you see my image before).

1 Like

Yep, I realized right after the error that I had wrong version…

This is what I got:

Intel FPT really seems to detect the whole 8MB BIOS, but says total accessable 4MB, does it mean this won’t work?

Also the dump is only 4MB just like AfuWin64 :frowning_face:

I also just tried with FreeDOS from RUFUS and it’s the exact same thing, only reads 4MB and only saves 4MB dump :face_with_spiral_eyes:

ps: It would be cool was if I could start up the Z77 with the P67 bios in it as long as it booted it sure would work to fix the Z77 Bios, but that’s something I’m not willing to risk :sweat: