Bricked Dell Optiplex 5060 + CH341a + SOP16 > Alive again

Hi Guys,

i messed up with my Dell Optiplex SFF 5060.

Whats happend? I found the device in the e-waste at our company. A short test showed that is still working. My tought: Perfekt for HomeServer, but Yellow Label 3 - ME Disabled. (i want to use Intel AMT for remote on / off etc.)

Long times ago i modfied an olden Optiplex 790 or so. In my thoughts this wasn’t to difficult.
But this device has a Intel Q370 with Intel I3 CPU. So i had to the CSME Packages.

As my source of inspiration i use the (Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)) Website. Very good to read, all information available, a big ‘thank you’ for the author.

First of all i took a Dump of the SPI via fptw63.exe -d spi.bin. Just to be sure…

In the next steps i followed the instructions from the " How to use FWUpdate Tool at CSME v12: Chapter. Everything worked smoothly. But i wasn’t able to active MEBx at all. After that i updated the Dell Bios with the last recent version without any success.

I played with the service jumper. No chance to get MEBx working.

Then i found a thread here in the board relating to an other Dell Workstation. The User dumped the SPI, loaded in into FIT, changed some Parameters, rebuld the Image and then push it with fptw64.exe -desc and fptw64.exe -me back to the SPI.

I did the same and dumb as i am, i ignored the warning about filesize within SPI and the Binary i had created before.

So now the PC makes nothing. Only 2x yellow / 1x yellow Error Code. In my eyes i overwrote the SPI with nonsense, so i have to reflash it.

This device uses a MX25L25673GMT SPI Chip (,%203V,%20256Mb,%20v1.7.pdf with an 16-PIN SOP Layout

First Question to you → Can i restore the SPI with the existings Dumps i made ?

spi.bin - Google Drive => First Dump without any Dell Bios Updates

║         ME Analyzer v1.283.3 r319         ║

║                spi.bin (1/1)                ║
║            Family           │     CSE ME    ║
║           Version           │  ║
║           Release           │   Production  ║
║             Type            │   Extracted   ║
║             SKU             │  Corporate H  ║
║           Chipset           │ CNP/CMP-H B,A ║
║ TCB Security Version Number │       1       ║
║ ARB Security Version Number │       4       ║
║    Version Control Number   │       10      ║
║       Production Ready      │      Yes      ║
║      OEM Configuration      │       No      ║
║       FWUpdate Support      │   Impossible  ║
║             Date            │   2018-07-11  ║
║      File System State      │  Initialized  ║
║             Size            │    0x77C000   ║
║       Flash Image Tool      │  ║
║         Power Management Controller         ║
║            Family           │      PMC      ║
║           Version           │ 300.2.11.1015 ║
║           Release           │   Production  ║
║             Type            │  Independent  ║
║         Chipset SKU         │       H       ║
║       Chipset Stepping      │       B       ║
║ TCB Security Version Number │       3       ║
║ ARB Security Version Number │       3       ║
║    Version Control Number   │       0       ║
║       Production Ready      │       No      ║
║             Date            │   2018-07-20  ║
║             Size            │    0x14000    ║
║       Chipset Support       │      CNP      ║

Warning: Outdated Database (r319 --> r320)!
         Download the latest from

Press enter to exit

MEInfo from the system before crash

Intel (R) MEInfo Version:
Copyright (C) 2005 - 2022, Intel Corporation. All rights reserved.

General FW Information

    Platform Type                              Desktop
    FW Type                                    Production
    Last ME Reset Reason                       Unknown
    BIOS boot State                            Post Boot
    Slot 1 Board Manufacturer                  0x00001028
    Slot 2 System Assembler                    0x00000000
    Slot 3 Reserved                            0x00000000
    Capability Licensing Service               Enabled
    Local FWUpdate                             Enabled
    OEM ID                                     68853622-EED3-4E83-8A86-6CDE315F6B78
    Integrated Sensor Hub Initial Power State  Disabled
    Intel(R) PTT Supported                     Yes
    Intel(R) PTT initial power-up state        Disabled
    OEM Tag                                    0x00
    TLS                                        Disabled

Intel(R) ME code versions:
    BIOS Version                               1.2.22
    MEBx Version                     
    Vendor ID                                  8086
    FW Version                        H Corporate
    LMS Version                                Not Available
    MEI Driver Version                         2229.3.2.0
    Wireless Hardware Version                  Not Available
    Wireless Driver Version                    Not Available

IUPs Information
    PMC FW Version                             300.2.11.1015
    LOCL FW Version                  
    WCOD FW Version                  

PCH Information
    PCH Version                                0
    PCH Device ID                              A306
    PCH Step Data                              A0
    PCH SKU Type                               Production PRQ Revenue
    PCH Replacement State                      Disabled
    PCH Replacement Counter                    0
    PCH Unlocked State                         Disabled

Flash Information
    SPI Flash ID 1                             Not Available
    SPI Flash ID 2                             Not Available
    Host Read Access to ME                     Not Available
    Host Write Access to ME                    Not Available
    Host Read Access to EC                     Not Available
    Host Write Access to EC                    Not Available

FW Capabilities                                0x31119140
    Protect Audio Video Path - PRESENT/ENABLED
    Intel(R) Dynamic Application Loader - PRESENT/ENABLED
    Intel(R) Platform Trust Technology - PRESENT/DISABLED
    Persistent RTC and Memory - PRESENT/ENABLED

End Of Manufacturing
    Post Manufacturing NVAR Config Enabled     No
    HW Binding                                 Enabled
    End of Manufacturing Enable                Yes

Intel(R) Active Management Technology -
    Intel(R) AMT State                         Disabled
    M3 Autotest                                Enabled
    Localized Language                         English
    C-link Status                              Enabled
    AMT Global State                           Enabled
    Privacy/Security Level                     Default

Intel(R) Protected Audio Video Path
    Keybox                                     Not Provisioned
    Attestation KeyBox                         Not Available
    EPID Group ID                              0x28C1
    Re-key needed                              False
    PAVP Supported                             Yes

Security Version Numbers
    Minimum Allowed Anti Rollback SVN          1
    Image Anti Rollback SVN                    4
    Trusted Computing Base SVN                 0

FW Supported FPFs
                                               FPF         UEP         ME FW
                                               *In Use
                                               ---         ---         -----
Enforcement Policy                             0x03        0x03        0x03
EK Revoke State                                Not Revoked Not Revoked Not Revoked
PTT                                            Enabled     Enabled     Enabled
OEM ID                                         0x00        0x00        0x00
OEM Key Manifest Present                       Not Present Not Present Not Present
OEM Platform ID                                0x00        0x00        0x00
OEM Secure Boot Policy                         0x3F9       0x3F9       0x3F9
CPU Debugging                                  Enabled     Enabled     Enabled
BSP Initialization                             Enabled     Enabled     Enabled
Protect BIOS Environment                       Enabled     Enabled     Enabled
Measured Boot                                  Enabled     Enabled     Enabled
Verified Boot                                  Enabled     Enabled     Enabled
Key Manifest ID                                0x0F        0x0F        0x0F
Persistent PRTC Backup Power                   Enabled     Enabled     Enabled
RPMB Migration Done                            Disabled    Disabled    Disabled
SOC Config Lock                                Done        Not Done    Done
SPI Boot Source                                Enabled     Enabled     Enabled
TXT Supported                                  Disabled    Disabled    Disabled

ACM SVN FPF                                    0x02
BSMM SVN FPF                                   0x00
KM SVN FPF                                     0x00
OEM Public Key Hash FPF                      69602F34CC9D121ECB7785F4F5CA4153ADC35633FF13A76B914FB2FE2835F691
OEM Public Key Hash UEP                      69602F34CC9D121ECB7785F4F5CA4153ADC35633FF13A76B914FB2FE2835F691
OEM Public Key Hash ME FW                    69602F34CC9D121ECB7785F4F5CA4153ADC35633FF13A76B914FB2FE2835F691
PTT Lockout Override Counter FPF               0x00


Found a thread about SPI Flashing this chip →

Here the Image i flashed via fptw64.exe which makes my device unusable

Here the last dump from spi (made with fptw64 -d) (recent BIOS Update from Dell, maybe older ME FW) (used as base image for FIT)

After FIT i replaced ME Sub Region with this file ‘’

All components have to be AMT compatible otherwise you can have a AMT enabled ME but system will go to standard manageability or maybe no manageability.

Components are chipset, network card, cpu (Afaik no i3 whatsoever with AMT)

Otherwise never a good idea to ignore size warnings when flashing.

Attach your dump if in doubt.

Hi, i thougt that the AMT compatiblity of the CPU is only important for KVM. Maybe this changed in time. I attach the Dump to the first post.

I think to ignore theese warnings the biggest mistake at this hole process

Thank you in advance

spi.bin - Google Drive p=share_link

=> Login?

Regarding manageability- there’s vpro, amt and no manageability, vpro already includes the 3 mentioned conditions. But they may have ‘developed’/ divided it even further. Earlier they mentioned vpro for non- vpro cpus in the fact sheet with a no, no they omissed the vpro information. Non vpro setups get somtimes delivered with a realtek NIC for example, it seems clear that Intel ME may not control the firmware of this NIC in the same manner as an appropiate Intel NIC.

Sorry. Now the Link is accessable without auth.

Looks like a perfectly fine image, ME unpacks fine.

How did you dump your firmware? Anyway I’d recommend to dump what’s in the chip now just to have a look what went wrong.
According to your description
“rebuld the Image and then push it with fptw64.exe -desc and fptw64.exe -me back to the SPI.”
That should work with a complete and properly rebuilt image, too, without size warning.

Can you attach the image you flashed and / or the actual content of the chip?

i dumped it with fptw64 -d command

I added the two links in my first post.

Thank you for your help!!!

cse_image_FWU_Base.bin, cse_image_FWU_Full.bin are files for ME- firmware updates made with FWUpdLcl64

The ‘real’ thing / the correct firmware (if you didn’t work on a region only) would be outimage.bin
(Not your bios in the example, it’s a lenovo with firmware divided onto two chips, that’s the reason for generating 3 outimage files.)

ftpw64 flashes everything you order it to, but update files do have a different structure than a ME region and don’t work. In addition they have a different size.
And they don’t contain a flash descriptor but of course ftpw64 will write it there even if it’s about 3000 times the size.

(Don’t work on a region with FIT, always use a complete firmware image- just in case)

The settings needed for vpro/AMT are:
“Intel (R) ME Kernel” - “Intel (R) ME Firmware Update”
HideMEBxFwUpdCtrl value=“No”

“Intel(R) AMT”
AmtSupported value=“Yes”
NetServicesSupported value=“Yes”
MngAppSupported value=“Yes”
MngAppPowerUpState value=“Enabled”
AmtIdleTimeout value=“0xFFFF”

“KVM Configuration”
KvmScreenBlnkEnable value=“Yes”
KvmSupported value=“Yes”

“TLS Configuration”
TlsSupported value=“Yes”

Hi. I see an outimage.bin and in the directory from the FIT Tool. You mean i simply flashed the wrong binary?

Tonight i’ll order the nescassry Equipment for flashing the SPI

  1. KeeYees SOIC8 SOP8 Test Clip für EEPROM 25CXX / 24CXX + CH341A 24 25 Serie EEPROM Flash BIOS USB Programmer

  2. SOP-16 Clip

Yes, unfortunately.

ftpw64 can (afaik) extract regions from a complete image with proper flash descriptor, but if an “unstructured” file / a file without recognizable structure is given, it will simply flash it to the region chosen in the commandline.

So a ftpw64 -desc -f outimage.bin will indeed flash the descriptor to the addresses stored in the FD, same for a ftpw64 -ME -f outimage.bin, that will flash only ME region with the corresponding region og the file given in the command arguments.

Open your own dump and outimage.bin in UEFIToolNE, compare the structure.

At the moment i see Problems to Flash the MX25L25673GMT SPI Chip at all

Did someone successfully flash a MX25L25673GMT with a SOP16 Clamp and a CH341a programmer ?

Update: Maybe NeoProgrammer can help

Today i received the CH341A Programmer and the SOP-16 Clip. The motherboard has to be dismount from the pc chassis.
In the next step i’ll have a look at right pin assignments as there are many combinations possible.

Here my Setup / Wiring


I wasn’t able to connect to the SPI IC. I used NEOprogramme and flashrom under Win10 (Admin). I switched drivers, MOSI / MISO Connection and even connect the PSU to the motherboard. No connection to the IC.

My next step is to install Linux (Ubuntu) beside my Windows and try again. => FAIL !

=> (within the next days) Will this fail too, i dissolder the SPI IC and solder it directly onto the back of the CH341a Stick.

In several threads i see problems with the SOP-16 SPI ICs in combination with CH341a. Is there anybody who can confirm that this possible at all ?

Best Regards and thank you


Last Update: I found another Dell Hardware with a SOP16 winbond25025… SPI IC. I cannot connect to this ic, too. So maybe the CH431a or the clip has a bug. Or. It is simply not possible.

Another Day, another try => Success. :sparkles: Connection to IC established

Will post details soon

Good luck!

Ok. Here the detail. Finally i have a connection with the MX25L25673G.
I use AsProgrammer ( in the latest version with the included driver.

I made four dumps with my Win10 Laptop. Every Dump has a different MD5 Checksum :pensive:
So i cannot say that i have a valid backup from the SPI IC. At this moment i connect the setup to my workstation and will make dumps again.

=> Change to workstation doenst make this better.

This is one of the DIFFs between the two dumps

Maybe someone could answer me the following question:

  1. What could be the problem that every dump has different data within? I dont move the SOP-16. I only click on the Read the Flash Button in the Software. Could it be the situation that the SPI IC still is mounted and connected to the motherboard and interference from other components could disturb the communication to the CH341a?

  2. Could i risk to simply overwrite the SPI content with the outimage.bin with the knowledge that i might not have a valid backup of the spi ?

  3. I wrongly flashed the SPI with cse_image_FWU_Base.bin. Am i right if i say i should found the content of this file somewhere within the dump i made ?

Probably bad contact of the clip.

If you can’t read it don’t write it. You won’t be able to verify a good write, sitting in an undefined state and unable to diagnose it.

Yes. It depends in which order you did use the commands. You wrote
fptw64.exe -desc and fptw64.exe -me

I’d say with overwritten descriptor the second command shouldnt have worked since there wasn’t any longer a valid descriptor to define a ME region? You should anyway have a large area of your bios region in the end of the file.

Hi lfb6,

so maybe i have the dissolder the SPI IC. I had the hope to avoid this step.

Thank you for your help

There are som tricks, like with or without CMOS battery, power attached, not using unnecessary pins, but as written, it’s mostly bad contact. In addition search the forum for this chip,

Just to mention: A file with only FF will have a valid looking checksum, too, and have identical reads. Please check structure with UEFIToolNE.

great news ! Summarized: The Dell PC is alive again and INTEL AMT is enabled.

So whats happend in the last days?

After i got no valid results from the SPI IC i decided to desolder the IC from the motherboard (hot-air dessolder with 450° C)
At the samtime i found an defective Dell 5070 Motherboard with a similar 25Q256JVFQ Chip to try and qualify my desolder skills (which are still quite bad)
I put both ICs into die SOP-16 Clip and try to read out. Now i got only FF FF FF Data. On both ICs.
In the next step i ordered some more CH341A Programmers, switched differend drivers and tools.
At on point i believed that CH341A and 256MBIT SPI Chips aren’t compatible. So with noting to loose, i solderd the SPI IC to the adapter board from the programmer.

and connected the wires. I used the datasheets from Winbond and Macronix to get a valid SOP-8 to SOP 16 Mapping

7 1
8 2
9 3
10 4

2 8
1 7
16 6
15 5


it was also quite important to connect pin 1 from the IC to 3,3V (up)

So i soldered only 8 pins from the SOP16 IC

Now i got a valid READ from SPI and same Checksums after severals passes.

In the next step i desolderd the winbond and solderd the MX25Q256 from the Dell 5060.
Unlike its Winbond Brother, i couldn’t get identical checksums. I tried several tools and drivers again. Nothing worked. i made six dumps. and all dumps differ in a very small area from maybe 100 blocks.

With nothing to loose i erased the whole IC (with NEOProgrammerm which detect the MX25Q256 flawlessly), checked the erase and flashed the outimage.bin.
After the first compare (binanry vs IC content) i got a positive feedback. Checksums identical. (Time to Party :wink: )

Then desolder and solder an the mainboard back again (now i realized that i definitely a new GOOD solder iron), connected the PSU and TADA. PC is booting again… but no Intel AMT

So with the knowledge about UEFIToolNE to validate the Binary from INTEL FIT Tool i made a binary again.

I found a short How-To here an Winraid

  • Turn off PC
  • Add Service Jumper
  • Turn PC on
  • Press F1 when warned about the PC booting into service model
  • Boot into Windows, log in as local admin
  • Run an admin cmd window
  • cd to USB drive.
  • cd E:\Intel ME System Tools v9.1 r7\Flash Programming Tool\WIN64
  • run fptw64.exe -d eastburn.bin -me
  • move eastburn.bin e:\
  • cd "e:\Intel ME System Tools v9.1 r7\Flash Image Tool\WIN32\
  • run fitc.exe
  • load e:\eastburn.bin
  • expand ‘ME Region’ → ‘Confirmation’ → ‘Features Supported’
  • Set the following:
    “Enable Intel (R) Standard Manageability; Disable Intel (R) AMT” = No
    “Manageability Application Permanently Disabled?” = No
    “PAVP Permanently Disabled?” = No
    “KVM Permanently Disabled?” = No
    “TLS Permanently Disabled?” = No
    “Intel (R) Anti-Theft Technology Permanently Disabled?” = Yes
    “Intel (R) ME Network Service Permanently Disabled?” = No
    “Service Advertisement and Discovery Permanently Disabled?” = No
    “Manageability Application Enable/Disable” = Enabled
  • Expand ‘Descriptor Region’ → ‘Descriptor Map’
  • Set ‘Number of Flash Components’ = 0
  • Build menu → Build Settings → untick ‘Generate intermediate build files’
  • File → SaveAs → E:\Intel ME System Tools v9.1 r7\Flash Image Tool\WIN32\eastburn.xml
  • Build menu → Build. Yes to prompt for ‘Are you sure you want to choose the Boot Guard Profile: “Boot Guard Profile 0 - No_FVME” for this build?’
  • Output .bin file will be “E:\Intel ME System Tools v9.1 r7\Flash Image Tool\WIN32\Build\outimage.bin”
  • copy outimage.bin to “E:\Intel ME System Tools v9.1 r7\Flash Programming Tool\WIN64\outimage.bin”
  • cd E:\Intel ME System Tools v9.1 r7\Flash Programming Tool\WIN64
  • run fptw64.exe -f outimage.bin -me MAKE SURE YOU INCLUDE THE -me SWITCH. Answer Y to ‘…fill enough data…’
  • run fptw64.exe -greset
  • pc reboots. Remove service jumper when PC is shutdown.
  • turn pc on. It may restart a few times, then it will boot OS.
  • reboot PC this time boot into the MEBx menu and configure settings with:
    MEBx login → default password is ‘admin’, change to ‘Jacobs5%’ (no quotes)
    Intel AMT Configuration → Manageability Feature Selection = Enabled
    User Consent → User opt-in = None
    Opt-in configuratuion from remote IT = Disabled
    Network setup → Intel ME Network Name Settings → Host name = (blank)
    Domain name = (blank)
    Shared/Dedicated FQDN = Shared
    Dynamic DNS update = Disabled
    TCP/IP settings → Wired Lan IPv4 Configuration → DHCP mode = Enabled
    Activate Network Access = Y (should change to ‘Full Unprovision’

After that Intel AMT with visible within the DELL Bios. MBEX is now accessable via the F12 Boot Menu.

BUT (there is everytime a BUT)
The Intel AMT Console via Web is an READ-ONLY. I can’t even power down / power up the PC.
All the work / the worries / the time for NOTHING ???

So, maybe the last question in this thread. The CPU is Intel i3 8100. In the Specs i found nothing about vPro capabilities.
Could it be, that it is simply impossible with this processor ? I cant believe it. KVM maybe, but simple, mainboard relating functions like power down / power up should be possible indepented from the processor.

I’m sorry. It’s simply to late here. There is a option to power down / power up.

so actually im trying to get KVM running. Within the MBEX Menu i see no options,
but this website says i have to use a Intel Tool named KVMControlApplication.exe to activate KVM (
This articel was written in 2011. So i think CSME maybe works different. In the Intel SDK linked in the article isn’t any binary file.
Maybe somebody has a advise for me.


big thanks to lfb6 !!!

Thanks for the feedback, congrats to a working machine :slight_smile:

Regarding AMT settings- you cited the ME 9 settings,they change from version to version, your ME 12 has slightly different settings (see #8)

For KVM (AMT) NIC, chipset and cpu need to have vpro capability. As mentioned i3 don’t have. Earlier this was clearly stated in the properties, now possibly some marketing i… found out that it’s better to no longer mention capabilities a cpu doesn’t have, thus leaving it unclear if the capability was forgotten or doesn’t exist.

Provisioning can either be done by the web page, a usb stick with a bin settings file, Intel software or via a trusted server ot other software. I’d recommend Meshcommander if you’re not in a large environment with existing management software.