Cannot create 6TB RAID 1 on x58 chipset

Hi Fernando & friends,

I just bought two 6TB drives to use in my old x58 Intel chipset motherboard with an ICH10R RAID controller but it reports the drives as 1.5TB instead of 6TB. I was running an old version of Intel RST (v10) that wouldn’t even let me see the disks in Windows. After upgrading to the latest RST (v15.7.0.1014) I can at least see the disks in Windows 7, with the correct size, but I cannot create a RAID 1 array out of them - the option simply doesn’t exist in RST. I can create a 1.5TB RAID 1 array in the BIOS, but it has no effect when Windows starts - the disks still appear separate.

Is there anything I can do with this old ASUS P6T motherboard to get a 6TB RAID 1 array working or do I need to buy new hardware? The motherboard is already flashed to the latest BIOS (1408).

@Bilge :
Welcome to the Win-RAID Forum!

Yes, you need to update the Intel RAID ROM of your mainboard BIOS to any version from v10.5 up. All lower versions do not support >2 TB sized RAID volumes. The best choice will be the v11.2.0.1527.
According to >this< BIOS modding success/failure table it should be no problem to get the Intel RAID ROM properly working with your mainboard.
Good luck!
Dieter (alias Fernando)

Actually, according to that table, the modder used "Intel RST RAID ROM v10.1.0.1008", and left the comment: "newer/bigger Intel RAID ROMs no go", suggesting that v10.5 would not work because it is newer. Am I reading that correctly?

@Bilge :
You are right - obviously only the BIOS of the ASUS P6T DeLuxe V2 accepts bigger a sized Intel RAID ROM like the v11.2.0.1527 one. I am sorry about my misleading answer.
Under these circumstances only the Company ASUS can help you by offering for your mainboard model a customized BIOS, which is able to load >100 KB sized Option ROM modules. Since I know, that the ASUS Technical Support has done it with other old mainboard BIOSes, it may be worth to contact ASUS.

As I am running an Asus P6T Deluxe V2 with an Intel OROM v15.1.0.2545 with a RAID-0 of 2 x 2 TB Seagate SSHDs with the drivers, I can confirm that it is possible at least on this particular board to get it to run with newer Intel Option Roms. But I had to create two 2 TB partitions instead of a single 4 TB. A major caveat though: I needed to crossflash it to the P6X58D-E in order to get it to work (see here for more details on this:…0#post_26300410). I don’t know if that works with other P6T versions.

By the way, while experimenting with the P6T WS Pro BIOS (which is also limited to the 10.X OROM), I’ve noticed some mild microstuttering in games (e.g. BF 3). As the only major difference was the Intel OROM, that might be the culprit. I know that Fernando does not recommend the OROM + driver combination I use, but at least from my own testing with my drives I have noticed that my combination gives me better results in comparison to the recommended 11.X combination. The newer driver does work in MSI mode, the older one uses a normal IRQ. MSI mode is known to provide better latencies.

@ms178 :
Thanks for your report.
Have you ever tried to insert a v13 platform Intel RAID ROM module? I suspect, that they are better for your old Intel RAID system than any v14 or v15 platform Intel RAID Option ROM.


Thanks, I have tried now the modded v13.5.2164 OROM with the driver and got mixed results. While the numbers in Chrystal Disk Mark 5.2.2. (x32) are very good at the first run after a fresh defragmentation, ATTO shows significantly lower read performance than with the newer v15.x OROM. But I have seen inconsistent results in both benchmarks before and will monitor the situation during the next few days. With the v15.x OROM it is the other way around, I usually see much lower read performance in CDM but very consistent good results near peak performance in ATTO in both reads and writes.

As a sidenote, the SSHD is expected to show at around 9.7 MB/s - 10.1 for 4K Random Writes in CDM once the algorithm puts it on the SSD part of the drive.

CDM_20170909201157.txt (1.94 KB)

ATTO135_1.pdf (63.7 KB)

My tip: If you don’t want to use the Intel RST driver v11.2.0.1006, I recommend to try the Intel RST(e) RAID driver v13.2.8.1002 in combination with an Intel RAID ROM, which belongs to the v13.2 series as well.
Any higher RST driver and Option ROM version will not 100% support your old Intel chipset.
By the way: The ATTO scores are not realistic, because this tool doesn’t use uncompressable files.

Thanks for the tip! Indeed, the v13.2.X OROM and the corresponding RST(e) RAID driver v13.2.8.1002 do work a bit better together. I should honor your recommendations next time earlier. :slight_smile:

CDM_2017091003756.txt (1.94 KB)

ATTO132_1.pdf (64.4 KB)

@Fernando Just for your information, the Windows 10 Fall Creatures Update contains a much newer version of the Intel RSTe driver (v from 22.02.2017). The 4K results were a bit better, but I still get very inconsistent read performance (usually it’s best after a fresh defragmentation but a day or two after that it dips into the 50-90 MB/s range).

@ms178 :
Thanks for the info.
To make this new Intel RST RAID driver v13.44.0.1026 usable for everyone, who runs any 32/64bit Windows Operating System, I am going to create a mod+signed variant and present it very soon within the start post of >this< thread.