Clover booting to a white blinking cursor on a legacy BIOS system

Hi there, I’m trying to boot from a NVME via a PCie 2.0 Adapter on my Supermicro X8dtt-hf+ server node, I was hopping to use the Clover workaround for legacy bios however I’m open to other boooader suggestions that support uefi emulation aka bridged spacer…

I flashed the latest Clover via Rufus on a MBR Scheme targeted towards uefi systems (Rufus wouldn’t give me another option), afterwards I transferred the NVME Driver over to both the BIOS and EFI directories as instructed.

During testing Clover boots to a black screen with a white blinking cursor.

Same goes for Duet and Redefined however the cursor color changes to red.

At this point I’m open to anything, I just need find a workaround that lets me boot from NVME on this older server…


Supermicro Chassie: 827-14

Supermicro Node: X8DTT-HF+

Specs per node: Dual Xeon E5660, 16GB’s of DDR3 ECC RAM (Two 4GB Sticks, One 8GB Sticks), and Special OEM Ami based BIOS 2.68…

Any help is greatly appreciated,

Mr Xeon.

It seems like, since the Xeon 5600 series was released around 2011, your system is a legacy one and probably non-UEFI.

I have some experience with Clover and I can possibly help you. See my post #817 here.

Step 1 : creating a Clover USB key that works

Since, when booting on your Clover key, you do not get the Clover menu but a black screen instead, you did not succeed in creating a Clover key that works. Latest versions of Clover are well known to cause problems with legacy systems. Because of this, I suggest that you try to create a Clover key using the BD Utility and Clover v.4961 (it worked for me and several other users who had a legacy system).

You will need a Windows system. You will find instructions and the 2 files you need in an attachment to my post #833 here.

Step 2 : installing your OS

Once, and only once you have managed to create a Clover key that boots and displays the boot menu, you can install your OS on your PCIe NVMe drive.

With the Clover menu on the screen, insert your OS installation disk (USB or CD ROM). A new entry should appear in the menu. Select it and see what happens then. Does it launch the OS installation process ? If it does not, I have other suggestions for you to try.

By the way, which OS are you trying to install on your PCIe NVMe drive ?

1 Like

Hey Morbius, thank you for assisting I truly appreciate it.

Just tried what you suggested, Now Clover boots to a black screen with a 6 and a white blinking cursor…

Used the BDU and Clover version you linked.

I’m trying to install/boot into a XCP-NG installation.

I was considering to try having Grub and the Linux Kernal stored on my Flash Drive for booting since once the Kernal boots NVME support should be available to access the Linux File System, however that has proven to be a little more hassle then the theoretical Clover Setup… do you perhaps have any further suggestions in order to get this booting?

When booting on your Clover key, you should indeed see a ‘6’ with a blinking cursor on your screen. But, 20 to 30 s later, the Clover menu should get displayed.

Have you created your Clover key on the same system (on which you try to boot Clover) or on a separate system ?

1 Like

I waited over a min, unfortunately it didn’t reach Clover Menu.

I am attempting to create Clover on a separate system…

So far I was actually able to move the boot directory over to a flash drive and boot via that method without issue… however still curious to why clover isn’t working as it should on my system, would be great to solve it and leave a footprint for future users who encounter a similar issue.

It looks like the Clover key you created on another system does not work on your target system.

I have read other users explaining that, for some Clover versions, the Clover key needs to be created on the target system (that is, on the same system it will be used on). However, I can’t say for sure because I personally did create my Clover key on my target system (I have only one PC so I could not experiment on that…).

Because Clover is a little tricky to install at first, I would suggest that you follow the method which worked for me step by step and try to use your target system to create your Clover key. Since BDUtility only works on Windows, it means that you will need to install a Windows version (could be Win 7, 10 or 11) on a HDD in your target system … just for the purpose of creating a Clover key with BDU !

I know that this can sound like a hassle since you intend to install a Linux server OS on your NVMe drive, but it might be your best option to succeed with Clover and finally get your Linux OS up and running on your system.

1 Like

Having to boot Windows on this thing would be he double hockey sticks.

However I seem to have already reached that level since moving Boot to a flash drive didn’t end up working out specifically with XCP-ng, it messed up migration/mounts thus many features were broken.

So I’m back to the drawing board, If I get desperate I might try the windows idea.

Any other ideas though for the time being?

Depends on whether you can get access to a spare - internal or external - HDD or SSD.

Personally, I have never succeeded in creating a Clover key that works on my system other than by using BDUtility under Windows on that same system.

So, unless you find an alternative way to make a Clover key that works for you - and I won’t be able to help you on this since I never found one - installing Windows on your target system for the purpose of using BDUtility may prove to be a good investment of your time at the end.

Or, you can wait for some alternate advice here, although I find this forum rather quiet those days…

1 Like

Yea seems that way atm.

I eneded up deciding to give your suggestion a try, I experimented with using a Windows PE build to run bdu on the target, nearly ran great but ran into issue where a dll was missing.

Unfortunately I wasn’t able to add it, I’ve started creating a Windows Live boot key to try a bit later today.

Hopefully it works out, I’ll be back with an update here soon.

Looking forward to learning about your findings …

1 Like

Hey I’ve got a update.

First off downloaded a Windows 10 Home ISO from Microsoft using a Custom User Agent, Flashed it to a Sata SSD via a USB 3.0 Encloser/Adapter in around 3 Minutes using the Freeware utility Win 2 Go, and finally connected that SSD to my Target Systems SATA Port.

That method allowed me to skip the Windows Media Creation Tool and The Windows 10 Installer, I was booting straight to Windows with a few basic system setup steps.

For anyone trying to reattempt that, I would suggest you try self customizing the Windows 10 ISO to not include all the extra bloatware and unnecessary setup features… it’ll save a little extra time. (However I didn’t end up doing that part)…

So after one blue screen of death… lets just say Windows got a little overwhelmed, I was able to Run the Boot Disk Utility as Administrator and setup the configuration as you suggested, I successfully flashed the suggested Clover version and copied the NVME express driver to those two directories as advised.

After ejecting the drive and waiting for Windows 10 to shutdown, I disconnected my SSD and Inserted the Clover Key… unfortunately it still Boots to a 6 with a Blinking White Cursor and stays there.

What am I missing, is this somesorta incompatibility I’ve ran into?

Any further suggestions would be greatly appreciated.

I have no idea what goes wrong with your system. You have followed the exact same method I described and which worked for me and many others, but you can’t boot Clover.

By the way, does your system boot in UEFI mode or in Legacy BIOS mode ?

1 Like

Definitely Legacy Mode, it’s a BIOS Based system.

Is Clover using DuetPkg for Legacy Support?

I’ve started trying to get Duet + OpenCore to chain load but I’m get the same results…

I’ve tested it now on two different Legacy Machines, so either I’m setting it up wrong or Duet is the issue all around the baord… why could Duet potentially not be happy?

It’s not my target system, it’s gotta be something to do with the file structure or the DuetPkg itself :person_shrugging:

It’s a good idea to try something else…

I won’t be able to help with DUET / REFIND. I have read others being successful with it. I was thinking that this method was only for UEFI capable boards, and you said that your system is Legacy only. However, as I said, I have no experience with DUET. Better read what others say about it…

Back to Clover, I was thinking of something you may like to try.
Since you mentioned that, when booting Clover, your system freezes after displaying ‘6’ (which indicates that you are using the boot6 file, why not trying the boot7 instead ?
To do this, under the Clover USB key file system root, remove the current boot file, and replace it with a copy of boot7, which you rename boot.
Any improvement ?

1 Like

I didn’t end up getting a chance to try this, Since my project was on a time budget I ended up changing gears last minute and invested into some bootable warp drives from Sun/SG.

Thank you for helping me try every possible combination haha, I truly appreciate it! :blush: :+1:

Hopefully this thread will come in handy for the next person attempting this.

Help, I followed exactly to instructions, after I inserted usb with win10 it showed up and i choose it, but then disk error press any key to restart