cpu upgrade leads to 30 min shutdown

forgive me firstly for my lack of knowledge in this area, however I will continue on and try my best to describe the issue I am currently experiencing.

I decided to upgrade my daughters laptop cpu and ram as she needed an upgrade for her school homework. The laptop model is a toshiba satellite C855 part no. PSCBWE.

The cpu I removed was an intel pentium B960
The cpu I upgraded to was a core i7 2760QM

Worked amazing for 30 mins then the laptop shuts off instantly even in bios. After my research online I have discovered that although the cpu will function, the hm70 chipset on this laptop model has some kind of block and a 30 min timer kicks in.

I am at a loss currently and approach you guys for help and would humbly request any advice on whether this can be sorted out. I have a very basic understanding here of what is going on however anything I can do myself to save you time I’d be happy to crack on with and report back,

Kindest Regards.

From the ME thread, download ME System Tools v8. Run MEInfo tool and show the report here. Also run Flash Programming Tool with the command “fptw -d spi.bin”. Does it show any error? The model you mentioned is not enough. The full model after PSCBWE is required for me to see that firmware it has.

hello, right, you are about to witness how utterly clueless I am with this stuff, I ran MEInfo tool, and a black box popped up on my screen for a split second, I assume its saved a log somewhere on my system?, I also don’t know how to run flash programming tool with that command you mentioned, do I type that in the run box because it doesnt do anything, sorry about this, anyway, the full model is PSCWBE - 02P00NEN

You need to open a command prompt (cmd.exe) and then run the tools. For example if you extract the System Tools folder at C:\ directory then:

1) Search for cmd.exe and run it as Administrator (right click on the result)
2) Type cd "C:\ME System Tools v8\MEInfo\Windows64" (or Windows folder if the OS is 32-bit)
3) Type MEInfoWin64 -verbose (or MEInfoWin if OS is 32-bit)

Same for Flash Programming Tool. A picture will do but if you want to redirect/save the output to a file and then compress and upload it here, then you can add a ">" at the end of each command (example: MEInfoWin64 -verbose > result.txt).

I was now able to find the model at Toshiba support. Lets see what the tools report first though.

right heres the first one, dont know if that will suffice, took a photo with my phone because I’m a clown and don’t know how to screen chop it…


hello, I’m having trouble getting the fptw64 to run, well it runs, but then it just says click any key to continue then disappears, what am I doing wrong? Again, apologies for this, you’re most probably slamming your face into your desk at this point! ha.

Such picture method won’t be helpful. Download the file I have attached. Since you have Windows 10, just go to any tool folder and then File > Open command promt > administrator and run these commands:

MEInfoWin -verbose > meinfo.txt
MEManufWin -verbose > memanuf.txt
fptw -d spi.bin > fpt.txt

Take the three resulting text files, compress them in one archive and attach them in this thread.

tools.rar (321 KB)

ok hope this helps you…

I currently have the pentium cpu in the machine, whether or not that makes any difference, kind regards.

i put the pentium back in once i realised the i7 was shutting off every half an hour, i can change the cpu back to the i7 and re run the tests?

Desktop.zip (3.17 KB)

Yes, I expected the i7 to be there during the MEInfo test especially. But it doesn’t matter. The ME firmware itself is healthy. The 30 minute shutdown is caused by the fact that Intel does not allow anything other than Celeron and Pentium processors work at the HM70 chipset. Basically the cpu you replaced is not “compatible” (intentional hard-coded limitation imposed by Intel) with the cheap HM70 chipset.

OK, so what are we talking here then, no solution?, or can this hard code be altered in some way with an hex editor?, also, would it not be possible to just purchase a hm77 bios chip and put that on the board? The reason I ask that is because there is a model, think its the p855-107 that looks identical to my model, only it runs the i7, and I can order a chip pre programmed from china for a fiver with any firmware flashed to it, would this infact work, or would that simply be opening up a whole other can of worms involving more restrictions.

I’m actually rather impressed with all this, so correct me if I’m wrong but I think what i have learned so far from this forum is that in this particular case, intel has locked the hm70 chipset to only work with celeron and pentium although theoretically it can work with core i processors, they have done this by hard coding some restriction into the chip, which is divided in ‘regions’, one of which contains the bios, although there is a different ME region which contains this hard code restriction that can probably only be altered by dissassembling and modifying the code using a hex editor. Is this all correct? This is amazing to be honest and you guys are providing a really good service for those looking to learn new knowledge and skills. Good forum.

The Platform Controller Hub (PCH or chipset traditionally) is a chip which is soldered to the motherboard and has nothing to do with what BIOS/SPI chip you buy, reflash etc. The HM70 PCH supports only Pentium and Celeron processors and the restriction is hardware coded/enforced at the PCH itself. Nothing you do at the cpu, SPI chip or the latter’s firmware will change that fact. So the SPI image regions and/or ME firmware in those have nothing to do with this restriction. The other laptop you mentioned uses HM76 chipset which can work with Core i-series cpus. Intel has a website with all their products and list the specifications, datasheets, what is compatible etc. Here is the page of the HM70 PCH cpu compatibility. To improve the performance of that particular system, pick the strongest of those Celeron or Pentium processors mentioned at the HM70 ark page.

Well plutomaniac, it has been an absolute pleasure mate. Thankyou for the help, I’ve learned alot. You don’t want to buy an i7 processor do you? Ha ha ha! Nah seriously cheers for taking out the time to help me. Appreciate it.

Actually, I do. I have a laptop which has the lowest end i3-2310M and wanted to upgrade the cpu to an i7 and the 2760QM is on my list. No joke! Send me a pm if you want to sell it and we’ll see if it works out.

Tell you what mate you can just have it for free, u saved me a whole load of hours searching around the web looking for a solution that didn’t exist. Send me ur address and i’ll pop it in the post its useless to me.

Another option is to buy a compatible C850/C855 motherboard with HM76 for this CPU, but @plutomaniac helped so many people here that he deserves this generous donation. Big thanks from me too, as such behavior is very rare nowadays.

Hi, new here! I got a busted laptop with an intel i5-3210M and decided to pair it on my samsung laptop with a b9-something on it and the exact problem was happening. Shutting down on 30min mark. I searched through the interwebz and there’s no real solution but to suspend your laptop at around 28 minutes or where you are comfortable. Sucks Intel did this. Back then i managed to upgrade a sempron laptop to a desktop athlon x2 cpu but the temps are through the roof and I did a water cooling due to normal laptop coolers does not fair well. But there were no locks like this.

If the second laptop has the HM70 PCH then yes, it was artificially limited to work with Pentium and Celeron CPUs only. There’s nothing you can do other than install the best Pentium/Celeron you can find. I think that was the last time Intel did that to a chipset, at least when it comes to CPU compatibility. So…yhei???

There is hope i guess. reading on…

[Update] Some success on other systems but the risk is great. Things to do for this to work:

1. I need to obtain my bios rom file.
-Samsung uses exe files for bios upgrade so extraction and manipulation later?

2. Download me_cleaner and flash the rom.

3. Reboot and hope laptop is not bricked.

Post the exe BIOS link if you can’t get it extracted, I can help you do that and probably figure out what to flash with and how.

Hi, I got the BIOS updater attached and some SS of my system if it helps. TY!!

On another note, the board the i5 came in have an HM77 chipset and I’m contemplating on getting the HM70 replaced on the samsung board. What’s the success rate on this method? Do i need to re-flash BIOS?

ITEM_20130402_1070_WIN_P05RAJ.zip (3.49 MB)

Screenshot (36).png

Screenshot (37).png

Screenshot (38).png

Screenshot (39).png

Replacing chipset? I assume you will need different BIOS, but maybe not? That’s not something I’m familiar with, I know you will need hot air station and a pro to do that for you.

If you are doing anything with the ME in this BIOS, as mentioned, I recommend you purchase a CH341A flash programmer first and a SOIC8 test clip cable, that way you can recover if flash goes bad.

Here is extracted BIOS from your attached exe file, phlash or winflash is used to update BIOS, I recommend finding non-OEM versions of the tool online instead of using “Samsung” version if you modify the BIOS
winflash or phlash INI files may need edited for flashing modified BIOS, with these versions or anyone you download too (Downloaded ones will be more in depth and have explanations too, if you need non-OEM versions of these let me know)