Dell Optiplex 7040 bios update: ME Firmware Update Faild: Image loading and HECI disable

Hello everyone,

I have a problem which occured after bios update. I see on the forum that lot of you have similar issues. I have read many posts related to this topic and it’s even more confusing so I am writing here because I am afraid that I will burn the mainboard with a wrong approach.

Basically, Dell Optiplex 7040 (service tag: B7T4XD2) (HWinfo states maindboard DELL 0Y7WYT Intel Q170 (Skylake PCH-H), i7 6700,16gb,256nvme + 2*2tb sata in raid1) after bios update from 1.2.8 on the last 1.15.5 and after POST a message has appeared with following text: "Error sending End Of Post message to ME: HECI disable, proceeding with boot"

I have established that the BIOS is updated to new version but ME firmware is not, for some reason the process was not finished. During BIOS update the following error has appeared: “ME Firmware Update Faild: Image loading”.

I have tried with different BIOS versions, but unsuccesfully. I have also tried to perform BIOS update from windows, dos USB stick, BIOS recovery console and always the same error appears, firmware update failed.

Sometimes HWinfo provides different results:
Intel AMT Support: Not Supported a and enable
Intel ME Version: v0.0, Build 0, Hotfix 0 and now

I cannot enter to MEBx menu with ctrl+p nor with f12, error is always appearing.
There was an option “Enable UEFI Capsule Firmware Update” included in BIOS which enables BIOS update and firmware via windows update services. I believe that the issue has started at this point or maybe I am wrong.
From what I have understood, firmware update is required because the firmware is corrupted, read-only etc.

I kindly ask your help and instruction from where should I start. step by step
Unfortunatley the computer guarantee has expired one year ago.

Also, for consolation, my colleague has identical Optiplex 7040 with BIOS version 1.4.5 and everything works perfectly, ctrl+p in order to enter MEBx menu also.
If necessary, I can download BIOS backup and firmwarea from his computer, just tell me how.

Thank you in advance.

Greetings from Croatia

To re-flash the CSME firmware, you need read/write access to its SPI/BIOS region. On the right of the white PCI slot, there should a 6-pin jumper. Look at the explanation/diagram at the bottom of the motherboard and set it to SERVICE_MODE. Boot the system, download ME System Tools v11 from Intel Management Engine: Drivers, Firmware & System Tools, dump your current SPI/BIOS image using Flash Programming Tool via “fptw64 -d spi.bin”, follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on your SPI/BIOS dump and flash the result back via “fptw64 -f outimage.bin”. Set the jumper back to its original position and run “fptw64 -greset”. After the hard reboot, the CSME firmware should be operational again.

dear plutomaniac, thank you for help but, I have a problem … I’m not very skilled

please i need help

1. I set the jumpers to service mode
2. fptw64 -d spi.bin (spi.bin attach 2 part)
3. download CSME System Tools v11 r42
4. download CSME 11.0 Repository r55 -> (.bin is att)

[b]5. i run fit.exe. -> I’m not sure, looking at further instructions I do not find "platform integrity"

7. please help me with these steps

spi.part1.rar (5 MB)

spi.part2.rar (2.47 MB) (3.62 MB)