Dell T3600 Bios to support NVME SSD (Success)

hi, guys,
I need some help to modify Dell T3600 bios to support NVME SSD (Intel SSD 750). I brought this pci-e card according to someone’s recommendation, however, it does not even support legacy bootup.
Now I am in stage 0 to learn how to extract out editable files from exe below. it seems that /writeromfile, and /writebinfile not working any more.


@cnwujianhua -
Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
I checked others dumps I have from this, and it’s probably V8 based on those, but check to be sure so you get the correct version tools.
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

*** Edit - Never mind the write test above or the dump info, this model has “service” jumper, we can dump entire BIOS and reflash entire BIOS at once with this jumper enabled.
This is a 2 or 3 pin header, may be hiding near memory tabs so look close in case it’s hidden there. Once you find ME version and get the ME tools, put jumper on the Service jumper on position, and then send me complete FPT BIOS dump like this >> FPTw.exe -d SPI.bin
I will edit for you and send back with info on how to flash it back.

hi, bro, a quick update, i followed the guide and extracted out SPI.bin as below lnk. let me know if u can open it.…dge?usp=sharing

thanks for your help

@cnwujianhua - You’re welcome! Here is NVME Mod of your dumped BIOS - with jumper on, program back BIOS >> FPTw.exe -f SPINVME.bin
Shut down, remove jumper, boot to BIOS, load defaults and save, reboot back to BIOS and make any changes you need, then setup your NVME…819704663032746

To do install of Win10, make sure your USB is GPT formatted, then put your Win10 install media on there. Then install to RAW or GPT NVME, or let Win10 set up the partitions (must be RAW or initialized as GPT, can’t be MBR)
Follow step #4 exactly in the “This is what you should do section” - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

I just tried it on the OptiPlex 790/990,and I proved the NVME module was flashed in the machine by examing the dumped bios.
But it could not show any PATA or windows boot manager in the boot list.(The NVME SSD had been install win10 on perfectly)
I think it would have something to do with the old bios structure.
I wonder if it work on the T3600.

I’ve never seen anyone have issue, but not sure how old you can go back, anything with UEFI BIOS should be fine provided mod done correctly , but you may need BIOS mod to access settings to enable Secure Boot / UEFI storage rom enable instead of Legacy rom only, hard to know without system on hand to test myself
I see your big thread about this too, and 790 is qQH65 chipset, so maybe something to do with old BIOS or certain chipset? Link me to BIOS so I can see about hidden settings that may need changed.
I see user with 790 here using bootloader, is this even UEFI BIOS? [Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method) (21)

For T3600 - we shall find out here soon

I checked 990 BIOS, nothing related to any of what we’d usually want to look at, set, change (no storage rom controller option, no UEFI/Legacy/Win8-10-or-Other, no CSM etc)
This probably why, I’ve never seen such things before, thanks for pointing out! Sadly, same for T3600 I see too, so probably this will fail for user above

Thanks,the bootloader can work even whitout UEFI bios.So I still think the old structure of the UEFI bios lead it failed.Actually Dell can add or fix something in this old structure bios to make it run well with NVME SSD.
Such as the post below I edit today(19.10.18)
Let’s collect mobos which have uefi bios but not support NVME even added nvme module!!!
ASUS released the new bios of F1A55-M LX PLUS(in the year of 2014),so that I can mod it to support NVME SSD even it had no CSM.<br />
Btw,I had modded T3610 successfully but SPI programmer.And it’s said that you can flash the T3630’s bios into T3600,so that it could support 22nm CPU.


@gloobox - Yes, I know bootloader methods both work fine without UEFI BIOS. That may be this users only option
Yes, that link you posted, that was “your big thread” I was talking about. I agree, Dell “Could” make new BIOS, but I doubt they will for anyone, maybe you could ask and see for T3600, since we’re discussing now and so we can see their lack of helpful response?
If you ask, do it directly via email, don’t use forum because that is almost always normal users replying, not Dell employees.

I think I helped someone do T3600 >> T3610, can’t remember, I know we discussed but not sure if he ended up needing it done in the end. On your convert like that, at now T3610 BIOS, can you use NVME mod on it and boot?

Certainly,T3610 was modded perfectly.I could use NVME SSD on it and boot well.

hi, Guys
@Lost_N_BIOS - thanks a lot. it works perfectly and now I am using INTEL SSD 750 as bootup drive. btw, do u mind share what tools u have used?

@cnwujianhua - Really, it works!??! Great @gloobox had me worried it might not, since it didn’t work for 790/990

Maybe some of those you didn’t get working need edited differently gloobox? Since, I expected this one to not work based on your comments, thread, chipset, what I see in BIOS, and what I found in google when you got me wondering about this too.
Did you try it on your T3600 before you flashed it to T3610, or was you more concerned about CPU support then and didn’t test NVME on the T3600>>T3610 until later on?

Actually Intel 750 NVME SSD owned option rom so that it could launch the system with T3600 without modded bios.

@gloobox - I thought only Samsung had internal rom like that? So, on that, and the Samsung, can you also use MBR, or still have to use GPT always?
He said in first post it wouldn’t work no matter what he tried, then mod BIOS = working

Sorry,I miss the word he said "ITNEL SSD 750".
And I know the SSD had internal rom such as INTEL 750/P3500/P3600/P3700/P4500/P4510 ect.(except INTEL 760p/660p),And they can launch the system even the mobo do not have the NVME module.
I once put the P3700 into ASUS p8z77-v deluxe with the official bios,and it run well.

Ohh yes, SSD Does not need rom anyway, only if NVME ones need the internal rom or NVME Mod. I don’t keep up on what’s what with all these, even the Samsungs, so I’m always lost

@Lost_N_BIOS @cnwujianhua
Hey!I just got the full bios of T3610.

@gloobox - Thanks, will add to the pile. I have others from T3610 I think, do you need them? Sorry, I didn’t know you needed, or I could have uploaded for you sooner
Also, I meant to link you before, but always forget. Join here, you can download one BIOS per 24hrs -

I manage to install windows 10 separately using MBR for legacy and GPT for UEFI, but it wont boot up after restart. I guess Dell T3600 have special boot up sequence bypass intel SSD 750 option rom.

Clean Install only one way, preferably UEFI Mode and then test. Do this install with no other hard drives in the system.

yes, i did clean installation but failed. btw, now i am facing another issue, cold starting windows 10 stops after windows logo, if i restart again it back to normal. any thing do with modified bios?