Dell T7910 Bios Unlock

Trying to Unlock all the Hidden menu’s and options on this board plus update the Intel ME region if possible.

I have already tried a few things but just haven’t had any luck.

I did go ahead and solder a pin header onto the service and amt jumpers on the board, so i think i atleast have a full bios dump from FPT Flash.

if anyone has any tips or can help me out that would be very appreciated!

Link for dumped bios!…DFOL19HBMQHOtww

Any one have any experience with these?

@tiredeathracing - What is BIOS chip ID, look with your eyes do not rely on software to tell you as it’s not always correct?
Is there only a single BIOS chip on this board, or two? If two, tell me ID of both, and then wait, I may need you to dump them with specific software/version etc.

Please remove solder jumper on pins, you don’t want that! Put a jumper in place when you need, and remove when you are done. What did you dump above file with, sounds like FPT?
Please also link me to the stock BIOS download page for your system

Hey Thanks for the reply @Lost_N_BIOS

I didn’t solder them together i soldered pins on so i can use jumpers. board was unpopulated for these.

chip ID is winbond 25q128fvsq

and here is a dump directly from the hardware programmer instead of FPT…waBrdVtGipHBGNA

stock bios link…doQT090/drivers

Ohh, OK, I gotcha now about the pins/jumper/solder

So, only single BIOS? If yes, OK. What software and version did you use for the dump above?

For W25Q128FV you need to use 1.18 version CH341A software, or use ASProgrammer 1.41, otherwise always fails.
Here is CH341A software package that has 1.18 -…213094641136166
And here is ASProgrammer 1.41 -

So, if you did not use one of the above, please redo dump using one of those and then re-up, thanks

Also wanting to do the all core turbo unlock mod, i’ve managed to flash a bios with no microcode but it freezes on bootup to windows and even the bootable disk

Yes as far as i can tell only a single bios, there is a 4Mb eeprom by the pciexpress slots. but unsure if that is related to the bios.
dumps were made with fpt on the first post and the 1.18 ch341a software for the hardware dump.

It could be bad bios mod, or could be your board wont run without microcodes. Did you load the FFS before OS?
Sorry, I really have VERY limited experience with that, so best you follow whatever guide you are using exactly, AND Be sure in google it’s been confirmed working on your exact board/model by someone.

I will look at menu unlock here shortly, but often not much is hidden, or we can’t mod, I’lll have to see how this BIOS is made.
Please use edit if you want to add more info, instead of making multiple posts in a row, thanks

Good to know you used 1.18 for dump, should be OK then. That is complete BIOS image at post #4, so whatever the other 4MB chip is it’s not part of the BIOS, or split BIOS Like some Dell etc.

* Edit - What is your main needs menu-wise, anything in IntelRCSetup can only be changed in place, other stuff I can possibly make visible for you, maybe.
Have you looked at the BIOS with AMIBCP? If yes, can you already see in BIOS, everything you see in AMIBCP at Setup >> Main (all contents inside, except deubg)

@Lost_N_BIOS I’m an idiot and forgot to disable c-states, its booting now with no microcode.
also in my UEFI boot menu i never get the option for the Intel ME stuff even if i press ctrl P.

See my edit above. Nice to see you got it working with no microcode!
Right now I’m currently trying to help someone do this Xeon/Turbo thing in PM and we aren’t sure if we should use method outlined at page 3 post #62 on the Anandtech thread, or use this method here

Do you mean AMT Stuff? If yes, it looks like that is disabled at ME FW side, do you want me to enable for you?



Amt stuff possibly, still not sure on all the nomenclature.
Whatever is supposed to be showing in this menu would be awesome.

Here are pics of all the current menu’s



Would just like to enable everything I can to be easily changed In the bios menu.

I’m not sure what you mean about the intelrcsetup?
Can that be displayed in the bios?

Not sure what you are showing me image of the boot menu for? AMT = Intel ME stuff you mentioned, I assumed you meant you were trying to get into AMT menus (MEBx etc)
Nothing ME related should be showing at the boot menu

I don’t need to see menu, only for you to answer my questions about it vs AMIBCP (Which by your last comment, I guess you have not looked at BIOS in AMIBCP)
No, IntelRCSetup cannot be added to the BIOS menu, at least not by me, but I can change anything you want changed in it.

There is NOTHING easily done here, which is why I asked what your main goal about the menu was. If you just need some settings changed that you can’t see we can do that easily, if you just need a setting or two made visible, that may be possible but not easy at all.
OEM BIOS, and especially this kind of Dell BIOS, it’s a mess to try and make things visible in menus you can’t already see. So if you just blindly wanted a BIOS menu unlock, this is not ideal or reasonable for this kind of BIOS, if you need some specific settings changed that is no problem (tell me what settings you need changed)

I will work out a list of things I need changed, I definitely appreciate the help! Also if we can manage to enable one menu that would be really helpful and I could probably replicate it after on other menu’s.

Any update on this project? I have a Dell T7910 that I would love to enable the All Core Turbo v3 on. That’s the only feature I’m looking to unlock, any hep would be rad. Thanks!

Basically all that needs to be done to unlock all core turbo is delete the microcode from the bios then flash, You will need to solder pins onto your service mode jumper in order to be able to flash a modified bios.
once you have the bios with no microcode make sure c-states are disabled in the bios and follow the guide for the all core turbo efi driver install.

@Lost_N_BIOS Can you tell me what the offset for the MSR 0xE2? I have the same chipset and bio’s as @tiredeathracing Huge Thanks in advance

I believe the offset is 19A6h but I want to be sure before I make a change like that. I got the Chip flasher just no soldering tools just yet.

I have a bricked 7910 motherboard, happened during bios upgrade. I have never done this kind of work before. I am good at following instructions and technically savvy. I have some really dumb questions, so please accept my apologies in advance.

1. Where is the bios located.

2. Can I use the raspberry Pi method to flash this bios.

3. I dont know how to do soldering, is it possible to use tester cable to connect to this bios ?

4. I see there are few downloads in this thread, i am dont know which one i should use to recover the bios.

Thank you so much for your time and consideration.

i figured it out, its the MX chip located near the screw MH9 enclosed in printed box that says SP1.

Hi friend, so none helped you , i will make it.

1. Where is the bios located.
1. The Firmware is into the Eeprom Chip (Bios is only a Region of it)

2. Can I use the raspberry Pi method to flash this bios.
2. Yes it’s possible as it has programmable channels, but it is very difficult to make, better use an CH341a (very cheap $.15,00 with the clip)

3. I dont know how to do soldering, is it possible to use tester cable to connect to this bios ?
2. You can use a Pomona Clip to get the eeprom chip wires easy …

4. I see there are few downloads in this thread, i am dont know which one i should use to recover the bios.
4. I don’t know your pc , so it needs to read on Bios Page Dell if threre is Recovery Bios and way to do …

I will give a look on Dell to see the possibility to Recover by as USB Stick and file your pc (Dell had it).

P.S. the Eeprom Chip has 8 pins and it a 25xx serie, MX Micronix , may be , post a photo please.

I was able to locate the chip and its made my MXIC Part # MX25L12873F.
I used CH314A with tester clip. to copy i used V 1.34. This is where the fun began, I had to dow grade software version in order to clear the old bios. Once i was able to to clear it using 1.18 , I was able to flash the motherboard and and do further updates directly.

I wish there was a way i can restore the service tag as it was over written during this process.

I hope you made a Firmware Dump before to write on the new one , so your System Data are into the backup and we have only to extract to rewrite into the new one.
Dell has some tools to make that …
Let me know