[Discussion] UBU Tool related Questions, Reports and Suggestions

You have here, a recent user, with a similar situation, he solved by getting a new SPI chip, now is performing tests but are not yet concluded regarding the old SPI/NVram or old Intel ME FW image on old SPI.

Read the whole thread to understand the possible causes.

EDIT: Glad you made it, presumably the EZ2 should be the one that doesn’t override the whole SPI… strange things happens…lol

1 Like

Thankyou for linking this to me.
I think I will buy a new BIOS chip then (which isn’t much a problem).

Or is here a guide on how to flash a .CAP Bios directly to a SPI chip with a CHA341 programmer? Because I have luckily one in hand.

Only thing that quite annoys me is that my motherboard has a plastic shell over the BIOS chip (Z97 Mark S) which will be quite annoying to remove as I have to unscrew the mainboard first in order to unscrew the plastic shell. Wish they would have placed the BIOS chip in a more accessable location or leave a small hole in the plastic shell to access the BIOS chip directly… :frowning:

I was able to fix this issue by just flashing latest stock BIOS via Asus EZ Flash Utility 2.
Now I’m able to use XMP again.

I tried exactly this before but instead with the BIOS Flashback USB function and this didn’t fixed my issue. I don’t know what BIOS Flashback via USB does different than EZ Flash Utility 2, but maybe someone else can profit from my finding/solution/fix.

1 Like

maybe if you want to mod, mod 1 bios from stock with UBU

then use MMTOOL to extract the dxe driver (remember the GUID shown when abt to change), mostly if OROM was changed its all on CSMCORE or CsmDxe, extract that, and the rest

For MCode, you might want to find the Guid 170- below MemoryPei, the one that’s not on DXE Driver. extract, then replace it to the guid 170 (size should be small) on very top, replace mcode as you want, save, and extract the verytop mcode, now with another clean stock copy, replace all the DXE you extracted to the same exact location

This way sometimes works on avoiding pad files getting destroyed.

Hi, the Intel_RST(e) updates in the original post seems down. Could I be possible to have a mirror to the Intel_RST(e) update archives?

Modules here (Mega and MS drive): AHCI & RAID ROM Modules - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)


You are largely right, the average user can indeed replace the essential files, but there are still some things that should be updated. I’m very sorry that @SoniX is no longer involved with the project. :frowning:


Sadness about the age or illness related retirement of important information “seeders” like SoniX doesn’t help the Win-RAID Community.
What we need are Forum members, who are able and willing either to follow their footsteps or to start a new Forum highlight…

I also struggle to find anyone that knows something about updating AMD AGESA… [REQUEST] Vivobook Pro 14 (M3401, AMD Ryzen 5000 Serie) - Bios SMU/Microcode upgrade - BIOS/UEFI Modding / BIOS Modding Requests - Win-Raid Forum (level1techs.com)

Can the UEFITool_NE in the UBU folder be replaced with the latest currently available version UEFITool_NE_A62? Or does UBU no longer work properly?

Why are there 2 identical versions of “drvver”? One is in the UBU folder, the other on the mega server in the modding folder:

Screenshot 2023-01-30 120302

I was able to extract my BIOS with the AMI tool. I am looking for updates for the Intel PRO2500 UNDI Driver and Realtek UNDI Driver. Where can I get these to update this?

Also, is there a way to find out what NVMe Driver I am using to update this as well? This is a chinese board with an AMD 6900HX.


Updated on LAN and other modules are all across this thread…search it.
Also here: [Updated] Latest ROM Modules (Not AHCI/RAID related) - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)
The NVMe is the Standard AMI module no update is available.
The Intel Pro2500 Undi has to be changed with UEFI tool, MMtool may not work for this.

Anyone having problems with XMP profiles after modding your bios, should try this procedure (took from ASUS Maximus VII Z97 Hero Big Sur Open Core Guide - Installation Guides | InsanelyMac) , it worked on my z97 sabertooth mark II :


Tools used(newer versions may not work correctly):

UEFITool 0.28.0

MMTool Aptio

AFUWIN64 tool v3.05.04 can be downloaded from the guide linked below

Open the older BIOS that has the working nvram driver. In my case version 1104.

Search by text and enter nvramsmi, in the messages section at the bottom you can click where it says found in PE32 to go right there.

Select the PE32 image section that is under NvramSMI/Compressed section and Extract body, save the bin file.

Take note of the GUID 842A45A… we will need this later. You can keep this open for reference and open another window.

Now open the latest BIOS in UEFITool in another window, in my case 3503.

Same as earlier search by text and enter nvramsmi. This time we will replace body.

Select the PE32 image section that is under NvramSMI/Compressed section and replace body with the bin you just saved.

After replacing it should look like below. Now save the new image.

Open up MMTool, Load Image and select your modified BIOS you just saved. Like I said this sounds redundant but just do it.

Go to the extract tab and scroll down to find the nvramsmi driver, the filename will be missing so using the GUID from UEFI tool you can confirm you selected the correct one.

They will also be in the same order as shown in UEFITool, so you can see NvramSMI is between NTFS and OpalSecurity. Match the GUID to be sure.

After you find and select the nvramsmi driver, click the browse and make a name like mmNvramsmi, then press extract, file will be saved

Now using MMTool load your unmodified latest bios file. This time go to the Replace tab.

Find the Nvramsmi driver again and select it.

Click browse and select the above mmNvramsmi, and then replace.

Save Image As, and name it how you like. I named mine mod.rom and then use AFUWIN to flash from Windows. USB Flashback won’t work since we are saving the rom without the capsule headers.

1 Like

Bug Fix: USU.BAT Line 714

Replace %xnbg% with %snbg%


Request new UBU build for Resizable bar support insertion inside bios!

Hello everyone,
The build date of UBU gets outdated. There are many new things to adopt UBU. One of those is at Releases · xCuri0/ReBarUEFI · GitHub waiting. Detailed explanation is at 🇬🇧 Resizable BAR on LGA 2011-3 X99 – how to enable and get extra performance - YouTube

UBU may check the presence of any similar type of ReBarDxe.ffs and may apply it like adding and changing microcodes. (M.2 disc support file NVMeExpressDxE.ffs variants also can be done either.)

SoniX seems like retired, but there are many people here can do this right? Waiting for new builds, otherwise this project seems like R.I.P.


What about you?
We are searching urgently for someone, who is able and willing to continue SoniX’s brilliant work.

1 Like

I can do for myself, but can be useful for many other people, why are you negative to opinions by others? Can’t you say, well thank you we can try like something. I did not say and bad for SoniX, retirement is not denying previous works. He was a Russian, I hope he is still alive, god knows where he is. After the leaving people, things can not stop…

He is a Russian and according to >this< page still alive (has been online there on 06/26/2023).


@Fernando, I sent to @SoniX my version of UBU, he is working on a new version. drvver and other. Dont touch LAN.
His eyesight is damaged after COVID.


Thank you @Michael_Code for not letting this tool on a “limbo”, really appreciate your effort and contact with SoniX regarding further development.