[Discussion] UBU Tool related Questions, Reports and Suggestions

Press F for update Cpu microcodes

Ok, appears "replacement" empty and "press a key to continue" only


Attach the original BIOS image or link,

If replaced in UEFUTool 0.26.0, there will be the same problem.
Old versions - old engines. :frowning: But everything is solved. :slight_smile:



Funny. The microcode file does not contain the search string to search for.


2455434F44455653 -> $UCODEVS

I will look for more common options.

Nice release for sonix!!!i update my x99 chipset 6950x with new cpu microcode!!!no problems all done!!!
the latest cpu microcodes is very iportant?incrase perfomance and security i think

Thanks , but what does it mean? I don’t understand : )

That pattern is not proper. For some time AMD was using $UCODEVS (? - most common), $UCODE2K (2K microcode size) or $UCODE4K (4K microcode size). But they stopped at Ryzen. So this scheme applied for a few years only, not before and not now. Thus, useless. Typical AMD. To detect AMD microcodes, the best possible pattern I use at MCE at this point in time is found here. This works for all microcodes since the beginning (2002).

# AMD - Year 20xx, Month 1-13, LoaderID 00-04, DataSize 00|10|20, InitFlag 00-01, NorthBridgeVEN_ID 0000|1022, SouthBridgeVEN_ID 0000|1022, BiosApiREV_ID 00-01, Reserved 00|AA
pat_acpu = re.compile(br'\x20[\x01-\x31][\x01-\x13].{4}[\x00-\x04]\x80[\x00\x20\x10][\x00\x01].{4}((\x00{2})|(\x22\x10)).{2}((\x00{2})|(\x22\x10)).{6}[\x00\x01](\x00{3}|\xAA{3})', re.DOTALL)

hi !
i am not able to update the microcode on my ASUS M5A97 R2.0 bios file .

i have extracted the latest UBU tool (UBU_v1_71_1) and also placed the MMTool.exe v5.0.0.7 as mmtool_a4.exe in the UBU directory.
but even after pressing F, it still doesnt update all missing AMD microcode’s .

seems like there is a typo error at line no. 1493 in UBU.bat file ?
where :-


should be :-

-Thanks !


Yes, I have seen, but you cannot explain UEFIFind like.
And the transition to Python is not so fast. So you have to improvise.

For Ryzen (Aptio V), there are no problems yet, the microcodes are mostly in Padding.
For old (Aptio 4) will have to install an explicit GUID.





I’d like to say " PERFECT! and Thank you very much all staffs "

@Sonix @Fernando l @plutomaniac You are the best.

EDIT by Fernando: Attached pictures resized (to save space) and re-attached by using the Forum software. They can be enlarged by clicking onto them.

I use the microcode 49, the following are warmer the cores (TJmax increased from 105 to 110°) but thanks for the infos

Thanks, it’s good :wink:


Open ubu.bat any text editor.
Find and replace










@Sonix, you can resolve your issue in UEFIPatch by updating the address of the FIT (that’s changed in that firmware because FIT is located in a file that got moved because of new microcode file having larger/smaller size). AFAIR, you are already updating the table itself to point to the updated microcodes, so you need to add a step to update the FIT reference (this is what “not referenced from the last VTF” message is about).
The reference is located at address of “end of BIOS region - 0x40”, and is used by ME FW to find FIT and load stuff from it. Before BDW it was optional (that’s why some earlier images worked even with broken FIT), but now it’s mandatory and the system hangs very early in boot if FIT can’t be found, which is exactly what happens in your case.

@SoniX :
Done! Working and flashed!
Good job!
Thanks very much!

Unknown VBIOS


vbios.zip (22.8 KB)

I got this message:
"MMTool not present.
Replacing microcodes will not be available.
Recomended MMTool v5.0.0.7 as mmtool_a4.exe"

I have the modded version of MMTool.exe (build Should I additionally get build, rename it to MMTool_A4.exe, and have TWO/2/II/DVA/ZWEI/"Language Limit Reached" MMTool files present for the most flexibility? I would appreciate a PM for MMTool because its very Googlable.

How can I fix this? I’m confused? Use UEFITool 0.26.0?

Or is UBU Tool fixed now?

i have found "experimental" function in UBU_v1_70 that produces a file called BIOSLock_str.txt , in my case it shows BIOS Lock VarOffset - 0x7E … can i use this offset value in Grub EFI shell to unlock bios??

@MonarchX :
I do not recommend to add 2 different versions of the AMI Aptio MMTool to the UBU folder. Users, who get the message “MMTool not present. Replacing microcodes will not be available.” should follow the advice given by the UBU script.

Please look into the start post of >this< thread and read carefully the red marked text of the “Preparations” chapter.