Flash Asus P8Z77-V LX BIOS issues

Having issues flashing a P8Z77-V LX BIOS. I am trying to update my bios and started by flash a new existing bios from someone else but don’t see the new splash screen that is suppose to be there after flashing. I suppose something is gone wrong flashing. I am using freedos to flash the bios and get the following output:

C:\TEST>AFUDOS.EXE morph2.rom /GAN
+ ------------------------------------------------------------
AMI Firmware Update Utility v3.06.01
Copyright (C)2014 American Megatrends Inc. All Rights Reserved.
+ ------------------------------------------------------------
Reading flash ........ done
- ME Data Size checking . ok
Erasing All Block ............... done
Updating All Block .............. done
Verifying All Block ............. done

any help appreciated.

You just want NVME Mod BIOS, correct? If yes, please flash to latest BIOS version stock BIOS using EZ flash and USB, then do the following

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

Fortunately there was a DOS version. I assume you need the bin file:

Main thing is to enable NVMe support indeed but any other stability and security improvements are welcome.


@osrcs - Why fortunately DOS? But yes, you can use DOS if you want.
I don’t need your biosreg.bin file yet, you will likely make another later, that I will want. Right now, I’m waiting on an image of the error you get, if any, when you try to write back the file you just dumped (see the bold part of the instructions )

And, please confirm, which BIOS exactly did you flash at first post example? Sorry, I thought you used MORPHEMIC’s BIOS at first post of this thread, which has the logo change I mentioned, but I just now see you do not have that model of board so you wouldn’t be able to flash that BIOS.

Don’t have windows.

Lol. missed that.

C:\FPT>fpt.exe -bios -f biosreg.bin
Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.
Platform: Intel(E) Z77 Express Chipset
Reading HSTSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q64BV ID:0xEF4017 Size: 8192KB (65536Kb)
Error 280: Failed to disable write protection for the BIOS space!

[quote="Lost_N_BIOS, post:4, topic:34280"] And, please confirm, which BIOS exactly did you flash at first post example? Sorry, I thought you used MORPHEMIC's BIOS at first post of this thread, which has the logo change I mentioned, but I just now see you do not have that model of board so you wouldn't be able to flash that BIOS. [/quote]
I tried that version indeed. Thought that would work cause the title saids its for all variants. How can I change something visual to the stock version so I can see if flashing worked?


Do I need to supply more info? If so which?



Looks like I finally made a step forward. Need to downgrade the bios before flashing the modded bios:

- fpt -bios -d stockbios.rom
- with ezflash flash this stock bios from asus: P8Z77-V-LX-ASUS-1603.CAP
- make changes to stockbios.rom and save as modbios.rom
- fpt -bios -f modbios.rom

Now it does not give an error. Will check as soon as my nvme drive arrives.

Are there any other bios mods that are advised?

@osrcs - Thanks for the info, and sorry for delays (I can’t keep up here with all posts )

You can only use the BIOS for your model, the title simply means that all variants are discussed in that thread (it shouldn’t have all been merged together is the issue there!) So, nothing was flashed, it only appeared to flash, lucky for you

Please slow down, stop trying to force things, wait for help, before you brick your system, especially with FPT!!

Please flash latest BIOS using EZ Flash, then do the following to remove 280 error - You can start at step #6, I’ve gathered info you need below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename your .efi file to >> Shellx64.efi

Variable to change at grub >>
SMI Lock, VarStoreInfo (VarOffset/VarName): 0x88
BIOS Lock, VarStoreInfo (VarOffset/VarName): 0x89

So, at grub prompt you will type the following, one line at a time, enter between each (case sensitive)
setup_var 0x88 0x00
setup_var 0x89 0x00

Then reboot, dump BIOS again with FPT, send me that or modify yourself, then flash back with FPT

… Very slow retailer …

… I finally got my NVME drive yesterday and that seems to work \o/. However when installing I found out that VT-d does not. Is there a way to change the bios so that will also work?