Gigabyte B85M-H3D 30min Shutoff

Hey guys, after hours and hours of troubleshooting i’ve been led to this site finally with a sense that someone knows what’s going on here…

So my computer didn’t want to start this morning, checked a few cables, power cycled and finally got to a bios screen that said it had been corrupted and that it was restoring it! Hooray! Not…

I accidentally bumped my tower right on my power button and it shuts off mid restore and I’m guessing it must’ve messed with IME and AMT or something because now it shuts off every half an hour which seems to be the running symptom for this…

I ended up downloading a fresh bios (old bios was F4, new bios is F12) but that didn’t seem to fix it. I’ve tried resetting the bios with the cmos jumper, power cycling and tried taking the CMOS battery out (which now bootup is a lot slower after that…)

I am running a Gigabyte B85M-H3D Motherboard with an 85 Series Chipset.

I’m only running Windows 7 Ultimate 64x though if that helps :frowning:

I’m pretty good with this stuff usually but dumping and flashing all sounds way above my pay grade.

Cheers for your help,
I’m completely lost and don’t want this computer to be a brick,
Lyrikal

Because of gigabyte board has dual bios,you could try follow method:

all of first you should best to have a PS/2 keyboard,if USB keyboard you could also try it.

now your computer is on power off stauts.

1.power on your computer,now press Ctrl+F10 button on keyboard as quick
you could see prompting on screen about swap slave bios to master bios,selecting yes by following the prompting,after finishing this step the computer power would shut down.

2.power on your computer again,now press Alt+F10 button on keyboard as quick
This step means copy master bios to slave bios,selecting yes by following the prompting,after finishing this step the computer power would shut down again.

3.power on your computer,now press Ctrl+F10 button on keyboard as quick,this operation means repeating step 1.

If after all above steps computer still has same problem ,you should consider about your hardware such as keyboard,mouse,memory moudle and power supply.

Sorry for my poor engilsh and poor communication,if you have any questions else,I wll try my best to explain.

@Lyrikalx - You are correct, this means the Intel ME FW is corrupted, due to that you will have to reflash the ME region and it’s a little more involved than regular BIOS flash.
What revision is your board? I checked Rev 2.0/2.1 and latest BIOS is FD, Rev 1.0/1.1 and Rev. 1.2 latest is F15. So I assume you have a Rev 1.0-1.2, do you want to get flashed to latest BIOS or stay on F12?

If you want to flash to latest version F15, please do that now, download the F15 BIOS - http://download.gigabyte.us/FileList/BIO…85m-d3h_f15.zip
And put on FAT32 USB then from within the BIOS enter Qflash and select that BIOS file and update the BIOS.

Then, once you are done, here is how to fix the ME FW - go to this thread and in the section “C” download ME System Tools Package V9.1 package
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Win32 folder.
Copy the file below (unzipped) into that Win32 folder and then back out of the folder and select that Win folder itself, then hold shift and press right click, choose open command window here (Not power shell).
http://s000.tinyupload.com/index.php?fil…801623481140832

At the command prompt type the following command to reflash the ME Region >> FPTw.exe -me -f mereg.bin

Then before closing out that command prompt type this command and hit enter (It should auto-reboot, so be ready, if it does not then go ahead and reboot)
FPTw.exe -greset

If you see ANY errors at the command prompt while using FPT, stop, do not proceed, and take a screenshot of the error and show me.

Thanks mate. At work right now so I’ll give it a go when I get home. That being said, she wasn’t making it to POST at the end of last night, hopefully she’s less cranky when I get home.

Also just to clarify, im flashing a downloaded FW onto my ME, not dumping, cleaning and reflashing,correct?




Lucky I double checked your link! The bios you’re looking at is d3h! Mine is h3d! It was hard discerning the difference myself when looking up my part. :stuck_out_tongue:


Noooooot having a fun day. The computer is booting (albiet slowly, after removing and reinstering the CMOS battery, if that helps).

Also trying to download both the System tools and the MErig.rar but both are at 100% but not completing for some reason… why of all times do things not download right now?!

Aside from that, still just fighting this 30min shutdown endlessly until I get those downloaded and get back to you…



Finally got it downloaded by backdooring Chrome downloads and just editing the file extension and wallah! there they are!

Now! I started up the command prompt, typed in what you told me to write and it told me the program needed administrator privileges, so I made it always run as admin.

Ran the command line again, another prompt window popped up and it said went away really quickly and I went into the folder, checked the error log and it says “Error 7: Hardware sequencing failed. Make sure that you have access to target flash area!”.

So not sure where to go from here :frowning:

Still shut off after 30 mins. Waiting your reply to see what to do next

@Lyrikalx - First off, slow down and do only as directed or wait for help/advice You said I linked wrong BIOS, why did you continue to use anything I posted after that??? Also, if you need to add more thoughts after a bit, please edit your post and add them in, thanks.

Very sorry for the incorrect board stuff, I copied/pasted your model from here, and then first result in google which is usually correct one was the wrong one, and I didn’t even notice! So you should not use the files I mentioned, none of that.

Checking now for the correct BIOS, and will get you the correct ME FW. And no, no cleaning extracting etc is needed for this process since I am pulling the FW Directly out of the BIOS for you.
Checking at Gigabyte’s site, there is no GA-B85M-H3D model, are you 100% certain this is your model? Show me the sticker on the board and CPU-z motherboard tab image >> https://www.cpuid.com/softwares/cpu-z.html

GA-B85M-H3D-NoResults.png


For now, until we sort that out, do NOTHING and wait, this way your situation does not get worse.

No need to edit any file extensions for anything I sent you, the ME FW should be MEreg.zip file, and the ME System tools package should be >> Intel ME System Tools v9.1 r7.rar

When we do get the board model figured out, and go to flash the ME FW, what you described is not the correct process to run the command prompt how I mentioned, nothing will open or close quickly, but you may need to approve running as admin.

To do it properly, you go into Flash Programming Tool folder, and inside that you see a Win32 folder. Select that Win folder itself, then hold shift and press right click, choose open command window here (Not power shell).
Then an Admin command prompt will open right there, at the correct folder location, and all you’ll need to do is type the command I mentioned. You may need to approve running as admin, but there should not be any new command prompts or other windows opening or closing quickly etc.
If that happens, it’s wrong and will not work, do it again, as I mentioned - If you don’t understand how that should work as I explained it, let me know and I will make you a short video, otherwise this will not work properly.

Here, I went ahead and did that now, just to make sure you see how it’s done (And I enabled the security/UAC prompt so the video will match how your system should act since you have this enabled still, but this does not create a UAC popup - and I see this is not Admin prompt, so = problem!)
Seems this does not work the same on non-Admin accounts, so I’ve created a shortcut for you to use. Put this inside your “Flash Programmer Tools >> Win32” folder, then run it and approve the UAC Prompt.
Then continue with the commands as mentioned (once we confirm what board you have, do not do anything for now/until then) This requires “C” to be your main system drive, and the “Intel ME System Tools v9.1 r7” folder needs to be copied to your desktop.
So, make sure it’s all setup just how I show in the video, this is how the shortcut is setup, if your stuff does not match it wont open properly and you’ll need to navigate to the correct folder location via CMD prompt
I’ve made the video in three formats, hopefully one of them you can view without having to hunt down codecs - here is the videox3 and the shortcut I made for you
http://s000.tinyupload.com/index.php?fil…226175486546338


I await your double-checking the board model printed on the board itself, and a CPU-z motherboard tab image

Heres the link to the mono for you. Revision 1. :slight_smile: https://www.gigabyte.com/Motherboard/GA-B85-HD3-rev-1x#ov

Just realised I’ve written H3D instead of HD3. God damn

@Lyrikalx - Hey, now I could have found that, sorry I didn’t realize the model name was still wrong when you corrected me too

Glad to catch you online right now, please wait, and I will edit this post with updated instructions for you! Download the above video and shortcut I made for you, and get that ready to use FPT
Which motherboard revision do you have? Look in bottom left corner of the board - None of those have F12 BIOS as an available option, so please check the board and show me CPU-z motherboard tab image too so I can see what current BIOS is and what version board it’s saying

* Edit, sorry, I see now you said Rev. 1.0 above, is that really what it is? If yes, where did you get BIOS F12? Link me to F12 so we can use that,
Rev 1.0 only has F11
https://www.gigabyte.com/Motherboard/GA-…support-dl-bios

Also, you do realize, you now linked a B85 board, not B85M, correct? Lets stop all this confusion now, please post an image of CPU-z motherboard tab for me, thanks!
There is B85-HD3 and B85M-HD3 - we need to be sure you are using correct BIOS now, and that I use correct BIOS to help you fix this. So please also check the board itself and confirm what model you have, along with show me CPU-z image of motherboard tab

B85M-HD3 Rev 1.x does have BIOS F12
https://www.gigabyte.com/Motherboard/GA-…support-dl-bios

At work once again but I’ll check it all out when I’m home. I’m 90% sure it’s B85M-HD3 but I’ll check when home and get back to you.

Yes, please confirm exact board model and revision, and for my sanity also provide CPU-z motherboard tab screenshot too

No worries. Should get back to you in just over 4 hours when I get home. I will have the original box too so I’ll include a photo if possible just to put your mind at ease

Here’s the link to the support page with the F12 bios that I used. https://www.gigabyte.com/au/Motherboard/…v-1x#support-dl

https://imgshare.io/image/PAKt
https://imgshare.io/image/PW2j

Here’s some pictures of the manual to put your mind to rest

And here’s the correct link to the support page for my mobo
https://www.gigabyte.com/Motherboard/GA-…v-1x#support-dl

@Lyrikalx - Thanks for confirming everything finally

You still will use all the same version ME tools I linked you to before, so grab that video and shortcut I made for you and watch the video and set everything up just like that.
Then copy this ME file into the Win32 folder, that’s inside the Intel ME System Tools v9.1 r7\Flash Programming Tool folder on your desktop. Then run that shortcut, and type the following command >> FPTw.exe -ME -f meregnew.bin
http://s000.tinyupload.com/index.php?fil…929935389650233

Once that is done, before you reboot or close the command window, type this command and system will auto-reboot >> FPTw.exe -greset

If the system does not automatically reboot after the above command, lease shut down the system, remove the PSU 24pin and 8pin cable from the board, remove the CMOS battery, and then press and hold the case power on button for 15-20 seconds.
Then wait 1 full minute before putting the battery back in and connecting the power cables.

http://imgshare.io/image/error7.Y8w6

Error 7 :frowning:

Sorry I took so long! Works had me buckled for a few days. <3

@Lyrikalx - No problem about the late reply. I need to see full image, I need to see command you gave before this error too, so I can be sure of cause, looks like you are maybe putting in wrong command. So expand that window or redo and show me full image of all command given and the output.

Also, with FPT, please run this command and send me the file >> FPTw.exe -desc -d FD.bin
Then wait, do not keep trying things.

http://imgshare.io/image/error7v2.HXGF

I am very thorough with my typing I would like to think :stuck_out_tongue:

Let me know your thoughts,

Thanks

@Lyrikalx - I can’t see the entire window, specifically title bar is covered, does it say Administrator? If yes, OK/Good!
Please also send me that created fd.bin file, so we can confirm if ME region is locked from write in the FD or not (Gigabyte usually doesn’t, but looks like they may have on this one)

Yes it was in admin! Sorry! Didn’t realise i’d hovered over my chrome window.

http://s000.tinyupload.com/?file_id=52627918676640492258

Thanks. Just as I thought, since Gigabyte never locks this kind of stuff, all is unlocked (every region) same as the stock BIOS file

FD-Unlocked-BIOSLockDisabled.png



Do you have updated ME drivers installed in windows? Do you get the same error in DOS?

Maybe it is the BIOS interface lock being enabled, I’ve never had to disable that though, and especially not in a Gigabyte board they usually leave it all unlocked, but lets check
Disable that via grub w/ >> setup_var 0x67 0x0

Then reboot and try FPT again in Windows or DOS

How do I check if I have updated drivers? And what do you mean in dos vs windows. Aaaaand what’s grub. Sorry, you’ll have to explain a bit more >.<

@Lyrikalx - You go to the Gigabyte page for this model, then support, then find the ME driver and install it along with “chipset driver” Too.
This is below, in the “Chipset” Tab - you need to install “INF” Package, and “Intel Management Engine Interface” - pick correct one per your OS< or choose your OS at top first
https://www.gigabyte.com/us/Motherboard/…-driver-chipset

Sorry for all the confusion there, I thought you already knew about grub w/ setup_var, must have been thinking of another discussion.
Never mind about that, I can just edit in a BIOS for you, please flash this BIOS, it has unlocked “BIOS Interface Lock” (I added the M to the end of the name, to mean Mod, it’s correct BIOS )
http://s000.tinyupload.com/index.php?fil…431778271980773

About DOS vs Windows, I meant DOS Flashing via FPT, or windows flashing via FPTw.

To flash from DOS, make DOS bootable USB Stick this way >> Follow steps 1-4 to create bootable USB
<Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

After you are done creating the USB, copy all files from Flash Programming Tools folder > DOS, into the root of the USB (Not in a folder), and a copy of your me.bin
To flash in DOS >> FPT.exe -me -f me.bin

The BIOS I posted above has ME Re-Flash enabled, and BIOS Interface Lock disabled. Flash this BIOS via Qflash from within the BIOS (F8), then reboot back to BIOS and flash it once again, then reboot and check ME (Or if asked first time, and or second flash session, if you want full or partial, you want full flash)
This may reflash the ME on second flash, since I enabled that setting. Once you are done, and we get ME fixed, flash back in stock BIOS (This BIOS will have ME Disabled, so that Re-Flash can be enabled). This may also be the reason for the FPT error, I’m not sure
After this double BIOS flash, try the FPT flash again in windows, after you’ve installed the drivers. Then if no luck, try from DOS, if no luck there, then flash back in stock BIOS so ME isn’t disabled via the Re-Flash setting for now.