Gigabyte EP45-DS5 AHCI/RAID ROM update problem

Hello. I have gigabyte EP45-DS5 motherboard with F12 bios. Couple days ago I put Xeon X5450 into my board. I have edited bios, NCPUCODE part of bios, and put new cpu microcode inside of my bios. CPU is now working without any problems but I wolud like to update AHCI bios to 1.2E version but I have very big problems. I try to insert ICHAAHCI.BIN and ICHARAID.BIN but when I replace that modules with new and save my bios that board want start. Than I have extracted and released all modules after problematic MINIT module but when I replace ICHAAHCI.BIN that is two lines before MINIT than my new bios want to start. When I replace all modules after MINIT module than board is working like normal. Here is list of my bios:


@ mdrazic:
Welcome at Win-RAID Forum!

Yes, as written within >this< guide you should not use CBROM32_198, when you want to modify any AWARD BIOS module, which is listed above the sensitive MINIT module.
Such modification is difficult and should be done according to >this< guide.

Dieter (alias Fernando)

Thanks for your reply. I don’t think that I will be able to build my custom rom by myself :frowning: . I must use cbrom155 for modules before MINIT module? I have all modules extracted including updated. Please can you or someone do it for me sensitive part of this mod?

Here is a fixed BIOS file. I have replaced all PCI modules with updated versions, plus added a dummy.bin to avoid MINIT relocation. Now you can re-add your microcodes and test the system. But Gigabyte has also posted a F13a, any reason to avoid it?

ep45ds5.f12.mod.rar (605 KB)

Thanks, I will do it now. F13 was very buggy for me and also I have wrong flash several times flashing f13 bios. Beta is beta, official is official.

If you change your mind or need it for some reason, here is F13a with the same updates.

EP45DS5.13a.mod.rar (612 KB)

Thanks, thanks, thanks :slight_smile: moded F12 with my xeon is working and boot time is lowered very much. I forgot, what is main difference f12 and f13?

There is no official changelog, but the changes are all over the place:


But if you meant between F12.mod and F13a.mod, there is no real changes apart from the official ones, the same 4 PCI modules have been updated to the latest version and a dummy.bin (different sizes, according to each file space) was added.

I am not using raid but I just tryed and found that raid is not working when I enable it in bios. Ahci 1.2e bios is displayed without CTRL+I option but no booting. I am using 1 SSD and 2x1TB HDD over ahci and when I select AHCI than my ssd is booting normaly.

Do you mean that the RAID boot menu is not appearing? Or that there is no boot in RAID mode?

I don’t think you can easily switch to RAID boot without actually installing in RAID mode and having compatible RAID drivers.

Yes, raid boot menu is not appearing without CTRL+I option, only ahci 1.2e rom. I have 2 same 1TB HDD drives and I can create raid fields on it but I can’t see raid option. Also when I select raid mode than my ssd want boot.

I don’t have RAID experience, this is where Fernando is the guru. But is my impression that the RAID menu should appear only when pressing CTRL+I. If you see a screen with when pressing CTRL+I, then it is working. Your SSD can’t boot in RAID mode without RAID drivers.

But this could be a size problem. I updated to the best version for your system, with TRIM, but it is almost twice the size of original OROM. You can try to lower the version of RAID ROM (ICHARAID.bin) with one from here. It should be safe to do it on your own now.

I think that only RAID MSM versions will work correctly. New version are RST and that version is no working for me. Because I have 1 ssd for system than it will not work in raid mode but I have also 2 x 1TB hard drives that will work. I will replace MSM RAID rom and try.

RAID MSM rom version is working

Hi Mdrazic, can you send me the final version of the BIOS file that you installed on this motherboard? I have a Xeon 5470, my boot is not fast, the RAID controller and AHCI do not go as it should. I’m interested in trying your version of the BIOS upgraded. Now I use a F13d version downloaded from the Internet and I do not know if it has included ncpumicrocode for my x5470 Xeon. Thanks in advance.

Welcome to the Win-RAID Forum!

Maybe you haven’t realized it, but Mdrszic’s last post is already 3 years old.
My personal advice is to replace within the BIOS the Intel MSM RAID ROM by an RST one (v10.1.0.1008 or - if possible - v11.2.0.1527).

Dieter (alias Fernando)

Hello Fernando, on my GA-EP45-DS5 motherboard I already have the latest BIOS F13d update, which I would like to think is the micro codes for my xeon x 5470 are also introduced. What I found in this post is a F12 and F13a bios mode which I do not know which program to use to put their xeon microcodes. For "Intel MSM RAID ROM with a RST (v10.1.0.1008 or - if possible - v11.2.0.1527) ‘’ do I have to add firmware to the new bios modified with xeon microcodes? My Bios is the Award.
P.S. What annoys me is that I can not install Win 10 from either the usb stick or DVD and even if I do not use RAID 0 or 1 I would like to use SATA ports to put more HDDs around 6.

Why do you want outdated BIOS versions?

I recommend to replace the currently working Intel MSM Option ROM by a better matching Intel RST Option ROM. The Intel CPU microcodes have nothing to do with the Option ROM modules.

Why not? How did you try it? What happened? Which error message did you get?

There is already X5470 microcode in F13d BIOS, but it is 2008 (A07) version (latest I have is 2015 - A0E)

If you want updated to that microcode I will do later when I return. Mod is done with cbrom (Probably 115 or 155, have to see when I do the mod)

* Here is mod BIOS (1067A microcode update only)
cbrom115 and 198 used to verify before and after, cbrom155 used to insert new NCPUCODE.BIN

I can redo mod later with Intel RAID Rom too, once you decide which version you want.

Hello, Fernando, thank you for your prompt reply. Since I got this motherboard I’ve been trying to squeeze all the best in it. About win10 I wanted to say I’m stuck in the logo windows and I do not see installation menu. I tried to boot from USB or DVD, both bootable. I’m still blaming the bios version I have on the current F13d and / or bios settings for win 10 (this is set on AHCI vers 1.20, HPET Enable 64) and yet with IDE instead of AHCI the same problem , win10 does not install. When I tried to install windows 10 as an update over windows 7 I received an incompatible processor error and from here I was thinking that microcodes are not introduced in my bios version … but the processor is correctly displayed in CPU-Z and AIDA64 and it works ok .