[Guide] How to flash a modded AMI UEFI BIOS

@bobypf :
Please post the links to the original and your modded BIOS. Then I will do a look into them.

To save space, please reduce the amount of lines for your Signature (3-4 lines are enough, the case and PSU details are less important for this Forum)

@fernando

https://drive.google.com/open?id=1Ppx5NU…0bXcMzG_cLs6Kaw

Here are both the original unmodified UEFI and the one modified by UBU.
SX570EG.CAP - modified (with the newer RAID UEFI)
ROG-STRIX-X570-E-GAMING-ASUS-1408.CAP - original

Thank you!

@bobypf :
Thanks for the links to the uploaded BIOS files.
This is what I found out:

  1. You obviously have manually replaced the AMD RAIDXpert2_Fxx.efi module v9.2.0.127, which was within one of the original UBU\Files\AMD\RAID\Xpert subfolders, by the newer v9.3.0.120.
  2. The reason why you cannot use the updated AMD RAIDXpert2_Fxx module version, is not a failed BIOS flashing, but problems with the original BIOS and with the UBU tool.
    Since this has nothing to do with the topic of this thread, we should discuss it within the UBU Discussion thread.

@Lost_N_BIOS : @SoniX : @plutomaniac :
Since the UBU tool is obviously not able anymore to remove the "Security Flash Check" code from the newest ASRock mainboard BIOSes, I am going to customized the ASRock BIOS chapter within the start post of this thread.
AFAIK the modded ASRock BIOSes, which are designed for mainboards with an Intel chipset, can be flashed by using the appropriate Intel FPT tool, but how can a modded ASRock BIOS be successfuly flashed into an AMD chipset mainboard SPI chip?

@Fernando

And how did you manage to flash the modified BIOS on your ASRock x570?

@SoniX :
I was not able to get it flashed by using the ASRock "Instant Flash" tool, although I had chosen the UBU tool option 2 (removal of the "Security Flash Check" code).

@Fernando

Option 2 fully fulfills the function of removing the protective Capsule as before. Only in previous versions of UBU, deletion occurred automatically.
This procedure works for motherboards on x99/100/200, but not for 300 anymore.
For AMD, this should work until the latest releases of the 400th series and does not work for 400-500 (2019).
Therefore, I made a manual choice.

In general, if you manage to flash BIOS through the built-in Instant Flash - good.
Else…
For Intel motherboards, you can use FPT.
For motherboards on AMD, in addition to the external chip programmer, I do not know.

flashtool compiled for AMD by @The Stilt

https://www.overclock.net/forum/11-amd-m…es-3rd-gen.html

@SoniX :
Thanks for your statement. I agree with you: We need an easy to handle way to get a modded BIOS of modern ASRock AMD chipset mainboards properly flashed.

@aGeoM :
Thanks for your info and the link, but according to what I have read the recommended "Flashrom" tool is not able to get an already modded BIOS for a modern ASRock X570 chipset mainboard properly flashed.

I’m thinking, probably there should be a recovery mechanism for BIOS like Flashback or Recovery.

I used flashrom some years ago to externally flash roms from a parallel port for recovering bad flashes on SPI eeproms soldered on boards like MSI boards. Lately I used only once the flashrom to backup my X570 original bios with success.
The reason of lack of flashrom use is because it work like an external programmer, it wipes/erase all info related with MAC, SN, OA3’s and so one… for X370 I use afuwinx64 /gan (from windows :slight_smile: ) and Flashback on X570 but I belive that flashrom it will work on ASROCK with the --force command (I was very close to buy the X570 Steel Series, and the main reason I did not was the flashback features, so I had to pay a premium price for this Strix X570 since I am not academic knowledge person I do lot of crazy stuff just to trial an error and I need an easy recovery). The only way is to try, if flashrom does not detect you chip then stop if it does go on.

Be well…

Paulo Aka aGeoM

Hello everyone!
I am in the process of flashing the BIOS with AWUFIN. I am a bit confused, so I need to flash the original unmodded BIOS first and after that I replace the original BIOS with the modded BIOS and flash it, right? I was just wondering why is it necessary to flash the BIOS with the original BIOS. Also I am doing all of this form my OS right? And once I restart the modded BIOS should be installed?
(I also attached the original and modded BIOS)
Am I good to go?
Thank you!

f44t6541p111113n5_ABkJXvIc.rar (3.18 MB)

P8B75-M-ASUS-CM6340-0604.zip (3.47 MB)

As it is pointed several times, the mod of the bios is relativity easy the, risky part is the flashing operation.
In Asus the safest way is Bios Flasback solution but not available in ur model.
So solutions presented here in 1rst post in Asus section, with AFUWIN and ASUS AI Suite methods r used to bypass Asus security in files
modded, since normal Asus flashing methods detect and fails when trying other than oficial bios files.
One or other solution will work but there always risks to a fail operation, that risk is urs to take.
Read careful the instructions and pointed links of success/examples in the post, u will understand the use of original flashing bios version in conjunction with the new mod in order to bypass security.

So I tried with Afuwin and I’m already blocked at step 2: the command prompt says that it does not recognize afuwinx64.exe as a runnable program. What am I missing?

Well…i presume that people follows the advice’s given…so would u like to try again and read and use the rigth tools/advices provided in 1srt post?
A small note…u can run x86 programs in an x64 OS but not the other way around, ring a bell…

I read the post again and I think I have done everything correctly, is there a specific directory I am supposed to extract AWUFIN to?
I also tried to download AI suite but I can’t find it for my motherboard.
Just to be 100%. How do I tell if I should use APTIO 4 or 5?

@Guddu988 :
1. You have to run the Command Prompt with Admin rights.
2. If you are running a DOS command, it is a good idea to put the AFUWIN tool into a freshly created folder with a short name within the root of drive C: (example: C:\AFU).
3. The ASUS AISuite, which you can download from >here<, is usable for all ASUS mainboards.
4. Since all AMI AptioV BIOSes have native NVMe support, your mainboard is an AMI AptioIV one.

Hey I was wondering if anyone could help me flash a stock bios back onto a motherboard? The most recent bios that I updated to(3006) screwed my computer up royally and I cannot do anything but get into bios.
The board is asus tuf x299 mark 2. The CPU is 10920x. This motherboard does not have bios flashback and will not let you rollback the bios inside the UEFI(says not a proper bios file). The only route left to me is to somehow force the older bios to flash to the bios chip. I am aware that this is possible with the right tools. What tools do I need to accomplish this task? I’m pretty sure I have to use one of the AMI branded bios flashers but have no idea which one or how to use them. I assume you would want to do the flashing in a dos prompt or when booted from a usb drive. How would I go about that? I’m not looking to modify the bios file, just get the older version back.

@Fernando - In regards to your BIOS flashing issue, and last comment here [Discussion] UBU Tool related Questions, Reports and Suggestions (58)
That AFU works and allows /GAN, many people use it, and I have personally tested it. That is leaked engineer version. The latest V3 version which supports GAN is for DOS only, it’s version 3.06.01, I’ve sent to you before.
Anyway, yes, seems like this V5 does not work for your particular board, but it does however support use of /GAN option. Seems like only possible way for you to use mod BIOS then will be flash programmer

@jeepkeys1986 - download official BIOS from asus, extract from ZIP, put on USB stick, boot to BIOS and flash via EZ flash. If that’s what you mean that will not work, then the only easy way is via flash programmer and you send me dump of your current BIOS and I then make you old BIOS with your info, NVRAM etc.
What is messed up with the new BIOS exactly? I can possibly help you downgrade to older BIOS version, leaving current updated ME FW in place, it’s not ideal, but we can do that if you think none of your current issues are ME FW related.

To get started on what I said above, please do the following and tell me what error # you get at step #2, and go ahead and upload the created BIOSreg.bin file for me too

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hi,
I am using latest BIOS J61_0396 and HP Workstation Z620. HP service support is something…
I have tried to modify it using of Fernando’s guide How to get full NVMe support for all Systems with an AMI UEFI BIOS

I have used two versions of UEFITool (0.26.0 & 0.28.0) and three versions of MMTool (4.50.0.23/4.50.24patched & 4.50.0.25) and during reflashing process I always got this message “System ROM Image is invalid” .
It seems that the modified BIOS is not OK. A missing Pad-file issue… see the attachment or HP BIOS has some integrity check and does not allow do reflash the modified BIOS according to Fernando’s guide as well How to flash a modded AMI UEFI BIOS

I am newbie here so I can not to add here a link.

Could you help me with it please?
Thank you a lot.

UEFITool.JPG