[Guide] X99: SATA controllers and drivers


What can occur on SATA Controller 2 if say I use two ssd’s non-raid using the v14 driver without software? Can I still use Samsung magician to monitor my ssd’s?

@jujubeans :
1. Why do you insist on using a not matching Intel AHCI driver for your on-board Intel SATA Controller 2 (= sSATA AHCI Controller with the DeviceID DEV_8D62)? The Intel RST drivers v14.x.x.xxxx have been designed by Intel for your onboard Intel SATA Controller 1 (= SATA AHCI Controller with the DeviceID DEV_8D02) and do not support the DEV_8D62 Controller.
2. What has the function of Samsung’s Magician to do with the in-use Intel AHCI driver?


SATA Controller 2 can work in AHCI or IDE mode. Device ID is DEV_8D62 (AHCI) or DEV_8D60 (IDE)

In the case of SATA Controller 2 (AHCI/IDE), we also have two options, v14 or v5. However, in this case v14 may cause some problems, so installation of v5 is recommended.

This is what was stated from the op/author of this thread, I already have the v14 installed so I wanted to ask what issue would occur if I just kept that driver installed instead of the v5 driver. Fernando would your suggestion is to switch over to v5, is that correct?

The drivers listed for my board on station drivers are as follow.

Intel rapid storage technology
V: 4/11/2016

Intel Rapid Storage Technlogy Enterprise
V: 10/31/2017

If you have set the SATA Controller to IDE mode, you will get none of the Intel RST/RSTe drivers installed, because they are only working in AHCI or RAID mode.

That is absolutely correct. The v14 Intel RST(e) drivers do not support your on-board Intel sSATA Controller (= Controller 2), no matter which SATA mode you have chosen within the BIOS.


would this be the driver I should be installing v5.3.0.1412?

Can I over write the existing driver with this new one, or would a fresh windows install be a better solution?

That is the version of the related RSTe Software, which I do not recommend to install. The drivers themselves are v5.3.0.1388.

A fresh OS install is not required, but you should uninstall the Intel RST Software v14.x.x.xxxxx (if it should be installed) from within the “Add/remove Software” section of the Control Panel and to reboot your computer, before you are going to manually install the Intel RSTe driver v5.3.0.1388 WHQL from within the Device Manager.

I cannot disable or enable “Write-cache buffer flushing” within the Intel RST Software on one of my Arrays (Getting an error that states: “An unknown error occurred while an operation was in progress. The operation could not be completed.”).

I am currently running a Rampage V Extreme x99/U3.1 (using a modded 3801 bios from post #245 in [OFFER] ASUS Rampage V Extreme - modded BIOSes (17)) with a Intel Core i7 5960X on a fresh install of Windows 10 Pro x64 1709.

The raid array that is having problems is two Western Digital RE 4TB in Raid 0. Also the second drive of the array keeps getting disconnected after waking from sleep. SMART and chkdsk show no problems with the drive. I also ran every test in GSmartControl and it reported that both drives in the array are completely fine.

I hope someone could help me figure out this problem. Thank you @Fernando , for providing this wonderful forum filled with great information and extremely knowledgeable people!

If i need to provide any more information please let me know!

You can use the Device Manager instead (> “Disk drives”> right-click onto the related RAID array > “Properties” > “Policies”).

Thank you @Fernando ! That worked like a charm! The option use to work in the software previous to the Windows 1709 update, which I assume might have broke how the software call’s this action. Any other reports of this occurring on other machines?

Hello Fernando, Hello to All!

I’m confused about v14 an v5… Can I install 14 driver and sw and, after reboot, remove 14 from controller 2 and manually add the v5 from device manager?

I’m on 2016 srv on asus x99 ws/ipmi… from latest bios published, the raid rom is “”, I’ve tried v14.8.18.1066 and v5…4.0.1464 drivers and seems to works both fine… I’m starting to buid this server, 0% of load now!


@ilrobby :
Welcome to the Win-RAID Forum!

It is not easy to understand what you want to do.
How many and which sorts of HDDs/SSDs are connected to which SATA/sSATA ports of your on-board Intel SATA and sSATA Controllers and with which SATA mode (IDE/AHCI/RAID) are they running?

Dieter (alias Fernando)

Hello Fernando!
Thanks for your reply!

My goal would be to get the best drivers/configuration!

At the moment I’ve connected 2x 2tb wd red on controller 1, now in AHCI, but will be RAID1; on controller 2 (also sata3 6Gb/s), I’ve connected 2 ssd and other 2 sata3 drives in AHCI mode.

I’ve also an M.2 stick, but I think that this controller has/use another, MS, driver… I cannot found it in the controller’s field in device manager… or better, I see another, anonimous, device controller… probably is the M.2 one!


@ilrobby :
Since I don’t have any own experience with an Intel X99 chipset system and its best configuration of the SATA connected HDDs/SSDs, I recommend to ask 100PIER for an advice.

Thanks anyway Fernando! I’ll wait 100PIER if and when returns!

Hi Guys,

Was wondering what is the best raid option rom/efi rom version for X99? There is a new bios for my X99 Mainboard and it is the 14.8.0.xxxx branch and not the 14.8.2.xxxx branch. As 14.8.2.xxxx has been out for a while any reason why my mainboard manufacturer would choose 14.8.0.xxxx? More compatible?

In any case have been experiencing weird failures to load windows and get past the spinning startup booting wheel on the new bios version. I have dual bios and can test out the differences between old bios and new bios. I have a number of SSDs attached. A Samsung 950 Pro on the M.2 connector, a Plextor M8PeY Nvme drive on a pci-e slot, and two Samsung 850 Sata drives on a raid 0 connected on the 1st Sata/Raid controller.

I think its the Plextor drive causing the lockup as long ago I experienced something similar that prevented me from using it on this system as a secondary drive and so a year later after a couple bios updates I was able to install it in the PCI-e slot without causing the primary M.2 Samsung 950 Windows install from locking up.

So time past and I forgot about that issue and dismissed it as a fluke but now after the latest bios release I think the reason Windows doesn’t load is probably the same one from a couple years ago although it works fine on the current bios I was using all this time since. Its just that if I turn on raid and MSI Fastboot setting it locks up on the new bios despite working fine on the same bios settings with the old bios. Has me confused as far as what is going on.

Anyone have any ideas?


Currently I do use the last BIOS v3902 offered by ASUS for SabertoothX99:



BIOS ROM RAID Driver: Intel RST v14.8.0.2377

No, the mainboard manufacturers generally do not update the BIOS modules of their mainboards, when Intel releases a slightly updated RAID ROM or EFI RaidDriver within the same develepment branch.
Note: The versions v14.8.2.xxxx and v14.8.0.xxxx belong to the same development banch, which is v14.8.
Due to the fact, that Intel would never spend money without any reason for a further devolopment of their RST drivers and BIOS modules, I generally recommend to use the latest version of a specific development branch (here: RST v14.8).

@100PIER :
Can you help our Forum member ilrobby finding the best HDD/SSD configuration and the best Intel AHCI/RAID drivers for his X99 system?
His post is >here<.

Thanks Fernando for answering my inquiry. So its a financial issue why the mainboard manufacturer would not choose 14.8.2 vs 14.8.0 efi driver. I mean MSI went out of their way to make major changes to the recent June release of the X99 Godlike vs the last release. I did a uefiextract dump and did a file by file comparison. In anycase no matter how new it is I can not boot Windows with it. Not only that when I select UEFI only mode the legacy Raid rom still loads for some crazy reason. Is it possible that Fptw64 does not perform a 100% clean flash from within windows? Perhaps I should have flashed through the bios setup utility?

Thank you

@davidm71 :
Do you get access to the “Intel Rapid Storage Technology” tool from within the BIOS after having set the Intel SATA RAID Controller to “RAID” mode and disabled CSM?