[HELP] Help for going on modding hidden menus in my Sony Vaio VPCEB3L1E

Hallo all,

I am trying to mod my Sony Vaio hidden BIOS menus, and I am stuck trying it. I have been readinf several guides but I do not know how to go on in thids moment.

First I tried it directly with AMIBCP changing to USER, without result. Then I have extracted with MMTools an with UEFIToll all relative tyo the Section "Setup" and try to find the magic 00 / 01 hex bits for Visible / Hidden options, but in any of the BIN files exist the secuence of my BIOS Structure. This is:



So I have been searching for “01 01 00 00 01 01 01”, but in any of the BIN files I got exist that sequence . I do not know if I must search in other section, but there is a lot and I do not know where to begin… I need some kind of help at this moment.

Sony Vaio VPCEB3L1E

My BIOS is:
AMI EFI BIOS
BIOS VERS. R1140Y8
EC VERS. K1140Y8
ME VERS. 6.0.31.1208

I attach the IFR files and my original BIOS without modifications

DUMP.zip (1.21 MB)

@Haplo - how are you flashing in your mod BIOS when you test? If AFU, please give me the exact command line you are using. If you are flashing in via the stock Sony tools extracted from the stock exe, please link me to that package.
How did you make the backup also?

Magic string (Those 01 01 00’s) is not used in your BIOS, but if it was it would be in the setup PE32 body, directly before EE 2E 20 71 53 5F D9 40 AB 3D 9E 0C 26 D9 66 57 @5B7Ch

Did you test setting menus to Supervisor instead of User, at Root of setup? This means the folder without name at the top, like you see below, this is where you normally enable or disable a menu via Access Level change

Root-Setup.png




This ^^ would be first thing to test, User/Super on those

@Lost_N_BIOS , thanks for you atention. I have just tested changing to supervisor without resul. Must I set any password in this case (user or machine), to take effect the change to supervisor?

I am using AFUWINGUIx64 on Windows 10 to flash, checking not to “check ID”. It flash witout problem. I attach the image of the PE32 section, with the hex bits you have posted. As you can see, just before there is “00 00 00 00 00”, only 5 times, when there are 7 menus (5 + 2 hidden). Very strange, No?

PE32.jpg

You’re welcome! No, no password required.

Please send me in zip, one of your edits with user and one with supervisor, so I can check you are changing correct thing. Those may not get it, but that is what to try first.

Flashing with AFU may be the problem here, it may not be flashing anything and only appearing to flash the BIOS. Not that is matters, but what else are you checking in AFU? The only thing you are editing here is “Main Block”
So check main block, or use /P in command line version, that is the only main thing you need to do/check. I dislike AFU, so advise against it for many reasons, but it may be only way to flash, if it’s even actually flashing.

No, the hex string I mentioned shows nothing, this method is not used by your system, that is all I was pointing out when I mentioned that.

Please link me to the stock BIOS package from Sony for the BIOS version you are using.

Since this is Intel System >> Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >>
FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges


Do not play around with FPT, you can brick your system in an instant, do ONLY as mentioned above and stop there then wait for further instructions.
Do not proceed or try to force flash/say yes etc if you get any red or size related warnings, stop, show me image of command entered and error given, then way for further advice.

* edit - Do you have flash programmer (like CH341A)? Asking in case NVRAM edit test is needed

Sorry for being so late @lost_N_Bios. I will tray all you say tomorrow, its a lot of work :slight_smile:

In my first post I showed my ME version

ME VERS. 6.0.31.1208

Can I upgrade it any superiir version?

No, i dont have any programer

Thanks

It’s easy! Start by putting the two BIOS you edited I asked for into a zip archive and send to me, that’s really easy

For ME System tools, then you will need a V6 package, I’m not sure which one though so you may need to download and try the FPT from both until you find which one works (probably IBX version)
Once you get FPT going, also dump ME FW like this and send to me, then I can let you know if there is an update >> FPTw.exe -me -d me.bin

Hallo @Lost_N_BIOS . I have been all the morning trying FPT without result… Neither in windows or directly from DOS. I always have the "platform not supporte error". Finally I have used the Intel ME System Tool to get the info.

I attach modded and original BIOS. Sony never updated this BIOS, so there is not access to any download. As you can see, in the modded I changed all the menus to supervisor. Appart, in the Boot section I changed some options to USER, because they where hidden in BIOS menu. Changing it to USER it is shown in BIOS

sony_bios.zip (2.12 MB)

Corel.jpg

Hi @Lost_N_Bios

Finally I got it with the Intel ME System Tools. It gives me an error trying to backup the ME region, either in Windows or DOS (image attached), and it backup the Biosregion and flash it without error.

me.jpg

bios.jpg

biosreg.zip (1.07 MB)

Please edit your posts to add more info if no one has replied yet, thanks

Please clarify some things before I look at either BIOS you attached at post #7. When you changed all menus to supervisor, did that make any visible changes in BIOS? If not, remove all those changes, or don’t do it yet/at all etc.
When you mentioned you changed some setting to User, did those become visible in BIOS? If yes, OK, leave. Since User make hidden setting visible, then User would be what you need to set on root for menu sections (if any changes are needed there, possibly/possibly not), but don’t leave something changed that didn’t work.
Now I looked at your AMIBCP edited file. First, you only need to change menus you can’t see, not all of them

Since you can’t dump ME FW without a BIOS edit/hassle, if you want to update ME FW, then please run MEInfoWin from the MEInfo folder (MEInfoWin -verbose), show me the full output and I will get you file and show you how to update

Please wait, I will see how to unlock your BIOS now and let you know how once I find the solution
* Edit - please zip one image of each main BIOS page so I can see what is shown to you and what isn’t. I mean, Main, Advanced, Boot, Save and Exit etc (No need to show me inside submenus or anything, just need to see each main page)

@Lost_N_BIOS



No it does changue anything



Yes, but those settings are in one of the visible menus (Boot)

I attach (MEInfoWin -verbose) images and from the BIOS pages

Thanks

fotos BIOS.zip (4 MB)

bios1.jpg

bios2.jpg

OK, change back for now (Supervisor stuff). User is what will be needed for menus too, IF a change is needed in AMIBCP, since User made that stuff visible for you in Boot, same will be what works in root menu too (if/when)
For now, please wait. ON ME, also wait, I can’t tell for sure which version so I will ask ME guru!

plutomaniac - Can you tell from above meinfowin images which ME Info I need to help him update FW? He’s using MEInfo/FPT from IBX V6 package.
I can’t tell for sure since both are “5/34xx-series” and none of the V6 system tools are without additional name (IBX/CCK) like this first one below. I assume the one that says IBX, but we all know how assuming can go

Intel ME 6 1.5MB Firmware v6.2.50.1062
For 5/34xx-series systems which run ME 1.5MB v6

Or Intel ME 6 Ignition IBX Firmware v6.0.30.1199
For 5/34xx-series systems which run ME Ignition IBX v6



Only for taking it into account. Is not this ME firm a downgrade of mine?



I tried USER in main menu yet… without result

It’s IBX, not Ignition, without vPro features so I assume 1.5MB SKU.

Plutomaniac - thanks, but now that’s still not clear to me, since you mention IBX which I did assume it would be, but the ME FW download pages only has IBX v6.0.30.1199 as latest IBX
User already has 6.0.31.1208, and the only one above that is the one I asked about above, which does not mention IBX >> v6.2.50.1062
So, should that one (v6.2.50.1062) also say IBX, ie are all v6 IBX if not ignition?

@Haplo - yes, I know about the User/Menus stuff you mentioned, I meant after menus are unlocked that may or may not be needed. Sorry, I still have not found the solution here yet, this is an abnormal BIOS, hopefully I can find for you soon.
If you had a flash programmer we could figure it out much quicker, then I could give you possibly bricking BIOS without having to worry about you being able to recover.
Since you do not have programmer, I have to be sure, so still looking and checking things out.

Thanks a lot for all your help @Lost_N_BIOS

Maybe these 3 articles can give you some idea about this BIOS. It is the only I found on internet, but I did not understand which was the trick:

VAIO_BIOS
VAIOGedon1
VAIOGedon2

He talks about R1170Y8 BIOS version, but it flash perfectly in my laptop. Another thing is that in any soft I have used, they show my BIOS is 4096Kb, but any program can backup more than 2048KB

For ME6 there were two PCH: Ibex Peak (IBX) and Cave/Coleto Creek (CCK). IBX had Ignition, 1.5MB, 5MB DT, 5MB MB SKUs whereas CCK has Ignition SKU only. IBX Ignition is not compatible with CCK Ignition so that’s the only reason the IBX/CCK distinction exists there. As I said, this user is probably using an IBX 1.5MB SKU (Intel ME 6 1.5MB Firmware v6.2.50.1062).

Plutomaniac - thanks for clarifying! Can you please disable the redirects for my user group too, I tried to wait it out thinking maybe a temp bug, but it’s been driving me crazy now for 2-3+ weeks

@Haplo - Thanks for links, but sorry no, none of that helps with BIOS unlocking (or ME questions I posed to plutomaniac directly). But yes, after reading it more, it does show him updating ME FW to the one I was questioning about, so yes that does answer my question I guess
Yes, that is normal for some software to be only able to dump 2MB or 3MB of a 4MB BIOS, this is due to security locks some areas are not unlocked to read/write
Interesting what he found about the graphics!

To update your ME FW, download this ME FW file, unzip and rename to ME.bin
https://mega.nz/#!zY1liBZL!MdnLKKX7igmJb…zj8rFofUFAfx96U

Copy that renamed file into ME System Tools >> FWUpdate >> Windows folder. Then, from this location, open an Admin CMD Prompt, and update the ME FW via this command >> FWUpdLcl.exe ME.bin -generic

Thanks @Lost_N_BIOS and @plutomaniac

I have flashed the new ME firm, and it is shown ok in BIOS


I don’t control these things. Try this or this in case they help.

Plutomaniac - Sorry, I assumed you could make some changes to user groups in the ACP, like you enabled option to soft-ban previously. I’ll check the opt out and see if it will help, not sure ublock would be helpful
Funny, I can’t check the opt-out link, unless I edit your post to get the URL Looks like that may be for their ads more than anything, so maybe only opting out of “directed” ads to general ads instead
Yes, no change in regards to this. I’ll have to switch browsers to FF for here and see if I can find anything to stop this

@Haplo - Great ME FW update went without issue! On BIOS Unlock, please order a flash programmer like CH341A + SOIC8 test clip with cable, any and all changes I think may help are to risky for you to flash without this.
Even swapping advanced looks risky (ie, may take a few tests, some may brick etc)