[HELP] Mobo AM4 1.8v Bios Connect JSPI1 with RPI for Reprogramming

Hello, guys.

I am facing a really problematic issue atm, I have a motherboard “B350M-MORTAR”. It has been laying around under my bed for around a year because of a failed bios upgrade. Now I replaced it for my current broken motherboard, which is currently innoperative.
Now I intent to repair the previous motherboard with the corrupted bios, I’ve tested it and it posts but since the bios is corrupted, it only shows a underscore blinking, keyboard and mouse wont work, nor usb drives.

I’ve tried everything trying to recover it, booting a boot drive with bios, using the renamed bios in a 4GB usb in fat32, etc, changing various components, no luck at all.

So I went searching for a while, and found out that the bios can be re-programmed, now here is where all my issues start:
I have a raspberry pi 4 working fine, but I can’t acquire any tool that will make this easier, because the current quarantine situation in almost every country in the world.
So my only solution is to use the raspberry pi.

I’ve tried to use various tutorials trying to accomplish this. Not sure if links are allowed to post but:


Problem is that from all the tutorials I’ve read, none of them show the connections I should take in order to connect the Motherboard JSPI1 to the Raspberry PI, since in the tutorials people used other bios chips, or they are using other re-programming tools.
I am not intending to connect the raspberry pi directly to the chip, since I lack the skill desoldering and also lack the tools doing it, like the clip for direct connection, Now I can provide 1.8v power onto the chip (instead of 3.3v) like the guy with a similar board (second link) just by connecting the 24 pins in the Mobo, no cpu, no ram, etc.

But I have doubts with all the other pins, would anyone help me connect the JSPI1 from my motherboard to the raspberry pi?

My Bios chip is: MX25U12873F at 1.8v (attached capture/image)

Now I would usually buy another cheap motherboard, but there is no stores, in my country they are currently banned, and in Quarantine. And I must work.

Regarding the flashing method I think I won’t have any issues with this.

Thank you in advance.




You need a logic level converter if your SPI chip is 1.8v.
For connection of JSPI1 there is various info on it in this thread, not just my first post but other posts in the thread also.
[Guide] Recover from failed BIOS flash using Raspberry PI

EDIT: it seems on the RPI4 you can select the GPIO pins to 1.8v, cool i didn’t know.

Oh no, I have not heard about this level converter thing, problem is, there is no way I can get one in a long while.
Is it really necessary to use one of those, may I ask what is its purpose?.

Wire up one of the normal CH341A 1.8V adapters to work with your Pi, otherwise not sure how you do it? I’d just pay the $4 and wait for delivery of CH341A + $4 more for 1.8v adapter + I’d go ahead and grab SOIC8 test clip while you’re there too

Order, wait for delivery, forget about it all, and then it will arrive as soon as you forget you ordered it

Also, here’s more info and pinout images etc in regards to JSPI1 - I use the item I show image of in post #7 all the time on Asus and MSI boards, let me know if you want a link to the seller/item on ebay (he’s in Korea and ships fast, usually 12-14 days delivery or less)
Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip
[Guide] Recover from failed BIOS flash using Raspberry PI (11)
Xeon E3-1240 v5 working with MSI Z170-A PC MATE but with bios reset on boot (3)