[HELP] MSI B450-A Pro bricked after bios update

Hello everyone,

I bought a second hand MSI B450-A Pro for my new Ryzen gen 3 build.
For this I have used bios flashback functionnality to make it compatible with my new Ryzen 5 3600.
First at all everythign get right except dual channel.
The computer won’t boot with dual ram modules, so I’ve flashed Bios with USB Flashback. I’ve got a current failure and now MOBO is bricked.
I’ve tried many times to update Bios via USB flashback but when I short the pins to power the modo nothing happens.
So I’ve made some research on this forum and I bought a Ch341A and 1.8v adapter + clip.

I don’t know why but ASProgrammer recognize the chip only with the modo OFF but PSU On and ATX_PWR and CPU_PWR linked.
I can read chip with CH341a Programmer v1.34
I’ve flashed the last bios from MSI website and now CPU debug led is on when I power the mobo, but it doesn’t POST.
I know I made a mistake here but which one?

I have already bought a second MOBO and I just really want what’s wrong with this one. I’m a bit curious and like expend my knowledge.

I have a backup of the corrupt bios.

For info chip type : W25Q128FW

Thanks for reading.



I just want your thoughts abou my problem, I really want to understand what’s wrong.
Thanks a lot for sharing your knowledge on this forum.


Make a try with to clear CMOS

Already done multiple times. But thanks for replying.


Some news and details about my problem and what have been already done :

- I have tried multiple times to use USB flashback to get a proper bios, result : no Post and CPU debug Led stuck light on.
- Made a backup of corrupt bios.
-Erased and write multiple time the chip but after reading .bin is always different than original. I use HxD to compare both files.

What I’m doing wrong?

@Hayef - MSI has USB Flashback??? That’s Asus thing, but maybe MSI has similar now on modern boards?

Your program >> Read = different is because you have power connected to the board and or attempt to run it between program/dump, thus checksums, time/date changes, NVRAM changes etc

Remove all power from the board, unplug 24-8 pin, erase the BIOS chip with ASProgrammer. Then write the BIOS, then dump the BIOS and compare with what you wrote, it should be a match, provided you did not power on the board.
If you can’t make programmer work without PSU as you mentioned, then use JSPI1 header instead.
There is a few different pinout images here, in these discussions about JSPI1
Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip
[Guide] Recover from failed BIOS flash using Raspberry PI (11)
Xeon E3-1240 v5 working with MSI Z170-A PC MATE but with bios reset on boot (3)

If I were you, I would first purchase some cheap old CPU that is KNOWN compatible with earliest BIOS.
Get that going, then update BIOS normally, this may be an EC or other FW issue, that normally updates with the BIOS, but is not working now due to your non-compatible CPU

Yes MSI new board has this feature, named Flash Bios Button. I don’t know why this feature can’t save my bios ?

To be clear whan mobo is powered time/date is updated in the bios “file”?

Why I can’t detect the chip when PSU is off ?

I will follow all your advices I will buy a cheap Ryzen 1200 and perform tests.
I’ll keep you in touch of the results.
About JSPI header : can I wire it to CH314a and use it like a secondary BIOS to get to POST and to DOS then flashing the original bios chip ?

EC is for embeded components and FW for firmware ?

Most important, thank you for repling and answering my questions.

Some boards need PSU powered on (I advise against shorting pins to actually turn the PSU ON), but some boards to dump BIOS need PSU power button on but not actually running, some it doesn’t matter. Those that need PSU powered on via short, are not always capable to program BIOS due to various reason.
I suggest you either remove the chip from the board, or use the JSPI1 header. Or yes, some cheap compatible CPU may get you going, it may be programming in correctly, but something else needs updated (not in BIOS) as well during the BIOS update to support your current CPU and cheap highly compatible CPU will let you know if this is the case or not.
If that does not work too, then you will need to program BIOS in another way. All JSPI1 info I know I linked you to. Yes, you can wire to programmer, and or program a BIOS chip that is in the programmer and then wire to JSPI1 and boot from that BIOS, unplug it while in BIOS and then directly program the main BIOS.

EC FW is different than BIOS, some systems have EC FW and other FW types on other chips. This what I meant, maybe during BIOS update, something else also gets programmed in too, when you update BIOS normally with old CPU for new CPU, and maybe this doesn’t happen with BIOS flash button (just guess)

Hello, some news since my last post.

I have bought a cheap Athlon 200G processor.
Problem is the same, no POST and CPU_LED on.
I’ve tried multiple times : flash with AsProgrammer, CH314A programmer software v1.34.
No result.

My last chance is to buy a bios chip on eBay and try to boot from it with JSPI1.

Something is weird, with only 9 pins over 11 on JSPI1 the chip is detected and I can erase and flash.

My JSPI version is 11 pin.

@hAYEF - Sorry to hear still no resolution here!! If you can erase and program over JSPI1, then after writing to there, dump and compare with what you wrote, it should be match. If so, then there is some other issue.
Are you 100% certain the new cheap CPU works? If you are not sure, please test it on some other board, otherwise you don’t know if it’s a faulty CPU or not.

I m sure it’s working cpu, it s the second I bought from Amazon and both same issues.
I will give a try with JSPI to compare.
If it failed I will stop investigating here, I will not spent my time on a non working 50€ Mobo.

Thanks for your rapid answer.

I just noticed in your first post, you mentioned it wont boot with dual memory, back then would it boot with single stick of memory? Was this board purchased used?

JSPI1 is really made to boot from a BIOS chip on PCB, but sometimes you can program BIOS directly through it. When I’ve used it, I booted to a BIOS on PCB adapter, then from within that BIOS, I pull adapter off and flash the onboard BIOS.
If you want me to show you this adapter let me know, it’s on ebay and costs $15 I think last time I looked, but there may be second cheaper one too if they’re still for sale
Ahh, not on ebay anymore, but found here, and this may already be what you are doing with cables, so not same as I meant - https://www.aliexpress.com/item/32837013205.html

Here is adapter I’ve used, and this is based on MSI’s original intended method for booting from JSPI1, they (MSI) have a video somewhere about it.
MSI JSPI External Flashrom module 1 set : $15 - It at bottom of listing info, you have to contact seller directly and tell him you want to buy this only, works for Asus boards too. This programmer is the one I use most often, have purchased from this seller many times, always quick ship too (2 weeks max usually)

Ohh wow, maybe not a good time to purchase from him, shipping price up from usual $3 to 25+ Maybe ask about that/why in your message, if you reach out to inquire about the adapter

I see this, maybe @davidm71 - can help advise you on 11pin JSPI1, if he ever figured out anything more about it.

See also, their discussion here too, seems power is required to the board in some cases (I normally am booting the board when I use JSPI1, so this makes sense to me, and of course some boards need it anyway when programming BIOS)


That MSI adapter will not work if his motherboard has an 11 pin JSPI1 port as most newer motherboards these days do. That adapter is for a 9-pin I believe it won’t work. In the past I have used hook up wire:


to directly connect the pins from either my Flashcat USB device or CH341B device to the SPI1 port of an Asus motherboard. Basically I made my own adapter. May have connected successfully to an MSI board but can not recall. The pin layout of the MSI SPI is widely available with google searching: https://forum-en.msi.com/index.php?topic=121790.0.

In anycase I have notes I wrote up last year about both Asus and MSI. Will scan them in here and share them for all who would want.

Edit: Scanned in my notes. Sorry it scanned in upside down.

jsp001.pdf (1.24 MB)

First of all, thank you both of you for your interest on my case.

I have bought the AliExpress adapter and wiring is incorrect because is for 9 pins JSPI1.
I will give a try with 2.00 mm to 2.54 jumper cables first to CH314a and directly to a chip with SOP 8 adapter.

I use the TechpowerUP Sasqui’s thread for wiring example. Very useful thread in my case.

I will follow all your advices and give you info.

Again thank you.

@davidm71 - thanks for your help and info provided etc!!

@Hayef - Good luck, hope you can get it without having to remove the chip! If all fails, and you don’t want to remove the chip, get the PCB adapter I linked on ebay, I use this all the time on MSI
But, I didn’t have to pay that extreme shipping price back when I purchased it, maybe there is some issue right now with mail going out from S Korea due to pandemic? I would talk to him in message on ebay, if it comes to this.

@Lost_N_Bios : your adapter is for 9 or 11 pins JSPI1? Any chip of the same bios chip size (memory size) can work with it?

@Hayef - 10pin max, so it’s designed for 9pin and would not work on 11pin. And yes, works with any chip, usually he will send you one adapter with chip soldered on already too and you can tell him what chip you want usually too (maybe not same brand if he does not have, but he will send whatever size you want)
I cannot remember if pins/hole-slots on the adapter are configured exact same as DIP8 BIOS, but DIP8 BIOS does fit in there too, and due to it being Asus compatible I assume it’s direct chip/socket layout but we all know how assume goes so can’t be sure unless I test (if you need me to check, let me know and I will check)
Here’s his site/info for the adapter - http://shop3.nanobios.cafe24.com/article/manual/3/24/

If you get, be careful, it’s hard to tell proper orientation onto the board, so once connected and you power on immediately feel the BIOS chip on adapter and if it’s hot shut down and reverse it

Worth checking out Elmors guide: https://www.elmorlabs.com/index.php/foru…header-pinouts/