[Help needed] HP Pro 3520 AIO bios update

I used UBU to update/modify HP original BIOS 8.17A (sp70066.exe hp file contain LEE_817.rom bios), all modify applied ok, but when i try to load bios with safuwin.exe tool error appear. I test modified file with safuwin.exe /D parameter and all controls are ok passed!

This is message when run update with safuwin.exe mod_LEE817.rom safuwin.exe LEE_817.ROM /p /b /k:

| AMI Firmware Update Utility(APTIO) v2.38_HP_v04_B04 |
| Copyright (C)2011 American Megatrends Inc. All Rights Reserved. |
Reading file … done
FFS checksums … ok
- Incorrect BIOS for the system.


This is the test file.rom with /D parameter:
| AMI Firmware Update Utility(APTIO) v2.38_HP_v04_B04 |
| Copyright (C)2011 American Megatrends Inc. All Rights Reserved. |
Reading file … done
FFS checksums … ok
- ROM File Size checking … ok
- ROM ID checking … ok
- ROM File verification status … ok


First section says incorrect BIOS for the system, second check says ROM ID OK. To me this means the BIOS mod is failed probably. That could be true, bad mod, or could simply be due to modified BIOS not compatible with that flashing program and you’ll have to use another flash program.

I cannot check BIOS now, but will tonight. Please let me know what ALL you need updated exactly and I will look at the BIOS and do the mod without UBU, then you can try same methods with safuwin and my BIOS file, then you will know if BIOS Mod was bad or simply any modified BIOS not compatible with the safuwin flashing tool.

i see the file bios in the sp70066.exe is 8192kb but if i give backup from my PC the size is 4096kb??? i can modify a backup file ?

i try modify 1 option for test SATA OROM to

after i test to mod EFI GOP Driver Ivybridge/Sandybridge and Video BIOS according with instruction on the forum

after i test to mod OROM network card and CPU microcode

but all modded file give same error…

if you want i can send you my backup PC bios ?

OK, so that is a lot of mods. Please upload all your modification files in a zip so I can put in BIOS my way (not with UBU)
So, SATA rom, your updated settings transfered vBIOS and GOP driver, and network rom (I can do microcodes on my own, no need to include)

Also, include your modified BIOS so I can see if anything is obviously wrong or anything sticks out as maybe being the cause. Like it said, it could be fine BIOS mod, just not flashable with that tool due to being modified
This is often the case with OEM like HP or Dell, even common with big brands like Asus and Asrock etc

Please also give link or full model name for your HP system, so I can download stock BIOS from HP

I assume for now, safuwin is not going to flash a modified BIOS, you need to look a using AFU directly or Intel FPT (Flash Programming Tool)

I will be able to answer the 8MB 4MB question once I can download the stock BIOS. How are you making the 4MB backup?

attach zipped mod_file, also i’ve update via UBU a CPU microcode.

attach also my pc BACKUP rom make with safuwin /O

mod_files.zip (233 KB)

HP_sp70066.zip (3.14 MB)

backup.zip (2.11 MB)


Try this.

Your backup bios is only the “BIOS REGION”, that’s the reason why it’s only 4 Megabyte big instead of 8 MB.

I’ve replaced the bios region of the native bios with your backup and added mod files as requested, plus all cpu microcodes updated.

bios.zip (3.21 MB)

same error with safuwin.exe

You can’t use safuwin.exe being a modded bios !!! You have to use AFUDOS from a Pure DOS environment.

ok i try with afudos

You will need the engineering version with /GAN support or /p /b /n /c syntax support in order to flash the whole bios chip.

i download it from ami site, but when i run afudos have the following error:

46 - Error: Problem getting flash information

same error appear if i run afuwinx64gui or afuwinx64

have you a link to download enginering version ?

Maybe AFUDOS is not compatible with your HP. Did you try from DOS to dump bios ? I think you have the flash descriptors locked. :frowning:

I have not afudos Engineering version mate.

I think hp have some bios protection and only with your safuwin.exe tool is possible to load bios.

hope a guru member of this forum have solution for this

Better with an Eeprom programmer.

Yes, i think

Anyway if you look on Google for HP bios mod flash there are some useful links. Did you read them ?

You still never mentioned your board or system model, nor linked a stock BIOS, so I still am unable to look at a full BIOS to see what your options might be. Please add this information now, thanks!

Did you try backup with FPT yet? Don’t flash with it, just see if you can dump complete SPI, ME, BIOS region, or description region (All in separate dumps)

Also best, in any other “AFU” attempts to use the regular non-x64 versions, they are not necessary even on x64 system and can sometimes give error when other version is working and you might not even try so gives false impression of it not working at all.

the model is in object of this thread, is:
all-in-one HP Pro 3520
mainboard i see HP 2AED
ID mainboard 63-0100-000001-00101111-122211-Chipset$00528000_VER: LEE817.ROM VLEE8.17
Chipset North Bridge: Intel Ivy Bridge-DT IMC
Chipset South Bridge: Intel Cougar Point H61

link to download HP site: https://support.hp.com/it-it/drivers/sel…3520-pc/5299218

latest version for (2AED) bios is 8.17A file sp70066.exe

I not try dump pc bios with FPT, i can download it and try to make dump. where can I download FPT tool?

Thanks for your attention!

Thanks for the board info - Here in section C2 is the system tools package you need (Intel ME system tools version 8) FPT is inside flash programming tools then win or win32 folder
Intel Management Engine: Drivers, Firmware & System Tools

And then see here, section D for how to dump all three test dumps to see what if anything is locked (Probably FD and ME locked)
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

AFU or FPT should be able to flash your BIOS, don’t waste time trying anymore with the safuwin as mentioned.

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.

Platform: Intel(R) H61 Express Chipset
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q64BV ID:0xEF4017 Size: 8192KB (65536Kb)

Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.

C:\Users\posto5\Desktop\vvvvvvvvvv\bios\Intel ME System Tools v8 r3\Flash Programming Tool\Windows64>