[Help] Problem to flash the Marvel 88SE9230 card (resolve)

Its work !


Thanks for reporting back.

Hi @chinobino , I have a Marvell Sata 88SE9215 Chip Revision 11 (hence A1) that has been causing blue screens of death for my PC. I am using the latest drivers from station-drivers now, which is working better, but I still get the occasional BSOD and I am hoping that updating the firmware for the device will help. What you post above is for the 9230 correct? Will it work for 9215?

@lontanadascienza Yes it will work with the 9215.

Great thank you. I am having some trouble figuring out how to actually run the go.bat script however. My computer is 64bit, so it can’t run the 16bit executable. I managed to create an MS DOS bootable usb stick, but then that can’t see any of my hard drives (I guess because they are using SATA?). I’m sure I’m missing something stupid - how should I proceed?



I would recommend to backup the existing firmware with the ‘go -ra’ command before you update to the newer firmware.

You should copy the go.bat script and the bin folder (it should contains three files; mvf_mag.exe, spilist.bin and the new firmware e.g ImageA1.bin) to the USB stick and update the card from MS DOS command line using the command 'go -v’

I uploaded the tool with the bin folder here if you need it - the tool comes with firmware so you will need to replace it with that I uploaded here.

Note that go.bat has been written for the 9230 (set hba_id=9230) so you will need to edit it in a text editor for the 9215 (i.e. set hba_id=9215).

You won’t be able to see your hard drives from MS DOS as it doesn’t have the required SATA controller driver.

The issue is I can’t copy things to the USB because once I put MS-DOS 6.22 on it, it thinks it only has 1.44mb of space or something like that - so the files are too big. I’ve never made/had to use a DOS usb stick so maybe I am doing something very silly.

Edit: Are we certain that FreeDOS doesn’t work? It seems like a much easier proposition.

You need to copy the files to the USB stick from Windows.

MS-DOS 6.22 is limited to 8 character folder/file name length.

If you type in dir /p you can see how your folder directory names are truncated (The switch /p views the directories one ‘page’ i.e screen at a time).

I don’t think it’s a naming issue it’s a size issue. The properties of the drive say that its capacity is 1.44mb after flashing ms dos 6.22 using rufus. When I try to drag and drop the files in it says additional space needed.

What capacity is the USB flash drive? It is recommended to use FAT32 file system with a USB stick that is 32 GB or smaller.

What version of Rufus are you using?

It is a 2 Gigabyte USB and I am using Rufus 3.1.1320. I have been using the FAT format I will try FAT32

When I run Rufus it re-formats it as FAT and I get the same result. I am using a .img file for MS-DOS 6.22. The image file is 1.44mb which I believe is the source of the issue

OK I understand the problem now.

That is a 3 1⁄2-inch floppy disk image of MS-DOS 6.22, which has a capacity of 1.44MB and can only read FAT12 and FAT16 partitions.

I have just spent the last half hour trying to make a new 32GB MS-DOS bootable USB stick using FAT32 and have found another way (other than using Rufus with a 1.44MB floppy image).

I have supplied the HP USB Disk Storage Format Tool and the 3 required MS-DOS 7.1 files (which supports FAT32).

Just run the tool as Administrator (leave it on FAT32) and tick ‘Create a DOS startup disk…’ and browse to the MS-DOS folder.

HP USB Disk Storage Format Tool - v2.2.3 (Portable).zip (190 KB)

Thank you so much! I will give it a go

Thank you so much - this worked for getting into MS DOS. Thought I would post my output from

go -r


MVF_MAG v1.0.0.2475

I then ran go -ra to backup my current image. I would like to confirm that you think the image you posted ImageA1 will work for my card with this additional information?

Actually one more question - really trying to do this right the first time - should I be using the files in BIOS_PG or UEFI_PG (in the upload you posted)?

Edit: I checked all four files against each other using vimdiff and they are identical it seems

When I run go -ra no file appears also

Okay I realized that what go -r is showing me is the incoming firmware/bios versions, etc, the ones I am going to install. go -r used to say Adapter_Count=0 but then I reseated the card, physically, went back into my bios and enabled the preboot splash screen, and now it properly reads out everything.

Weird, sadly my bios is already and my firmware is So I am getting hella blue screens of death with even the latest firmware etc.

So, just to try it, I replaced ImageA1.bin with your 1078 ImageA1 and ran the flasher, having backed up my image successfully. It said it wrote everything successfully and that the flash was successful, however when I rebooted the marvell splash screen didn’t come up and now when I go back into ms-dos and run “go-r” it again says “Adapter Count = 0”. I am not even sure I will be able to flash my backup in this state - have I bricked the card?

Was my mistake something to do with using the spilist.bin file you uploaded in that package alongside the 1078 image?