Help unlock all hidden settings in BIOS on DELL 3590

I have a Dell Vostro 3590-8914 laptop
It has UEFI Bios 1.8.1 installed (from 05/08/2020)
here is the link of the latest BIOS from Dell official site…ro_3490_181.exe

The task is as follows: you need to unlock all hidden settings, expand DVMT Pre-Allocated to 64 MB, set DVMT Total GFX Mem to MAX, and also patch MSR 0xE2 (CFG LOCK)

I have a CH341 programmer, and a soic8 clip (I am going to take a BIOS dump from soic8

I took apart the laptop and found two BIOS chips
One XMC QH64AHIG P2000600 68 1933C
The second microcircuit is WINBOND W25Q128JVSQ 1334, but it is covered with a black square sticker (the textolite shows the markup where exactly to glue the sticker)
Probably, all the BIOS data is located on the second microcircuit.
Then what could be on the first?

What program to take a dump? And which chip to start with?

Here are photos of all sections of the BIOS. (photos are compressed, archive weighs 8 mb)…1hE?usp=sharing

Thank you in advance for the work done!





About Dump Bios Region w / FPT

Step # 1 went well, the dump was removed successfully
Step # 2 gave error 167

Since my version is ME 14.0, I am using Intel CSME System Tools v14.0.11-r1. Did I get the correct version?



I really need it urgently.
Please help with the modification

@Lost_N_BIOS Can you help me? I really need this modification.
Thank you in advance.
I can pay for the job how much you say

@vismut1822 - Sorry for delays! Not sure how I missed this thread for so long

Please dump both chips with programmer and send to me, then we can see what is on each.
Some Dell BIOS it’s split right in middle between both chips, so both need programmed at same time, others it’s split in a way that you can just dump/program one at a time.

For W25Q128JV use ASProgrammer 1.40/1.41 or Colibri (use BV ID) -…213094641136166
For XMC QH64AHIG / XM25QH64AHIG try using ID GD25Q64 and same programs above.

Is there a Service/manage/ME/FD/FDO jumper on this board? If yes, also put on this jumper, reboot to windows three times, then >> FPTw.exe -d SPI.Bin
If there is no such 2-3 pin service jumper, then ignore this step

Also, you need to be using v14.0.20+ r7 ME System Tools package
Intel Management Engine: Drivers, Firmware & System Tools


Yes, I successfully dumped two chips!

Here is an archive with two chips

Regarding Service / manage / ME / FD / FDO jumper, I did not find this on the board.

Thank you in advance

Sorry for the distraction.
Will it be possible to modify the BIOS?

@vismut1822 - About the 2-3 pin jumper, look all over board, not just at bottom by other jumpers, be sure to look above/below memory thumb tabs too, sometimes hides there
If you can’t find, it’s OK, you have programmer anyway

This is split BIOS, but safely split so that you can dump/program the 16MB Winbond chip by itself. 8MB chip contains FD, EC FW, and ME FW
Please wait, I will see what I can do here, if anything, this is odd Dell/Insyde BIOS
If we cannot unlock, then we can still directly change settings instead, so one way or another we will get done what you need

I understood you.
I will wait

Here @vismut1822 - Please test and let me know >> At >> System Config >> Below Audio >> USB area >> Do you now see Rear or Side USB Configuration?…295050716851490

I flashed this image into the Windond drive through the colibri
The laptop did not start. Rather, the indicator on CapsLock is on and after 15 seconds it turns off (The fan does not spin.)
I flashed my backup, the laptop started

@vismut1822 - OK, thanks for the test info, I will check BIOS over again and be sure it should be all OK

Please do the following, and show me image of the end of the report, looking for Measured and Verified boot, if it’s enabled at FPF or not.
From Me System Tools >> MEINFO folder >> MEINFOWIn.exe -verbose

I have Error 20


I can’t see the command you entered? Anyway, that is odd, it gives ME read out info, then says can’t find ME!!
Does it do the same if you run without the verbose switch? I see at least FPF committed, so Boot Guard probably enabled here, but it’s not covering the volume I edited in, so not sure why that would brick
The only thing I can think of here is that this module is checksum’d somewhere, and I’m not seeing it, so we may not be able to unlock anything visually. I checked the BIOS I sent you, all looks OK.
If you want, I can try the same edit, but use different tool, maybe that will matter, sometimes it does, sometimes not.
Let me know if you want to test. Actually, here, try this and see if same outcome or not -…489046253628514

Here is the setup file, scroll through, make a list of any settings you want to change by exact name, and what you want them changed to, and I will tell you how to change…418395132189360

Here is a photo of the full request

Unfortunately, I cannot check the latest BIOS image, since it is long and hard for me to disassemble the laptop.
I am ready to make out when I am 100% sure that the BIOS will be flashed, and not turn into a brick.
You need to make sure that Boot Guard is really enabled, and that it really is the problem.
Even MEINFO, when everything should be fine, it gives error 20. This is very strange

What do you think, what could be the cause of this problem?


@vismut1822 - Thanks. Did you try without -verbose?
Also, did you test the above linked BIOS? If yes, is result same? * Edit - Sorry, I did not see your 2nd post until I posted this reply already

No, I don’t really care/need to check if Boot Guard is enabled here, I assume it is, but as mentioned what we edit is not covered anyway so this not part of the problem.

I ran as you requested MEFINO without the "-verbose"
In general, I got absolutely the same error 20.
In the BIOS updates DELL, as well as the System boot guard.
So 800% of it is here, and because of it all the problems.

Thanks, I understand about error 20 without verbose above, but rest of your comment I do not understand

Boot guard is not the problem here, we are not modding anything covered by boot guard. YOu can try the older MEINFO from other System Tools and see if that is same, or check from DOS/EFI if there is DOS or EFI version in the MEINFO Folder
Probably the file I modify is signed or checksum’d and I can’t see it to correct, sorry

Test other BIOS, then if it’s a fail too, we can just directly change settings you need changed instead.

Tell me, how can you run MEInfo via EFI?

Boot to shell and run meinfo.efi

Here’s crappy way to do it Follow link to other thread, do step #1-2 ONLY, then come back to link below, and make USB like shown in image
[Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

Or, better, google how to boot to Shell, then once you have USB ready, copy all files from MEINFO EFI folder to root of USB, then at prompt run MEINFO.EFI

As I said, we don’t have to confirm if boot guard is enabled, I assume it is, but it does not matter for this edit, I only asked to check to be sure of my assumption.
The volume we’re editing for this is not covered by boot guard