How to add nvme support for IBM X3650 M4 BIOS

There is almost no information on Google search for IBM server to add NVME. I tried to add it with UEFITOOL, but I couldn’t save it! In addition, the BIOS file is divided into multiple files and compressed layer by layer, which is really hard to do!

I hope that the experts in the forum can give pointers and provide some ideas, thank you in advance

IBM model x3650M4
Download link for BIOS file:

@ttkx :
Since your problem is BIOS and not driver related, I have moved your request into the Sub-Forum "NVMe Support for old Systems".
I have tried to have a look into the linked IBM BIOS, but was not able to get it downloaded without getting unwanted bloatware installed.
If you want help, you should put the "pure" BIOS file into a *.ZIP archive, attach it or upload it to a hoster and give us the link (if the archive is bigger than 6 MB).

Link to stock BIOS download page as well, the above linked file is not proper BIOS size/format, so I want to see the stock EXE or zip etc…ll&function=all

Please click [UEFI] in the link above to jump to the BIOS download page, You may need to register and log in to download

I am confused, the BIOS file is not a single file

It’s a bit strange. The BIOS file of the IBM server has the suffix * .uxz, which is a compressed file that can be decompressed with 7zip

This is the first time I have encountered the BIOS file of an IBM server. I have no clue at all. I hope someone can help me. Thanks a lot


I used the software SIV 【】and extracted the BIOS under the windows system. This is a single * .rom file, but I can’t edit it with UEFITOOL

If the .rom file is modified successfully, what software is used to write to the CMOS? This is also a problem

BIOS download:


I use UEFITOOL to add the NVME driver to CAPSULE_PLATFORM_A.scap , but it cannot be saved, as shown in the following picture


I have added the NVME driver, but it cannot be verified. Some data may need to be modified, but I do n’t know the source of this data.


Can you provide some clues?

@ttkx - Please use the edit button if you want to add more info and no one has replied yet, no need for multiple posts - thanks!

You are correct, I can’t download that file from IBM without login The file you uploaded first, only extracts to two files with 7zip and neither match what you showed in your image (ibm_fw_uefi_d7e154b-2.21_anyos_32-64.upd + Payload.XML).
The file you uploaded (UEFI_BIOS.rom) is not UEFI file, actually NO File you uploaded here can be opened with UEFITool.
Please upload for me the file you are opening in UEFITool, just so I can look at it, you wont be flashing this (even if you had a flash programmer, we couldn’t use this)

Obviously you can’t flash mod BIOS here with stock tools, so you can stop trying that for now.
You can try unchecking “Verify” and whatever “Additional Options” are, but I doubt that will help, it’s normal that you can’t flash mod BIOS using standard BIOS update method
Is this Intel or AMD CPU system? Do you have a flash programmer, like CH341A?

If this is Intel system, please do the following

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C.2” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder (NOT x64).
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175 << I suggest this, it’s quick and easy way, reboot before enabled may be required

Thank you for your reminder, I will record a video later, which has the most detailed operation process

Video will not help me, and I cannot watch it due to limited internet. Please answer my questions above and do the things I asked, then maybe I can help

The BIOS file downloaded from the IBM website:

This file can be decompressed with 7z, and finally get five files

CAPSULE_PLATFORM_A.scap, I can use UEFITOOL to add NVME driver

File Down:

Problems I currently need to solve:
Need to get the new file d7e172dus.tar.gz file size under linux
However, I did not install the linux operating system and could not get the size of the compressed file
The same file, under the windows system and the linux operating system, the file size is different

now I need to get a New value,【<compressed_size>】 How to get it?
The picture below is the original value

Upload this file for me >> ibm_fw_uefi_d7e172d-3.10_anyos_32-64.uxz
You keep uploading a bunch of files that are of no use for me to even look at, and do not match what you discuss, so I’m not even going to download the above unless you confirm it is this file >> ibm_fw_uefi_d7e172d-3.10_anyos_32-64.uxz

As I mentioned above, you CANNOT flash mod BIOS via any stock method, so stop trying to figure it out and trying to flash this way, or your going to brick the board.

Is this Intel CPU or AMD CPU board? If Intel, do the above FPT stuff I mentioned, but, you may need to give me your ME FW version so I can link you to another thread for ME Tools instead.

If you want to have this done easily, purchase a flash programmer and test clip that fits your BIOS (normal desktop BIOS you need SOIC8 test clip with cable, but I don’t know what kind of BIOS chip this board has, you’d have to show me image)

Additionally, if this is Intel system, it may have Boot Guard enabled at the PCH (burned into chipset), so you may not be able to mod BIOS AT ALL, even with flash programmer.
So if it is Intel, you need to tell me the ME FW version, so I can show you how to check about this before you flash anything

Thanks again for your help, my english is terrible

1.I confirm it is this file >> ibm_fw_uefi_d7e172d-3.10_anyos_32-64.uxz

2. Intel CPU MB

3.I tried many methods to backup BIOS, only SIV can backup, The file is on the link above

4.use FPTw Unable to backup BIOS

I can’t use the editor to burn, because there are two chips on the server motherboard, one main and one backup,

I have modified a lot of BIOS before, and it is really difficult to modify and refresh this IBM BIOS


Now, I have a new discovery, I have another server, model is IBM x3550 M5, this machine model supports NVME hard disk boot system,

I downloaded its BIOS file,

CAPSULE_PLATFORM_A.scap contains NVME driver, this verification Got my previous guess

Now I can export this NVME driver and insert it into the BIOS file of x3550 m4

The only question is how to verify the modified file

Thank you for confirming file name
4. Show me error (FPT) << see below

SIV Backup, this is not UEFI BIOS, or not valid file etc (UEFI_BIOS.rom), that’s why I asked for the ibm_fw_uefi_d7e172d-3.10_anyos_32-64.uxz to check more
FPT may be only way to flash in mod BIOS, this is why I keep asking you about this, we need to try and you need to show me errors etc, so I can tell you how to bypass.

This CAPSULE_PLATFORM_A file, is a very tiny part of the BIOS, partial BIOS update is all. We wont be flashing this, because you wont be able to flash this modified using stock method

Now I see why FPT error, please wait!! You don’t need to show me error now, you need different ME FW system tools package - for SPS v2. I need to ask Plutomaniac if he has and can send to me.
Otherwise, if we can’t get this we can’t check Boot Guard status and we can’t flash mod BIOS, unless you order flash programmer (Like CH341A + SOIC8 test clip with cable, or whatever clip fits your BIOS Chip)

Two chips does not matter, you would dump both and send to me and I will tell you how to proceed. Sometimes one BIOS is backup/copy, other times BIOS is split between both.
Either way doesn’t matter, can be modified if you dump with programmer (IF boot guard is not protecting the region you want to modify)

If you have programmer and cables now, dump both chips and send to me!

Thank you again for your help order flash programmer (Like CH341A + SOIC8 test clip with cable
I have n’t bought these things yet. If it can be written by software, I do n’t want to use the hardware method because it is a little troublesome. In addition, there are many chips on the motherboard. see below pic, Which is the BIOS chip


I am sure that as long as this file is added to the NVME driver and the writing program is deceived, the task can be successfully completed, but I have not found a solution yet.

3. FPTw.exe -bios -d biosreg.bin

Error 3: Internal Error. Unexpected error occurred.

Error 620: Unknown hardware platform.


–copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

No dos folder found, only EFI64 | LINUX64 | WIN32 | WIN64

–Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.

BIOS main page Did not see the version number of ME

HWINFO64 Did not find ME area see pic

Hardware method is MUCH easier, no resitrctions etc - software is probably not going to happen, your ME FW type is a very old one, and plutomaniac replied to me and said he doesn’t have the tool package so I have to see if I can find in google (I only have 3+4)
As mentioned above no need to carry on with FPT, since you do not have the correct version for your ME FW type (SPS v2), and we do not have it here, so NO FPT will work on this system until and if I can find it.

BIOS chip is the 16pin Spansion SFL128P chip that’s labelled “Sys BIOS” - so you need CH341A + SOIC16 to dip 8 clip w/ cable -

Read your manual, what does the “Low Security” jumper do? If it does what some security/service mode jumpers do, it will allow us to FPT flash once I have the correct package, without having to jump through some possible hoops we may have to otherwise.

Also, read what the “UEFI Boot Recovery” jumper does, this may auto-flash BIOS from USB possibly, if that is case you may be able to get mod BIOS flashed in that way

1.Read your manual, what does the "Low Security" jumper do?

There is no description in the manual what the "UEFI Boot Recovery"

Can switch to alternate BIOS

3.I still hope to use the software method

OK, thanks! We can test about security jumper, once I find SPS v2 tools package (This will be only software method, if I can find, because we need this before anything is attempted to flash because if boot guard enabled = brick no matter how you flash mod BIOS)

OK, thanks a lot

I found two versions of the BIOS file, ver2.20 and ver2.30. After comparison, only the file 【CAPSULE_PLATFORM_A.scap】size is different, please see the picture below

Bios files Down:

After comparison oem_ibm.xml , Only the values of the three fields are different, currently I cannot get the value 【compressed_size】please see the picture below

I have added the NVME driver to the file 【CAPSULE_PLATFORM_A.scap】, but when using IBM BIOS tools to Flash, the verification fails, I think it is related to the value of the above field 【compressed_size】please see the picture below

I Hope someone can provide some suggestions, how to pass the verification? how to get the value 【compressed_size】?

Size does not matter to anything here. Nothing you can do without SPS v2 tools as mentioned, or flash programmer, don’t waste your time

I already bought it flash programmer

However, the chip still cannot be recognized. The seller said that the chip needs to be taken down. I do n’t have this hands-on experience. It seems that it can only be solved by software.

What is the BIOS chip ID? You just need to learn how to use and get used to using it etc. Chip does not need removed usually. Sometimes you need to leave power supply connected to board though, sometimes you need to remove.
Main thing is, the clip is VERY hard to get into perfect connection, sometimes you may need to re-try 10+ times before you get it perfect. Keep at it and you will get it, provided you are connecting everything correctly.

Here is a guide, DO NOT ERASE or WRITE anything (or use “AUTO”), until you have made a dump and send to me to check, otherwise you may erase your chip without getting a good backup made first and then you wont be able to fix!
[GUIDE] Flash BIOS with CH341A programmer

I tried many times,

In the case where the power cord plug, the BIOS chip can not be identified, but may recognize the programmer

A second inner unplug the power cord can be identified to the BIOS chip, but after 1 second, the BIOS chip can not recognize

I think it might be insufficient power supply