How to flash the gigabyte 6 series mobo to uefi bios?

As everyone knows,there are many gigabyte 6 series mobos without efi bios.
Such as p67a-ud3p-b3,I hope to flash it to the uefi bios which p67x-ud3r-b3 has.
but the flashefi has ID check,and how to avoid it to flash?

Another question
How to rename the bios to another mobo?I used AMIBCP but it seemed failed.
eg:rename bios of p67x-ud3r-b3 to p67a-ud3p-b3

Thanks!!!

Which form of motherboard do you use? GA-P67X-UD3R-B3 (rev. 1.0)
if yes this is the motherbord GA-P67X-UD3R-B3 (rev. 1.0)? latest version of your bios firmware already supports uefi
you use BIOS/UEFI right now? guesses BIOS firmware


Earlier, when it comes to BIOS updates, you need to follow the version number to last update to the latest available version

i did this myself and regret this all the time
when it comes to updates of BIOS firmware/UEFI firmware, dont run (BIOS firmware.exe)/(UEFI firmware.exe) update inside Winodws what so ever rather use FreeDOS latest version today 1.2

You want to go from a stable BIOS firmware version
to a BIOS / UEFI version that gives you the support for UEFI but which is in beta version

step one step is Pre-alpha or Nightly builds
step two is alpha version
step tree is the beta
step four release release
step five so-called gamma version there after final release




would not recommend flashing what you want to do as it says this is a Beta BIOS
(Most important of all makes backup of your (BIOS firmware/EEC firmware/Intel ME firmware)<— If you do not do this, you will otherwise regret that you yourself have experienced this


Earlier, when it comes to BIOS updates, you need to follow the version number to last update to the latest available version


can find official publications on the Intel chipset 6

There are different versions of the chipset 6 and also the processor needs to know exactly which processor you are using

I found this info (Switch BIOS ID), which I already knew I could do for you, but to be honest many of the UEFI BIOS for P67-Z68 were only hybrid UEFI/BIOS and were very buggy (broken CPU multi + other random bugs) - https://forums.tweaktown.com/gigabyte/28…a-bios-833.html
If you are using SB CPU then best to stick to BIOS instead of UEFI/Hybrid, if you are using Ivy CPU, then up to you to decide if you want UEFI BIOS and broken CPU multi (Sticks at 31 or 32 I think, can’t remember, plus whatever bugs mentioned on that page due to the boards not matching)

If you want me to swap BIOS ID’s for you, please link your original BIOS for your board and UEFI beta BIOS you want ID switched to match your board. Or you can put both in a zip for me.
Same will need done in reverse if you want to flashback + use AMI2Award tool

@Lost_N_BIOS :
P67a-ud3p-b3 just got award bios.And P67x-ud3r-b3 has got uefi bios.
So I want to flash ud3p to uefi bios
I could use WinHex64 to change the code,but I found the code is different between award bios and uefi bios in the same mobo.So I got confused.
Could you tell me how to find the ID code in one board.

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing

Desktop.rar (4.27 MB)

It has to be edited in a few modules and not by straight hex for some, I will make P67x-ud3r-b3 BIOS for you with P67a-ud3p-b3 ID in a while, maybe tonight if I run out of time today.
When I do it, I will tell you the locations of all this in both files.

* Edit - @gloobox - Flash using included FlashEFI from DOS (or autoexec)
http://s000.tinyupload.com/index.php?fil…158085891922913

GA-P67A-UD3P-B3 – 37 41 38 39 56 47 30 39 / aka 7A89VG09
GA-P67X-UD3R-B3 – 38 41 32 31 41 47 30 55 / aka 8A21AG0U

BIOS ID locations on GA-P67X-UD3R-B3 BIOS

Unicode text “8A21AG0U” found in AMITSE>> PE32 image section at header-offset 413E4h
Unicode text “8A21AG0U” found in Setup >> PE32 image section at header-offset AFC4h
ASCII text “8A21AG0U” found in CMSCore >> PE32 image section at header-offset AC1Ch

Those three I believe are for system info/display only, not for flashing (not done in file above).
These two below, change (Already done in file above)

ASCII text “8A21AG0U” / Hex ID - found in Raw section at header-offset 24h / GUID - 56E14F88-234B-4C34-B204-299670447247
ASCII text “8A21AG0U” / Hex ID - found in Fid (Flash ID) at header-offset 1Bh / GUID - 3FD1D3A2-99F7-420B-BC69-8BB1D492A332

@Lost_N_BIOS :

Thanks!!!
Another way to solve the problem,could you mod the “flashefi” to ignore ID check
as with the link below
https://www.win-raid.com/t1361f16-Flashing-Gigabyte-while-avoiding-quot-Invalid-BIOS-image-quot-1.html#msg48828
I tried the '“efiflash” but it was useless for gigabyte 6 series

Or this way would be fine?
Mod the p67a-ud3p-b3’s award bios ID offset to the p67x-UD3R-b3’s award bios ID
then flash it,p67a-ud3p-b3 will turn into p67x-UD3R-b3’s award bios
then flash the p67x-UD3R-b3’s award bios smoothly.
And could you tell me how to find and mod the award bios ID offset?



EDIT by Fernando:
Unneeded fully quoted post replaced by directly addressing (to save space and for a better readability)

@gloobox :
Please stop fully quoting any previous post! It doesn’t make any sense, but prolongs the Forum access time and decreases the readability of the related thread.

@gloobox - you’re welcome! Let me know how the flash goes, so I can mark the file confirmed OK or not on my end. I’ve done similar mods for many Asus and Gigabyte boards, but I like to be able to get report back so I can mark it for sure confirmed working.

On your last method/question, that will work too but could cause some issues, I gave you the p67a-ud3p-b3 ID location in the above download, check the Info.txt
If you do this method, right after you update the main BIOS and reboot hit ALT+F12 before it starts booting (Hit several times), if you get boot menu reboot and try again, until you see “Press [Enter] to start copying main BIOS to backup BIOS.”
This is best done with PS/2 keyboard if you have. Same function on UEFI BIOS, but it’s done with ALT+F10) This way, backup BIOS will get updated with your ID swap too.
Otherwise the update to UEFI BIOS might fail mid-way through and leave you with one BIOS of each type and that will possibly brick the board. It may fail midway through anyway, due to this ID difference between Main/Backup

Originally suggested method as I modified above is suggested rather than this way, due to this reason.

I can try to mod flashEFI but can’t promise anything, it’s totally different than EFIFlash, so none of that info applies. And that file is so small, I doubt any good, easily recognizable info is hidden in the assembly coding
I can easily spot what to edit in EFIFlash as you can see below, but it’s not needed anyway because you can edit the single byte in BIOS when it’s enabled (What’s discussed in post one and it’s image, of that thread you linked) - [OFFER] Gigabyte GA-Z370-Aorus Gaming 7 BIOS mod (6)

EFIFlash.png



What is the exact error it gives you?

@Lost_N_BIOS OK,could you mod the flashefi to me?
If failed,I can feedback to you quickly~~~

@gloobox - as explained, I cannot easily do that, but if I even want to try I need to see or be told the exact error you get when you try with it now.
And, as I mentioned, doing it that way may brick your board due to the way dual BIOS works, do you have a flash programmer to recover?

@Lost_N_BIOS
I’ve got ch341a and clip,but gigabyte’s bios must be welded out from the mobo to flash.And I don’t have a heat gun so far…
So,If dual bios could be destroyed,just put this method on ice……

Gigabyte BIOS does not need removed from the board to program with CH341A + SOIC8 clip, you can do in place (Both too if you wanted)
And yes, I am not certain it will brick doing what you wanted with FlashEFI, but there is a chance due to on reboot after flashing one BIOS will have on ID and the other will have different ID

That will not happen if you use the original BIOS and package I posted on post #5, that will update both BIOS at once to same UEFI BIOS file.

@Lost_N_BIOS
I could show you an example.
I’ve tried z68p-ds3 rev1.0 update to it’s official but unpublished uefi bios version which had cpu fan bug,but I mod the CPU ID offset of Z68A-D3H-B3,let the CPU ID offset same as z68p-ds3 rev1.0,finally it was flashed successfully but the mobo name change into Z68A-D3H-B3,And certainly fan bug had been resolved!!!
And I use the “efi2awd” to flash back the z68p-ds3 rev1.0’s award bios,it was flashed successfully too!!!And the mobo name became back to z68p-ds3.
All the process,the CPU ID offset keep the same as official bios of z68p-ds3 rev1.0.

So I thick as we remain the CPU ID offset of the mobo unchanged(no matter award and uefi),it would be flashed successfully.
Do you think so?

You have to change the model ID in a few places before, or after and reflash again, if you want to change the model name. I did not mention this before because you didn’t, so I didn’t think you cared.
Since you are now talking Z68, I’m lost. If you need to know how and where to change a motherboard model name let me know exactly what BIOS you want this info from and I will show you.

CPU ID or any CPUID offsets, have nothing to do with any of this, but unsure what you mean really, maybe you mean something else?

@Lost_N_BIOS
My friend was on vacation that I could not play with his p67a-ud3p

But I did the trick with another mobo!!!
mobo:p67a-ud3r
The mobo is “b2” version,first I flashed the “b3” version bios which was modded the check ID.And then I flashed the uefi bios version of p67a-ud3r-b3,and it could flash smoothly!!!
At last,I flash the nvme bios by Q-flash.It’s OK.

Good work @gloobox Let me know how stress testing and such goes on “B2” flashed to “B3”, I considered that on the non-UEFI BIOS but never got around to testing

@Lost_N_BIOS
About B2 and B3 version,B2 just get the problem of sata2 interfaces but not sata3.
So I play games,watch vedio are everything is OK.

Btw,Asus’s B2 and B3 bios version are the same(eg:P8P67),But Gigabyte show no mercy to the B2 version that can’t support 22nm IVB CPU.
After flashing to the B3 version,I can put my 3570K in it.

A little bug:
4 pin CPU fan can’t run.3 pin is OK.

So I flash the P67X-UD3R-B3 by modding the check ID,All is well!!!

Thanks @gloobox - yes, I know about the issues with B2, but wondered if the PCH changes in the BIOS for B3 would affect usage at all on B2 systems.

Hello! Forgive me my English. It’s all Google Translate. Please tell me, could you reflash the BIOS GIGABYTE GA-P67A-UD3P-B3 on uefi?

@Lost_N_BIOS
Just found this… is the U1G (2017 2nd beta) for GA-Z68X-UD3P-B3 a bad / buggy one?
If that’s a dud, are there tools that can do the UBU things to the F8 BIOS