[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Thanks! First I’ll give you time to take a look on my modified Bios.

Later I will use AFU as you raccomend with [Guide] Flashing modified AMI Aptio UEFI using AFU

Yes, please upload your modified BIOS and I will check it over.

This is my modded BIOS (I added ".M1" to the name to recognize that it is the Modded one BIOS).

I’ ve insert the "NvmExpressDxe_4.ffs" becouse UEFITool dosen’t say "File size exceeds the BIOS volume size", it’s the last DXE record.

If you need it, this is the link of the last original BIOS that I’ve modded https://www.asus.com/it/Laptops/N751JK/HelpDesk_BIOS/

Thanks a lot Lost_N_BIOS, take your time for checking the file, I’m not in a hurry

N751JKAS.205.rar (2.21 MB)

write please the instructions for the firmware of msi h97 gaming 3 motherboard

The method is the same for all mainboards/systems with an AMI UEFI BIOS.
If you are unsure, whether you have done the BIOS modificatio correctly, put the modded BIOS into a *.ZIP or *.RAR archive and attach it. Then I will do a look into it.

@raven1234 - thanks! First, you have to remove the BIOS from the capsule container, then modify. Do not put back into a capsule (Nor rename .cap)

If I was you, I would start over and do the mod again, with the below first if you didn’t do that the first time.
Because I am not sure, if you extract the rom now, if checksum or something else needs corrected in BIOS after the mod, which UEFITool already did, but if contained in cap file that would be part of the checksum making it wrong to extract after the mod.
Hope you get what I mean. I think it’s safer to redo the mod, extracting the rom first from capsule, insert the NVME module, then save/rebuild and then flash.

Then flash as I mentioned. If the NVME mod is all you did, then it looks correct to me, except for the above concerns.
Open the .cap file in UEFITool, right click AMI Capsule file, and choose Extract body.
Then, that file is what you want to flash with using methods for flashing modified BIOS, and what you should do before modifying BIOS.

You can flash with AFU or FPT, How to with AFU Is in the guides linked above

Here’s how with FPT (Intel Flash Programming Tool) - FPT - >> FPTW.exe -F N751JKAS.205.M1 -savemac -BIOS
You need to use FPT from version 9.5 system tools - https://mega.nz/#!CdFUSaxb!DkpSh5cUQN7hs…IurQ18sGI_O3KR4


I think I understand what you mean but for safety I write the process of what I will do:

- Open the original BIOS with UEFITool (my bios have no .CAP extension, original file is called “N751JKAS.205” without extension. This is not important, right??)
- Right click AMI Capsule file, and choose Extract body. IT will generate a file .ROM (to be clear, I’ll call BIOS_1.ROM)
- Open BIOS_1.ROM file and add the NvmExpressDxe_4 record as last DXE position as written in the guide
- Then File\Save Image File from UEFITool for generating the modded BIOS (to be clear, I’ll call BIOS_2.ROM). This file will NOT BE encapsulated
- Flash BIOS_2.ROM file with AFU or FPT

Do you agree?

A second Question: Can you write the link for downloading AFU?
The link of the guide (http://www.ami.com/download-license-agre…ate_Utility.zip) say "We are sorry. Your file does not exist. Please contact your AMI representative."

If you think that FPT (Intel Flash Programming Tool) is equally good I can use that but please confirm to me that the right file of the RAR archive is on the folder "Flash Programming Tool/Dos/fpt.exe"

Thanks again!

That is good then if that is what you already did! .205 is .cap actually, no matter what it’s named, I only meant you should probably extract the BIOS out of the capsule before modifying, which you already did it seems.
I wrote all that because the BIOS you uploaded to check was inside a capsule again, which it shouldn’t be if you did as you outlined above. Or, sorry, is that outline above only you asking what to do now to do correctly?
If so, yes, please that’s what I meant to do, sorry if I made anything unclear

I will get you AFU link tonight, or look in google for AMI AFU Download (Try to find latest version you can, and older ES versions, in case you need to use /GAN switch).
For FPT that is correct if you want to use DOS version. Don’t forget -savemac switch when using FPT, if it gives you error about MAC then remove that switch and we can fix later (As long as you made backup first). Or stop and use only AFU
In DOS you must also use fpt.exe instead of fptw.exe

You right! I haven’t made "Extract body" command in the first Bios that I posted. Now I understand what you mean :slight_smile:
Thanks for your help!

In attach the Bios maked with the procedure I wrote before.

Excuse me but I don’t know what to use between AFU or FPT becouse it’s my firs time…my desire is to do the simplest method to avoid mistakes.

For example CodeRush say in the guide that AFU is not reliable

If AFU is good i find the official download page otherwise I can use Fpt! https://ami.com/en/products/bios-uefi-to…uefi-utilities/

I must to download AMI Firmware Update (AFU), right?
maybe Aptio 4? Or another?

I ask you really sorry for the many questions but I’m incapable and it is always a bit risky to flash a bios

BIOS M1.rar (2.21 MB)

I sent you AFU versions, I am not sure which is better to use, AFU or FPT (I’ve used either). But, if @CodeRush says AFU is not reliable and to use FPT instead, I would use FPT then (Just don’t forget the -savemac switch) And always before you write/flash anything, make a backup preferably with both AFU and FPT

No problem about asking questions, it’s good, you are right BIOS flash can be risky, especially when you have modified BIOS. I looked at BIOS and it looks good, other may have been OK too but better to be safe than sorry.

Backup BIOS
From Wwindows with AFU >> afuwin.exe backupBIOSname.bin /0
From DOS with AFU >> AFUDOS.exe backupBIOSname.bin /o

From Windows with FPT >> fptW.exe -d backupbios.bin
From DOS with FPT >> fpt.exe -d backupbios.bin

Flashing BIOS
From Windows with FPT >> FPTW.exe -F BIOSM1.rom -savemac -BIOS
From DOS with FPT - FPT.exe -F BIOSM1.rom -savemac -BIOS

* I removed the spaces in your new BIOS file name, you should too, then flash from above commands

Thanks again, I’m finally starting to understand.

1) I prefer to use FPT. You suggest to use from 9.5 r5.
I must to use that one or it’s best use the lastest release ? ( That is V12 r7 Intel Management Engine: Drivers, Firmware & System Tools)

2) Just for know, my bios is an Amibios 8 right ? (not Aptio 4 or V)

3) Make Bios backup give me some insurance?
I have to prepare an USB Dos bootable pen with the backupped Bios?
I know that if the BIOS update goes wrong it is no longer possible to fix except if desoldering the EEPROM and flash with a programmer…and I did not understand how the backup can be useful.


Yes, I’m pretty sure you have to use the one from system tools that matches your Intel ME version. At least that is how I’ve always done it because many of the other Intel system tools you have to use correct version matching ME, so I’ve made it habit, it may not apply to FPT but I bet it does.

You’re BIOS is Aptio 4, but can be opened with some Aptio V tools as well. Yes, you always want to make a backup, in case you need to recover your motherboard serial, UUID, LAN MAC, DTS Key etc. Or yes, also in case you need to recover later you can use it.

Recovery can be done without soldering, using jumper type cable and a flash programmer.

Ok, so I will do this: ( it could be useful to others write the procedure)

1) Checking my Intel ME hardware version: (I saw that exist "v10.0 r6 for 8-series systems with ME v10.0" but I’m sure that the best is what you say, that is "v9.5 r5 for 8-series with ME v9.5"

2) Make Bios backup
- Open Windows prompt and reach FPT & AFU path and do:

From Windows with AFU* >> "afuwin.exe backupBIOSname.bin /0" <— it’s a ZERO or an O letter??
(If someone want to use DOS version of AFU command is "AFUDOS.exe backupBIOSname.bin /o" <— it’s a ZERO or an O letter?? )
* (for mine is Aptio 4 version)

From Windows with FPT "fptW.exe -d backupbios.bin" (If someone want to use DOS version of FPT command is "fpt.exe -d backupbios.bin" )

- Save backup file on an external storage and send to my Email

3) Flashing Modded Bios with FPT (In this example modded Bios file is called "BIOSM1.rom" )
- Open Windows prompt and reach FPT path and write:

"FPTW.exe -F BIOSM1.rom -savemac -BIOS" ( If someone want to use DOS version of FPT command is "FPT.exe -F BIOSM1.rom -savemac -BIOS" )

4) Reboot

Thanks, I’ll write to you if everything went well!

P.S. Excuse Me @Fernando , in this guide it is not specified that, before insert the NVMe module, need to extract the AMI Capsule with "Extract body" command.
Maybe it’s not normally necessary but I thought it was useful to tell you

I looked at what driver version was posted for your board, because it was quick and often the same as ME FW on older setups, but not always.

If you want to know for sure, you have to install the latest Intel ME drivers for your board - http://dlcdnet.asus.com/pub/ASUS/nb/Driv…VER95231766.zip
Run the MEinfoWin from that same version system tools package (The version I mentioned, linked above from Asus). That will give you your FW ME version, it will show current ME FW version.
Then you can try latest FPT, or if that fails use the version of FPT from the package that matches your actual ME FW version.

When using ME related tools such as MEInfo, you must use same version as the install ME FW, you cannot use latest version for this, nor older versions, they must match and that is why I said go ahead and use FPT from there too (unsure if that is required for FPT or not)

Sorry for the confusion on the AFU backup, it’s in the letter O (lowercase o may be fine too, unsure), not zero or number 0

It’s common knowledge that when modifying BIOS, the capsule will be broken anyway (It’s purpose is security capsule, to prevent modification). So most already assume to extract body before modifying, and don’t put back in some other BIOS with capsule.
So yes, I agree with you and think maybe Fernando should add this to the guide so it’s clear to everyone. It may not be necessary to do this for the modifying part, but it has to be done before flashing anyway so always best to do before you start any modifications.

Thanks so much for maintaining this site @Fernando ! I can hereby confirm successfully installing to and booting from a Intel Optane 800p NVME drive on a 2012 ASUS P8Z77-V motherboard using a simple M.2 to PCI-E adapter card and following the instructions in this thread. These are the steps I followed to make it work:

1. Mod the latest ASUS P8Z77-V BIOS according to instructions here:
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

2. Rename the modded BIOS file to “Z77VB.CAP” as described here:

3. Flash the modded BIOS using the ASUS flashback method.

4. Set BIOS settings:
First “Load optimized defaults” (F5) to make sure you have a sane starting point.
- “BOOT → Fast boot = Disabled”
- “BOOT → CSM → Launch CSM = Enabled” and all other settings to “UEFI driver first”
- “BOOT → Secure boot → Secure boot state = Disabled” and "OS Type = Other OS"

To disable secure boot, see https://www.technorms.com/45538/disable-…fi-bios-utility.

4. Create installation media exactly as per the instructions here:
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

I disconnected my other drives when installing Debian GNU/Linux 9.5 to the NVME drive, chose automatic partitioning and went with the default choices when installing GRUB. I don’t do dual booting using GRUB, but rather select which OS to boot using F8 on boot to trigger BIOS boot devices selection (I have Linux on the NVME drive and Windows 10 on a SATA drive).

IMPORTANT note for others: I wasted a lot of time not understanding how crucial it is to follow each step in this thread precisely, so make sure you don’t miss a step.

Have a problem getting my new 970 Pro 512 Gb to boot on a X79 Rampage IV Extreme.
Did flash a modified 4901 bios which I took from ROG forums, seemed to go OK, set the bios like in this guide (all other drives disconnected), Win10 installs, but after it finishes installing and restarts, windows won’t boot :frowning:
I’m getting a message like this: http://vfl.ru/fotos/e8771f4f22570830.html

Tried CSM both enabled and disabled with these settings but to no avail, same result prompting me to go to CSM settings to select the proper boot device.

Here are some other settings from my bios. What am I doing wrong or missing?


I guess my bios update was unsuccessful, how can I check it?

Thanks for any help guys.

@alster :
Welcome to the Win-RAID Forum!

As far as I can see: Nothing, but you should disable the option “Booting from Network Deices”.

Do you see a Disk Drive named “PATA SS” within the BIOS? If yes, it is your NVMe SSD.
How did you flash the modded BIOS?

Dieter (alias Fernando)

Hey Guys,
I have the Asus Maximus Hero Vi (z87) mainboard an bought a Samsung 970evo Ssd, connected via asus hyper M.2 X4 Mini Adapter.

I cloned my old ssd with Samsung Data Migration, while the nvme driver was already installed on it

I followed this guide and already flashed my Bios and now the 970evo shows up as Pata ss - as it should.

Regardless of what I do, I can’t boot from the 970 as it either wants me to activate cms, or if it is tries to boot from the „generic storage device“
or gives me like the „_“ sign frozen in the top left corner depending on my bios Settings

What do I have to do next?
Do i need additional DXE Data for M2 ssd instead of sata ssd? Do i need something because of the PCIE adapter?

-> additonally i found in the description that the adapter only supports x99/z97/h97/b55 mobo but as I can use it while booting from my old ssd this shouldnt matter i guess

If this questions was already answered please share a link to the answer

Thank you so much in advance
your effort for helping people and providing knowledge is amazing

Hi Fernando,
No, I don’t see any ‘‘PATA SS’’ anywhere in the bios ( It should be within ‘‘boot’’ section of the bios, right?
I flashed my bios via Flashback, the LED blinked like 4-5 times and after that I restarted the PC. However, the settings within the bios remained intact, though they always change after bios reflash, that is why I guessed it didn’t flash properly.
What should I do now? I read all the previous post with similar problem but it didn’t help me ((

@Directed :
Welcome to the Win-RAID Forum!

It is not enough to have the NVMe driver installed, you must have booted from it, if you want to proceed with a clone of your previously used system drive.
Where did you read, that you can simply boot off a cloned system drive? You should consider, that your currently used bootable system drive is not connected to any NVMe Controller. That is why you cannot boot off the cloned copy of it.
My advice: Follow my guide and you will succeed.

Good luck!
Dieter (alias Fernando)