hp omen 15-dc0030nr

Ive dumped my bios, and am able to view it via amibcp. Could I edit and make the changes I like and simple flash it with a hardware SPI programmer? Would it matter if its locked or not if using a programmer?

Make sure you are using the latest correct AMIBCP, sometimes older version may work with your BIOS, when a newer version may also work too and would be the better choice.

Yes, programmer is all you need, locks don’t matter then. Dump your BIOS and make sure you get a verified dump (open programmer, read and then verify only, once it’s verified then hit save and keep a copy safe unedited). Then edit a copy of your dump and reprogram.

AMIBCP may not be able to enable everything you want, that depends on what you’re trying to do, if your mod doesn’t get what you need accomplished post back and let me know what you want done and I’ll see if I can help you fix it.
Enable chipset tab is one it usually wont help with, and sometimes advanced tab too, usually other methods needed as well.

I was told that rsa signed bios’s brick when you try to edit anything and flash them. So that is false?

Here is the bios file if that helps at all.

Im used to desktop bios, this bios is very limited and Id just like to see what all can be added.

Sometimes that is true, especially with “Flashing” Pulling a dump off the BIOS with programmer and editing it not the same, that is easier usually with higher success rate. Do you know it’s RSA signed, drop a link to stock BIOS download. The BIOS you uploaded is not encrypted.

This BIOS opens in AMIBCP latest version 5.02.0023, mentioning in case you only tried older/others.
If you try your mod BIOS, and it works, but doesn’t show the options you wanted enabled, let me know what those are and add images of your current BIOS showing main tab, advanced tab, security, and save/exit tab and at least one that shows all currently visible sections.

Ok perfect thanks for the information. Ill let you know how it goes in a few days time once i get the programmer.

Here is the link to bios. https://ftp.hp.com/pub/softpaq/sp88501-89000/sp88526.exe

Thanks, due to the way this is packaged, I cannot tell still if RSA signed or not, mainly due to how it’s built and how you’d extract (With AMIUCP, so BIOS file name is under R00 instead of what we’d want to look for when checking RSA)
But, both the contained BIOS and your dump are exact copies byte for byte. So I think that’s a good sign, but wait… How did you dump your BIOS, if programmer has not arrived yet?
I see clean NVRAM too, so I don’t think this is a dump in the way we normally talk about BIOS dumps.

I see in FD of both your “dump” and the BIOS I extract with AMIUCP has read/write BIOS region = yes, so you should be able to dump -bios region with FPTw
Can you please download Intel System Tools package v12 from this thread in section C
Intel Management Engine: Drivers, Firmware & System Tools

Then run this from the Flash Programming Tools folder and upload the file.
FPTw -bios -d biosregdump.bin

I was getting it from the copy firmware function by running the update tool.

Heres the dump https://filehost.net/66a9fc3a79d1d518

So that’s why it was exact copy

So, we can test a modified BIOS region flash now if you want, or wait until your programmer arrives?
If you want to go ahead and try now, test something simple that you know will be visible, edit in AMIBCP change some setting or enable some setting (Not in advanced or chipset), then flash and see if it flashes and booting is OK, then see if BIOS changed or not.
Something like on Boot page, change nun-lock default (To OFF) and then see if flash is OK and num-lock default setting changes or not.

FPTw -bios -f modbios.bin

So fd is unlocked? I might give it a go just worried to brick it and be stuck waiting on programmer. Thanks for all your help.

Sorry, I can’t check that with BIOS region dump, I should have asked you to dump FD… my bad

Here is to dump the FD
FPTw -desc -d FD.bin

I think it may be for BIOS region, you can test by flashing the unmodified region dump back and see if process completes without error
FPTw -bios -f biosregiondump.bin

If the above completes OK, without error, then your BIOS region is unlocked and you can attempt to make changes in AMIBCP.
However if RSA signature is being used internally then any change to BIOS will cause boot failure and you’ll need to do BIOS recovery most likely.
That can only be tested by trial, change something and see if OK or not. Flashing back the non-modified BIOS region dump wont let us know about this or not, only an edited BIOS region flashed back would.

If this is your only good computer, I would wait for programmer before trying anything modified, just in case the RSA stuff is going to brick the system. But if you have another system you can use while waiting to fix a brick, then it’s up to you

Heres the fd bin https://filehost.net/f4dc2409224286eb

I think I will wait on the programmer just in case, but again thanks for all your help.


Looked in uefitool and seen that read and write to. Does that mean fd is unlocked?

Yes, that means BIOS region is unlocked for read/write, that’s what I was saying before, this is the only region you are modifying when using AMIBCP. That’s why I had you test dumping it to see if we could then test flashing it back if you wanted to try.
If you do want to try, first try flashing back the unedited region dump, then if OK you can try flashing a modified BIOS (complete BIOS file used), but use the -bios switch in FPT so it only flashes the BIOS region out of the file

It does not mean FD in unlocked, it only means those you see write yes are unlocked, unlocked FD would be all yes on both sides

Perfect thanks for clearing that up for me.

When you say complete bios file used, edit the bios dump with amibcp? I seen in another thread you wrote it was possible to just edit and flash region.

You’re welcome! No, I meant use entire BIOS image to flash, not BIOS region, since you can’t edit a BIOS region with AMIBCP (I don’t think, never tried - Wrong, see below )
Probably in other thread I was talking about modifying the BIOS region and or it’s modules another way, with other tools etc.

Anyway, I meant edit the BIOS with one simple change for test in AMIBCP. Then flash with FPT using that entire BIOS image, but flash only the BIOS region using >> FPTw -bios -f biosname.bin
Or yes, it can be flashed region only, but you have another step there after you modify the entire BIOS with AMIBCP. Then you extract BIOS region UEFITool, then flash with that.
There’s more steps and possible errors that way, this is why I suggested using the entire edited BIOS, but with -bios switch so only region is flashed. Since BIOS region is unlocked in FD, that is all you can flash via FPT anyway, if you don’t use the -bios switch you will get error and it will not flash

I checked before posting, and you can edit the BIOS region file in AMIBCP, learn something new every day! So, whatever seems easier to you I guess, just keep in mind if using entire BIOS use -bios switch so only region is flashed otherwise it will fail with error due to locked FD (use -bios with region flash too of course)

Sorry if that’s confusing, but I want to leave it all there If you need me to make a quick short summary instead let me know.

A short summary would be awesome. Thanks again for all your help. Nm figured it out. But now I get this error https://imgur.com/a/DYRe1DJ


Is there a way to see if this new bios revision will lock it down? https://ftp.hp.com/pub/softpaq/sp92001-92500/sp92193.exe

PRR (protected Range Registers) set is a bit more tough to get past, if it can be done (Sometimes, by PRO’s, which I am not at that edit). Is that with your stock BIOS, attempting to reflash the -bios region only?
If yes, OK, if not and it’s modified BIOS, see if you get the same when using stock BIOS. In mean time I will look in BIOS and see if I can undue the PRR lock, if not you will have to use stock BIOS until you can get a flash programmer and test clip cable.

Sorry, forgot to add, no, new BIOS will have same locks as old BIOS.

Your the best thanks for all your help!

You can try flashing with AFU/AFUWin/AFUWinGUI, these are the default flags used in the stock package >> /dc:0 /p /n /mer /fdr /reboot /ssid:084DA,084DB

I would use only these >> /p /reboot
If using the GUI version, uncheck everything except "Program main block"

However, I now see this BIOS is RSA Signed like you mentioned, so nothing may work Even with programmer (Sorry, I forgot you had already when I mentioned that above… Or, has it not arrived yet).
It may be OK, once you dump with programmer and we edit, but we wont be able to tell that until you can dump and we test.

I’ll still check on the PRR lock for you now though, but I think it might possibly brick on you if it does flash in? Sometimes clear CMOS will fix that, if not you will have to try recovery methods, or wait until programmer arrives.

*Edit I see it also has “BIOSGuard” feature, so probably no matter what, nothing is going to work even with programmer

Damn programmer gets here next week seller is slow to ship. So even with programmer it might not work? PRR if you find that would that make it so I could flash? If so is there tutorial on PRR I have nothing but time on my hands to search.

Oh wow so biosguard will stop anything we try to do and theres no way around biosguard?

Yes, sorry, even with programmer it may not work due to BIOSGuard. I mean even if we get around RSA stuff with programmer and got lucky on that front, it looks like BIOSGuard checks some kind of signature too but what I do not know. HP is becoming more of a pain for BIOS modifications each day.
The new version of this I’ve dealt with recently is now called HP SureStart, which re-writes the BIOS on reboot no matter what you do, from some other non-BIOS chip on the board.

I found the PRR lock in your BIOS region dump in 4 modules at 7 locations, I can remove which should let you go past that 301 PRR error you just posted in FPT, but then you may end up with a brick until programmer arrives (I can’t be sure of outcome due to never tested what happens with RSA signed BIOS flashed in)
If you want to try, and want me to go ahead and remove this lock, let me know.