Orom (Intel-RST_RAID-ROM_v15.9.3.3408) you can find here:

(Under B. Newer Intel RST(e) RAID ROM modules:)

The Z77 chipset will support EFI RaidDriver v13.x Series.

It is not easy to understand your last post.
What is the sense of it?

Please click on the right side of my reply where it says ‘daniel_cascales.’ That will show you the article I replied to.

Hello, I need the latest version of Intel Raid Rom (Rom/Sata Driver), currently I found the following version:

I need to update my raid for Acer aspire f5-573G. As for the parameters of my laptop:
Intel i5-7200U
Windows 10 (64bit)
Disk 1 TB HDD and 256 GB SSD
my driver is:
Intel(R) 6th Generation Core Processor Family Platform I/O SATA AHCI Controller
matching identifiers

thanks in advance

Neither you nor your Acer Aspire needs an updated Intel RAID BIOS module. It will not be used by your current system, because it is running in AHCI mode.
By the way - the download link to the currently latest RST v17 platform EFI RaidDriver module v17.8.4.4671 can be found within the first post of this thread. The related Legacy Option ROM modules are offered within the first post of >this< thread.

Now I have a question: how to upload this EFI Raid Driver module v17.8.4.4671 file because the file itself weighs 68 KB and secondly, is it possible to update the AHCI version? because in my laptop it is version 1.31
Second question, is this link

where I placed it, is it possible to somehow replace this file so that it detects the latest version?

This Forum doesn’t just offer BIOS modules, but also Guides about how to get them into the BIOS. Please read the entire start post of the related threads before asking already answered questions.

An Intel RST EFI AHCI BIOS module is neither required nor available.

I wanted to ask one more question, of course I read the instructions at the beginning on how to update the EFI RaidDriver module v17.8.4.4671 but I have a question regarding this link

in which folder should the .efi file be replaced from the older version to the newer one EFI RaidDriver module v17.8.4.4671 is it even possible

I found this version from 2020 regarding intel raid rom for this device:

I have similar parameters to my aspire f5-573G, so I thought it would be suitable for updating my firmware in this matter
question is it still for my aspire f5-573G??

You should expand the DXE Driver Volume of the BIOS and look for a module named “SataDriver” or “RaidDriver”.
Provided, that the desired newer module is complete (as *.ffs file) and has the same GUID Header as the older one, you can simply replace it. Otherwise you should replace just the “body” of its PE32 Image.
By the way: An update of the Intel RAID BIOS module only makes sense, if the on-board Intel SATA Controller is running or will run in “RAID” mode.

Intel RAID VMD EFI (95.6 KB)


I’ve noticed when I attempt to replace SataDriver on my ASRock Z77 OC Formula with any newer version, I’m unable to access the Intel RAID utility in BIOS. It works fine with the version that’s in the build released by ASRock.

CSM is disabled in my BIOS and it works as expected now. Replacing it makes the option disappear from the “Advanced” menu in BIOS. If I manually replace the newer version with, it shows back up.

It looks like some people ran into this in the past. Did anyone ever figure out a way to get this working?

The newest Intel EFI RaidDriver BIOS module versions do not work with old Intel chipset like yours.
Please give us the information, which specific Intel RST EFI RaidDriver versions you have tested with your Intel 7-Series chipset mainboard and compare it with my recommendations within the start post of this thread.

Sorry I wasn’t clear. I tried versions,,, and from this thread. I also tried that I extracted myself. They all show the same behavior of the RAID setup menu no longer showing up under “Advanced” in the BIOS after enabling RAID on the Intel chipset.

The related Intel RAID Configuration BIOS settings may not appear at first try after the update of the BIOS.
Sometimes it is required to shutdown the PC completely. Then restart it and enter the BIOS again.
If this shouldn’t help, clear the CMOS of the BIOS and retry it thereafter.

Just tried this. Powered the computer off completely for a minute, then back on. RAID settings didn’t show up. Same thing when I powered off, reset CMOS, then reenabled RAID. Tried with and Switching back to loads fine.

I would try the same procedure as Fernando stated, but with the v13.1.0.2126.
Also how does CTRL+I behave for console?

CTRL+I doesn’t seem to do anything during boot even when RAID is working. I think this may only be functional if CSM is enabled.

Behavior from appears to be the same. BIOS recognizes the drives, but the RAID configuration menu just doesn’t show up.

EDIT: Looked into this a little further and it looks like UEFI may be refusing to load modules other than defaults. I noticed the onboard Marvell controller appears to just not work when it is replaced when a newer version.

Intel RAID VMD EFI (100.9 KB)

1 Like

I have a Lenovo M710q that uses a B250 chipset and can only find one QLC SSD when entering the OS, will I be able to find Optane SSD and QLC SSD in the PC after adding this BIOS module?