Just what exactly should I grab for my Z390, using Windows 7?

Yeah, I know. This is about as newbish as a question gets. The thing is I really don’t know what I’m doing, and know that somebody has the quick and easy answer and could provide it in 60 seconds, whereas no further amount of research on my own part is really going to get me any closer to the answer.

I’m using Gigabyte Z390 Aorus Wifi Pro with Windows 7. I got it installed by first injecting the USB3 drivers found here, and then, after it was up and running, installing the AHCI drivers found here (until which time I could not boot off the installation drive). I also installed the LAN driver from Gigabyte’s own support links, which worked without complaint, despite being designated as Windows 10-only.

But that’s all I’ve got, because I don’t know what else I need or what to try using as a community-provided substitute. Right now, the OS works, but a lot of drivers are regarded as missing, and, more importantly, the stability of applications is not what I am used to from Windows 7, and I suspect at least some of the missing drivers are dictating this.

So, if anyone would be willing to just point me to the specific download links for things I ought to install, given my motherboard and OS, that would be greatly appreciated.

@Fredas ,

My suggestion is to put a screenshot of the device manager here for those who can help you.

:slight_smile:



Sure, I can do that. Here it is.

Though what I was more directly getting at was stuff like the “chipset” driver for this motherboard. I know that hasn’t been covered by the LAN, AHCI or USB3 drivers I’ve installed so far. Seems to me if there’s any chance of me fixing the stability of this OS, that would be at least important. I’m pretty sure it’s part of what is provided on Gigabyte’s support site for this motherboard, but the only driver that installed without issue from that page was LAN.

Can you provide the HWIDs for each of the devices in the "Other devices" section?


Here’s that info.



I should mention that I have a total of three PCI devices plugged in, two of which (GPU and soundcard) already have their drivers working, and the third, an optical audio input card, I haven’t bothered with. Not sure if any of these unknown devices are what would hypothetically be covered by the chipset drivers one would normally install for this motherboard, though.

@Fredas

There are no Windows 7 drivers for the Intel Wireless-AC 9560 WLAN-card (VEN_8086&DEV_A370), at least when checking this forum, the official intel site + driverpack solution site (could be able to search and allow downloading the zip file to check the inf files regarding the HWID without using their program).

For Intel devices DEV_A379 (Cannon Lake PCH Thermal Subsystem), DEV_A324 (Cannon Lake PCH SPI Controller) and DEV_A323 (Cannon Lake PCH SMBus Controller) you should use Fernando’s AIO package including Latest “pure” Intel Chipset Device INF files, which can be found here (“II. Latest “pure” Intel Chipset Device *.INF files for all Intel systems from 6-Series up (for manual installation):”). Run devmgmt.msc, open each of the mentioned devices, choose “Update driver software” → “Browse my computer for Driver Software”. Navigate to the root of the extracted package and make sure “Include subfolders are checked”.,

For VEN_144D&DEV_A808 (Samsung NVME SSD Controller SM981/PM981/PM983 according to pci.ids), the best driver would be either ‘Samsung NVMe Driver v3.1.0.1901 WHQL for Win7 x64’ or ‘OFA NVMe driver v1.5.0.0 for Win7 x64 mod+signed by Fernando’, which can be found here. I recommend checking these threads to help you judge which driver will suit best for you.

The Intel device DEV_A360 (Intel Cannon Lake PCH HECI Controller) is related to the Intel Management Engine, so the appropriate driver for it is “Intel MEI Driver v1914.12.0.1256 (Windows 7)”, which can be found here (Section A2. Intel MEI Driver only)

When it comes to ACPI\INT3450 (Intel(R) Serial IO GPIO Host Controller), Fernando’s AIO package doesn’t contain the HWID within the files, so for this device only, you need to use this older version of CannonLake-H inf files instead, ONLY for this mentioned device

Thanks for the great help. Everything you linked took care of the various missing drivers. With the lone exception of the Intel Management Engine one (PCI Simple Communications Controller), in which case Windows claims to be unable to find drivers when I point to the downloaded files. File structure: heci.cat, heci.inf, subfolder x64: TeeDriverx64.sys, subfolder x86: TeeDriver.sys. Any suggestions for this last item? ;p

Try forcing the driver by using the “Have disk” method, you might want to uncheck 'Show compatible devices" just in case.

That seems to have worked. Thanks again.

Now if only doing all of this and updating Windows 7 had resulted in the stability I was expecting. ;p Oh well. There must be something fundamentally incompatible between the OS and my newer hardware. My previous hardware under Windows 7 was absolutely rock-solid, and what I’m getting with this attempt is essentially unusable. So it’s a choice between hideous performance that doesn’t crash (Windows 7) and reasonably smooth performance that is guaranteed to crash within 20 or 30 minutes (Windows 10).


I don’t think there is something ‘fundamentally incompatible with Windows 7’, that is what I call Micro$oft’s propaganda driven by some money-interested people. You can find screenshots of Windows XP rocking on an 9900k, I tried the same on my 9600k test rig, I did get to work but not really stable.
I am currently in the last steps for my Windows 7 Service Pack 2.9-Series with the driver found in this forum for Z390 and those, an it worked with no problem from the beginning. And I don’t slipstream just drivers, i slipstream also some updates, not without a reason I call it SP2-series, because some drivers need particular updates to work well, I suggest that is that what you encountered first.
I am wondering what you mean there with this AHCI driver that you mention, because Windows has AHCI support out-of-the-ox since Vista from 2007.

Greetings from Switzerland.