Lenovo Z50-70. 30 minutes shutdown

i have a laptop lenovo Z50-70. I am having issues with the Intel management engine interface. In the device manager the device status of Intel MEI drivers is ‘This device is not connected to the system code 45’. This issue is causing an excactly 30 minute shut down from the moment the laptop starts. My current MEI driver is
Things i have tried :

i have updated the intel MEI drivers, (it doesnt let me do a roll back)
i have tried to download the drivers manually from lenovo website and install them, but I get error that the platform is not supported
i have tried to run the system with linux (using a cd) but also the system shut down ,the system also shut down in the bios menu
i have tried to update bios but the update failed without harming the system

Lenovo and Intel support couldnt help me as they suggest me just to try update the drivers with various ways that i had already try, or try to reinstall windows, but as the laptop shuts down also in the bios menu i dont think that could work. After hours of searching on the internet I found that this is the only forum that have figured out simillar problems and have helped tons of people.I have I have read about intel me firmware corruption but how i can be sure that this is my problem . Also if this happens how is possible to flash a valid version of Intel Me in my laptop?


The ME firmware is corrupted so that’s why the system shuts down every 30 minutes. You’ll need to repair it, which might not be that easy. To catch up with terminology and what does what, read section A of [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing and Section B,C of Intel Management Engine: Drivers, Firmware & System Tools. Afterwards, download ME System Tools v9.5 from Section C and run MEInfo tool with “-fwsts” parameter to verify that the ME is indeed corrupted. Also, run Flash Programming Tool with parameter “-dumplock” to check whether you have read/write access to the ME region of the SPI/BIOS chip. Do you happen to have a programmer or are you even comfortable with opening the laptop and re-flashing the SPI chip manually?

Ok I runned the tools as you said and i am sending you screenshots of the results . Can you specify what do you mean of having a programmer. I’m sure not comfortable with opening the laptop.



If you don’t know what a programmer is, you don’t have one. As you can see, the ME firmware is corrupted. The Flash Descriptor is locked too. You need to follow [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing and see if something can be done, on the software side, to unlock the FD and allow ME firmware rewrite/repair. However, at option E4, you might be able to use this tool (first sentence), since your system is Lenovo. I say “might” because it’s not for your system technically. So there is a bit of risk. But it’s not like you can use the laptop at its current state so it might be worth a try either way. You’ll now it worked if you can dump the laptops’ SPI/BIOS chip via Flash Image Tool command “fptw -d spi.bin” without encountering CPU access errors.


Thank you for all your guides and input! It helped me fix the 30 minute shutdown problem on my thinkpad E130.


can you help me i think i have same problem on dell optilex 990
every 30 minute my computer powering off its no overheating its mother board %100
please help me

Hello @nik_gr

I have the same laptop model with the same problem (shuts down 30 minutes).

Did you fix it? If so, could you guide me how.

Thanks a lot.
Greetings from Chile.