Little help with update H61 chipset to ME 8 version for Ivy bridge support

I woul like to ask you for little help. I just ordered I7-3770s meaning to upgrade Lenovo AIO B320 machine which running I5-2500s, just for better graphics because it hasnot slot for external GPU.
Than I find bios upgrade is needed - so I was searching to yours nice forum.
After many reading and learning here, I managed transfer settings and update two VBios modules to 2171 via MMTool and microcodes for current Sandy CPU via UBU tool.
Than I found ME update is also needed and update to latest 7 version according your guide. I am also learned that ME 8 needs to be flash under condition of unlocked descriptor, which is happily unlocked in my case.
But from some threads here is clear that even ME 8 update cannot guarantee success.
So I would atleast give it to try :slight_smile: But to go further I dont want to make stupid mistake - so can I ask you to advise me with transfer settings from me.bin dump to
Also do I have possibly flash only ME region, becose according analyzer ME is not included in BIOS file (2 mb)?
I mean, do I need to buy programer?
I just dared to upload my stock bios here man and I really appreciate any advice Thanks a lot! and sorry for bad english…

DXKT25AUS.doc (2 MB)

You should buy a programmer because it is very likely that a brick will occur if something doesn’t work out as expected. Read [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing to learn what regions are included in the SPI chip and why providing the BIOS region only is useless for ME. For the latter, the upgrade should work on desktop Cougar Point chipsets only. But it may not work if the BIOS source code is old, before IvyBridge. For the ME firmware, you must transfer the settings manually by having two FITC instances open (v7 and v8). You’ll find more info at other threads such as this and this.

Hello @plutomaniac ,
Thanks for your kindness. The programmer arrived yet and I learned how to use it, because I got boot loop after some editing and bad flash, so now I recovered it and pc is ready to continue.
Maybe I am lucky, by searching web I accidently found bios file (2,86 Mb) with 3 gen support for my B 320 model, so it probably has BIOS source code, but since it is not full spi image, ME 8 is not included probably.
Now I am stuck and dont know how to continue because bios file is ISO and boot device menu is somehow broken, so I cant boot from DVD.
Have you please any advice how transfer this iso file to bin file?
Or do you actually think I must upgrade to ME 8 via FITC at first and then put all spi together?
Thanks for your replay!

Please attach the current/stock/original full SPI image dump taken with the programmer. The official SNB and IVB BIOS (not full SPI) links can be found here:


Also, there seems to exist some (custom ?) Ivy Bridge EOKT13A BIOS with ME8 over here, alas, behind a paywall.

Hello man,
very thanks for your replay, really apreciated it!
I just attached SPI dump from FPT 7 version fptw64 -d spi.bin- if you dont mind.
The reason is, I am not sure if I can make dump with programmer becose when I was recovering machine, I actually had to desolder that chip.
I was trying build ME 8 by opening two instances FITC 7 and 8 on my own.
I put current SPI at 7 instance and at 8 instance. Further I couldnot loaded Bios.bin there, so I made changes and built outimage.bin, which has 4 Mb, but than could not continue becose I am not famillier with UEFITool (couldnot find exe into it).
I am just bit afraid if 3 gen bios eokt07a was actually ment only as update for B320 machine which came with 3 gen. But who knows? Also thanks you much for you effort regarding chines page. Maybe if I wont be lucky I give them pay? :slight_smile:
Your pages are very inspirate, good work!

spi.doc (4 MB)

outimage.doc (4 MB)

You need to adjust every single setting at FITC, including Flash Descriptor. The easiest way it to open FITC v7, load the original SPI image and keep the window open. Open FITC v8, first adjust the SKU at the top, then input the BIOS Region, GbE Region, OEM, PDR etc from the FITC v7 decomp folder, input the ME v8 RGN firmware at the ME region and afterwards manually adjust every single FITC v8 setting found at the tool to match the values from FITC v7. In your case, instead of inputting the BIOS Region from the FITC v7 decomp folder, point it to the Ivy Bridge BIOS image from Lenovo (EOKT07A.ROM) to kill two birds with one stone. No need to use UEFITool afterwards, just build with FITC v8.

I followed the above procedure and created an Ivy Bridge compatible (ME 8 + IVB BIOS) SPI image for B320. Flash it wit FPT v8 via “fptw -f spi_ivb.bin” followed by “fptw -greset”. Theoretically, this should work. Obviously, if it doesn’t, you’ll need to use the programmer to recover, no way around that.

spi_ivb.rar (2.33 MB)

Thanks again very much for your work and time you spend with me!
I just flashed your SPI and greset command under Sandy and everything seems to be fine, even though it hasnt microcode for Sandy into it lol :slight_smile:
Bios menu shows ME 8, which never shows nothing before, Model - Invalid, UUID - FFFFFFFF-FF, Serial number - Invalid, but - ME 8 info shows no error, Memanuf test passed.
UFF… so for me you are Genius now and I certainly will buy you a bee man.
Fingers cross I ll go changed cpu to 3 gen and let you know how was it.
Big thanks :slight_smile:

Nice, good to hear that ME 8 shows at BIOS and it passes MEInfo and MEManuf checks. Let’s try with an IVB CPU now and cross our fingers. :slight_smile:

It does have one, CPUID 206A7. The rest are for IVB.

These are to be expected because we used the stock/non-provisioned BIOS region. If everything works with an IVB CPU, LOST_N_BIOS might be able to migrate this info but it’s not important right now.

You are genius as I said before. Everything works fine. That invalid model and uuid really doesnot matter…I just didnt expect anybody could help me for free and I am very pleased by your help. Moreover I learned many from this site.
Now it looks like I am at minority here with 3 gen working on H61 - which came with Pentium G 630 to me haha
About microcode - I was under impression if the tab into UBU showing red NO, it isnt presented at all, instead it just isnt latest but presented in Bios?
I used had about 25 fps in WOT under sandy and now I have about 100 fps on minimal resolution and details, HUH
Good luck man, I was enjoying your help so I will send you message and send you few bucks to bye beer !

I’m glad this community could be of help, enjoy your working IVB system. About UBU/MCExtractor, it is loaded by the BIOS but it’s just not the latest version.

Amazing, great work here plutomaniac

Is there any way to know when this is possible as easily as you did (ME Major version upd) or only by that manual ME UPD/Swap and user initial test before anything else done?
I’d have been scared to test, without programmer in hand and backup made

It worked because there was an official BIOS from Lenovo with IVB support. Thus we had upgraded BIOS source code. It is a BIOS region only though so we were missing the ME region. From a full SPI dump we can upgrade the ME from v7 to v8 by following the instructions above.

Ahh yes, IVY ready BIOS region helped here, I missed you guys discussed that!

Hello @Lost_N_BIOS , the cpu upgrade is just fine and thanks for your assistance here and I’d like to respectfully ask you for another help if I can.
I have carefully read your thread here:
[SOLVED] How to unlock MSR 0x194 for 2nd/3rd Gen CPU overclocking which won’t let me sleep.
I found the current cpu can be boost +400 Mhz on Turbo bins, so I followed your thread and I tried make some changes accordingly.
I extracted startup via UEFITool than boot in GRUB and tried changed some variables like long duration maintained and GT frequency - which worked.
Then I rewrote Core ratio limits in HEX for core 1 to 0x2B (43), core 2 to 0x2A (42) etc., but it didn’t make any changes at all.
So I made few readings of yours guides about to unlock hidden menu and - Boolean strings seems to work, so I managed unlock advanced - but all writing to core ratio limits in Bios setup didn’t applied anything, so now I’m sticking here. Btw thanks for all yours guides.
All four limits are set to 0 by factory, so probably bit 1 at MSR 194 is responsible for.
MSR 0x194 shows 0x00190000 of EAX where bit 9 should allow +400 Mhz but on the other hand bit 1 is reason I can’t rise the multi, at least on TS forum is it such explained.
I also downloaded IDA assembler and look for 194h into, but it seems require skills, which are behind me completely :slight_smile: Even when I possibly found 194h, cant able to continue anyway.
Could I ask you for bit assistance here? Thanks for your replay !
P.S. should I rename this thread?

@DaCou - great you’ve learned a lot and been able to follow along in stuff you’ve found that I wrote!

Sorry, I can’t help more here, unless you are more specific in what you need. This is not a mod I do often, that you linked, and I’ve never personally use this method for unlocking bins etc., so I don’t know about any of this other than what I’ve been linked to in threads.
I think you need help changing “Core ratio limits”, correct? If yes, upload your BIOS for me and I will look and see what’s going on, as of right now I don’t even have a copy of your final mod BIOS from above, so I can’t even look at the what the stock values are for this
Do you have turbo enabled in the BIOS setting? If not, that would be why your set values in BIOS wouldn’t work, or it could be you need to undue your previous hex or grub edit and reset those back to stock values, then try changing them in visible BIOS setting.

I know nothing about the MSR stuff, you’ll have to research that stuff in forums where they discuss this.
However, if you find something you think needs changed in assembly, I can do that, but I need to have specifics to find what you want changed
Reading a few pages of that thread you linked, it looks like I know how to unlock MSR 0x194 if you need still?

Hi @Lost_N_BIOS , thank for your response and yes I need help changing "Core ratio limits"
regarding your question, yes I have Turbo enabled at bios setting, same for Speed step. The Cpu default is 31 with turbo for core1 - 39, core2 -38, core3 - 36 and core4 - 35, which could be rise + 4 on all cores for this model cpu.
Basically I tried rise it at AMIBCP and flash with no result, than in Grub with no result, than I unlocked advanced settings and all became visible except "Core ratio limits" and was quite sad. Than I got idea and undoing previous grub edit works, so now "Core ratio limits" are visible, but with no effect with writing into.
I uploaded two fails, first is original spi made from Plutomaniac including original bios from Lenovo and second is Bios file with unlocked advanced via 0101010101010000 to 0101010101010101 changes.
Yes am very glad you refresh your mind by reading your thread, that unlock MSR 0x194 is exactly what I need.
Thanks for your effort sir!

spi_ivb.rar.rar (2.33 MB)

bios_unlocked_advanced.rar (1.39 MB)

This is an outstanding achievement!
This should easily work for the Lenovo D30 Workstation as well. The D30 has 2 bios branches for the same motherboard, one for the SandyBridge CPUs (they call them: MT 4223, 4228, 4229) using bios: A1JxxxUSA; and one for the IvyBridge CPUs ( they call them: MT 4353, 4354) using bios: A3JxxxUSA.
So following the same principles, we can line-by-line copy the ME7 parameters to the stock/virgin ME8, build it all up and flash the SPI with the IVB-capable bios.

I’m getting my 16 pin SOIC clip soon. @plutomaniac , I hope you don’t mind but I will be sending you the SPI dump and the IVB-ready Lenovo BIOS at some point, I will creat a new thread for the Lenovo D30. This would be unbelievable if it works!!

@DaCou - sorry, still unclear, do you need MSR 0x194 unlocked, or not? If you didn’t do that already, then that is why your raising of turbo’s above stock isn’t working, that’s a required edit before you do that.
Your BIOS files attached are also confusing, I only need the current BIOS you are using. Dump it with FPT, unless you have a flash programmer, if you do then dump it with programmer now.

Hello @ Lost_N_BIOS, I’m sorry if I’m not very clear, English is not my native language.
I understand your point that without unlocking the MSR 0x194 I will not be able to raise the multiplier above the basic level and yes I need that MSR 0x194 unlock.
I uploaded file which is my current bios dumped with FPT.
I also have a programmer in case something goes wrong and I can handle it.
Thanks very much for your kindness sir.

bios_unlocked_advanced.rar.rar (1.39 MB)

@DaCou - It’s Ok I only wanted to be sure what you needed before possibly wasting time doing a mod that wasn’t needed.
Here is mod BIOS with MSR 0x194 unlock, same exact edit on this one as the BIOS in thread you linked previously, so image at post #17 is exact method used to unlock…528015096832436