Marvell 88SE9123 Firmware ASUS PCIE GEN2 SATA6G

Last year I tried to update the firmware on my ASUS PCIE GEN2 SATA6G…N82E16813131610 its basically a U3S6 without the USB 3.0 ports. Now the bios version is not visible when the computer starts up but it shows in the device manager (Windows 7 x64, XP x64, and XP SP3) but that’s all. Last year I tried the Asus form and they said to contact Marvell directly and I got no reply back. There is no info on the Marvell site about the firmware version. The manual says that it has a Marvell 88SE9123 chip on it. Would anyone have firmware that would work with this card and explain to me to me exactly how to install it? I have updated the firmware and bios on several computers a but I can’t figure it out this Marvell firmware. Yesterday, I almost threw it away but I have a older backup machine that I can use in if I can get it working.



Hello Dave,
welcome at Wn-RAID Forum!

Unfortunately I cannot help you myself, but I am pretty sure, that someone else will give you the requested support.


Hi, please look here and here. Maybe you find something helpful…

Regards hanson

Thanks for the reply Hansen,

That was the post that I ran across and decided to join the form. What should I do download the zip files in the post and try to flash them and see if one works? Not sure exactly how to make the firmware bootable. All the BIOS and firmware that I have updated could be done in Windows or with a bootable CD of floppy image. Dos always seems to give me trouble.


Where in your profile do you enter system info at?

Hi, my systeminfo I entered in the signature section of my profile. So for your problem: there is a downloadable image for the 9123 controller somewhere in this thread. You should download the firmware and try to flash it by making abootable usb stick with just the flashing files on it. There are also good instructions written how to do it exactly. I had some trouble as well with my U3S6 card (the Marvell software flasher did not recognize it). Do you have the same trouble or is it just about finding a good firmware?

Hi, I am one user that went ahead to flash the onboard Marvell controller firmware. I managed to f**k completely the controller. I still have not fixed it, and am waiting for the eeprom programmer.

From what I have read, there are two different locations where the controller firmware resides, in the actual motherboard BIOS or in a separate chip.
If it is on the BIOS, it may be easy to upgrade and to troubleshoot.

In my case, it was in a separate chip soldered on the board.
After all I have gone through, I shall suggest that if it is working, do not attempt anything on it unless you have the skills and equipment to desolder, reflash and solder again the eeprom chip on your controller.
Apparently the OROM in these controllers is somehow different from the stand alone boards, so even after a correct flash, you may not be able to boot, the IDE channels may not work, or other sort of problems.

But, having said that, if you still want to go on, we will help you to achieve your goal.
Just make sure you make a backup of your original OROM before starting to mess with it.

We are here to help.


I think in his case it is a separate pci express card like my ASUS U3S6. They have an own chip on board

You are right, my mistake of not checking the link provided. In this case, it looks like it can be flashed with the Marvell tool mvf_mag.exe.
The eeprom chip seems to be a SOIC 8 as in my mobo (from NEWegg pictures, top center), so similar recovery procedures as in my post may be used (Problem after flashing firmware to Marvell 9123 addon SATA3 controller (4)).
Also, Lordkag has done an excellent work on building test images.

Hanson, did you ever get your U3S6 working again? I just made a bootable USB flash drive with HP USB Disk Storage Format Tool and it works. The instructions seem kind of vauge. Do I extract the firmware files on the USB and try them one by one using the list of commands in the read me file? I really suck at this Dos stuff!


I managed my card by using a programmer finally but that was because the mvf_mag tool did not see it even when the controller worked fine. You should just put the Bin folder and the go.bat on the stick and then type "go". I attached a firmware for you that was meant for 9123 I think (483 KB)

As far as I can tell the ASUS Model PCIE GEN2 SATA6G and Asus U3S6 are the same except for the USB 3.0 controller. Information on these models is hard to find for some reason.


Yes maybe, the pictures look similar. But mine has a 9120 chip for sure. When using the mvf_mag that comes with the marvell firmware, do you get an error?


You should avoid the image Hanson has attached. It has a different and dangerous autoload. I could pretend to be upset that he has already forgotten that the autoload is critical and that it differs for external and onboard controllers, but he might not read it with a sense of humor. Rather than that, let’s go with the baby steps.

What is the exact controller that your card uses, the exact numbers from the chip, like in this image?

What do you get when using “go -r” from a bootable USB with the firmware content placed on the root of it? I need this backup image to be sure of some things.

How do you feel about a broken card? If you have one shot and the image is wrong, you can only use a programmer to restore the card to a working condition.

I have attached some test images. You should first try with typing “go -r” from a DOS prompt provided by a bootable USB, after having dropped the content of the archive at the root of this USB.
- New-smaller.rar uses the new format for images with a proper structure.
- Old-bigger.rar uses the original format found for U3S6R0.

Note: this is done assuming you have a Marvell 9123 controller and assuming you have the same image as U3S6R0. I strongly suggest that you first post the backup image you get when running “go -r”.

New-smaller.rar (206 KB)

Old-bigger.rar (205 KB)

You’re right - my fault. :frowning:

Hanson tried the first firmware and nothing happened. Then I tried "" and I think it worked! The BIOS version shows and hard drives visible when the system boots up, drives are visible and accessible in Windows. What keys do you use to access the Raid menu? My TV monitor has a dialog box that blocks out most of the Marvell BIOS information when the computer starts.


dear Lordkag, is the image9.bin used for flashing with a programmer? and what version is old-bigger.rar? thank you and i appreciate it.

Hi, congtatulations to your success. AFAIK the key for RAID menu is CTRL+M but I’m not sure if your card does support the RAID feature. Mine does not, just “pass through AHCI”…

Hi, when you took it from the thread regarding the Marvell 9120 controller it is an image to be flashed with a programmer.

Best regards

About a year ago I took my last CRT monitor to Goodwill. Its been so long since this card has worked I can’t remember what the boot options are anymore if it has any. Not much of a manual came with it just a couple of pages. My x58 has a built in Marvell controller on it that is also uses CTRL+M. The system starts so fast that it takes a few tries to get into the BIOS. Right now I don’t have any empty Sata drives to try to install a OS on but everything seems to work again. The only down side was somehow I screwed up my XP x64 in my spare machine and I need to redo it now. Thanks Hanson and everyone who also posted on this problem.



It is useful to provide the original name of the file you downloaded, not the one offered by the server. However, I was able to locate that file and it seems you downloaded the oldest firmware for U3S6R0, from 2009, which Hanson reported to give BSOD.
If you are happy with the current situation and the image works great, there is no need to read further. But if you have problems or want the latest firmware, you should look at the message I posted yesterday. One BIG warning: if the image is wrong, you won’t be able to use the card again until using a programmer to reflash the chip.


If you are going to use any image, it is better to give us more details about your card/controller. Every image is tailored for a specific combination and even so, it could still fail.