ME gone after bios update - ME FW version - could not fix it by sw so I decided to do some soldering

After a bios flash ME is no longer available on my HP Z420, I have tried to reflash bios both in dos and windows but had no success - bios now lists ME FW version as and there is no options in bios for ME/AMT.

Computer starts up and works as it should but I have 3 devices that can not start in device manager, adding drivers does not help either - this mb has a Bios ME/AMT Flash Override jumper but flashing bios with this setting makes no difference.
I’m able to save my current bios using with override jumper activated: - fptw -d spi.bin
Using dos tools I get an error 8193 ‘Cannot locate ME device driver’ , in widows I get error 1002,9458 and 9459 - see pictures.

Right now I’m at bios 3.88 - it should have ME - link to sp71579.exe

Is it possible to extract ME from bios update file and flash only ME region ?

ME windows.JPG

ME dos.jpg


Use UEFITool to “extract as is” the ME region from the HP SPI image (Rom.bin). Set the service jumper and run “fptw -rewrite -me -f me.rgn”, where “me.rgn” is the extracted ME region, followed by “fptw -greset”. Set the jumper back to its default position and the Engine firmware should be healthy once again.

Not sure if you use AMT, but if not, try disabling it in the bios, some of those ‘missing’ devices should be gone.

Extracted and - tried first with V7 but it did not come back up even if region was erased,programmed, verified and reset bit set.
Same with V8, Me did not come back.

There is no option in bios any more, there used to be but after bios flash they are gone.


I did another dump using fptw -d and it shows ME successfully installed but bios still shows


Only try ME8, just like the BIOS includes, nothing else. Now, since restoring the stock region does not help, this is clearly a BIOS and/or ME provisioning issue which requires running a few HP manufacturing tools. Otherwise, the BIOS automatically troughs the ME in Recovery Mode as a warning that provisioning has not been done. You’re probably getting some messages at boot such as “Not in Committed State” or similar. Stupid/annoying HP weirdness. We’ve dealt with such issues in the past as well but it’s not that easy and you have a lot of reading to do at the first and second thread. The first thread was our first unsuccessful attempt but the second time we managed it.

That’s the weird thing, I have no post error about warning or provisioning error and computer does not power off after 30 minutes either.
Only problem I have is 3 devices in device manager with yellow exclamation mark.

I will try the Hp dmi tools.

I had no luck with the dmi tools floating on the net, either they did not work at all or my hw was not supported. Most of the utils error msg was ’ Your notebook is not supported by this utility’ so clearly they are only for laptops and not workstations.

So I tried some soldering instead.


Bios chip is quite close to the sata ports.


Wetted properly.


…and removed chip and cleaned pads


I reprogrammed it with an unmodified bios file from HP.



I kind of new I would have a few problems so I decided not to resolder the chip back on but instead use the pliers trick - it works beautifully as the pliers press point fits and holds the chip in place.




Machine starts up and AMT option is back in bios, sadly mac lan address was FFFFFFFFFFFF but using Intel’s Eeupdate /nic number /mac=123456789123 in dos fixed it back to what I earlier had.
Intel’s hw test passes in windows so seems to be ok.


Ctrl+A opens additonal fields in Security>System IDs menu so I successfully added the proper asset tag, UUID, chassis sn, build ID and featurebytes.
Remember that the build ID has a few ** on your chassis label so take picture of bios system IDs menu before you reflash and start experimenting.


The new problem now is ‘Management platform (ME) in manufacturing mode’ and I can’t seem to fix it.

Any ideas or clues ?

Ahh plutomaniac posted som nice information about ME manufacturing mode - link

I ran ‘fptw -closemnf’ in windows and computer restarted and ‘Management platform (ME) in manufacturing mode’ was gone.
I don’t know if it’s needed but I used -greset after reebot.


Before I solder back the chip does anyone know if this looks correct ? Not provisioned and Pre provisioning I not sure about.

Very nice, you found a different solution and detailed it as well. You can use MEInfo tool to see more robust AMT state info instead of Windows System Info. You should also be able to control AMT provisioning via MEBx while the system boots. Generally, if you don’t use AMT, it should stay unprovisioned.

Here is the MEInfo tool readout, system UUID and mac address I painted out but are listed correctly.


What I don’t like is OEM Id and OEM Tag’s showing just zeroes and Slot1,2,3 listed as unused. Is that normal ?



Now AMT is listed in Aida too,added pictures.

You’ll see even more info at MEInfo if you add -verbose command. These Slot info are probably taken from the DMI so they are completely useless. Either way though, the firmware is now healthy so you can commit to the current SPI state. If you want you can configure AMT via the MEBx, it might be possible to completely disable it there as well.

MEInfotool verbose 1.JPG

MEInfotool verbose 2.JPG

MEInfotool verbose 3.jpg

MEInfotool verbose 4.JPG

MEInfo -verbose lists ‘No error’ under ErrorCode, AMT option is back in bios and I have no yellow exclamation mark in device manager so I think I’m happy, I’ll just resolder the chip and call it a success.

Thanks for your help and tips.

Wait, I saw something. Can you run “fptw -greset” command and check if after the restart you can now see “Valid OEM data, ICC programmed” next to ICC? That shouldn’t say “No valid OEM data, ICC not programmed”.

I will check, give me an hour or so.

What is ICC ?

Did not change anything, still has no vaild oem data.

I will try an ME fw update - HP has released an update from ME 8/9 to - Link

There is no fw update just new drivers as I can see.

Tried -greset both with and without override jumper activated, did not work.

Anyone have a valid bios dump for HP Z420 ?

ICC is Integrated Clock Controller, an important regulator for system clocks. There is no upgrade path from ME8 to ME9-10, only to the latest ME8 firmware, as provided at the (CS)ME thread. Since HP provides a full SPI image for your workstation, what you need to do is to make sure that you have the latest HP BIOS v3.92 applied.

Given that, I think I know what’s going on now and if I’m right, it should affect all Z420 users. HP messed up while updating the ME firmware at the newer SPI/BIOS updates. Normally, to update it they need to do everything from scratch which takes a lot of time so what the community does (and probably OEMs as well) is to follow the Engine CleanUp Guide to clean and update the firmware at the same time. However, from experience we (the community) know that Flash Image Tool v8.1.40.1456 or earlier versions are bugged when it comes to Patsburg (C600) SPI images and the ME settings are not detected when following the CleanUp Guide (Step 5 > 2nd bullet). So I think that HP did the same procedure as depicted in that guide but was not aware that their (probably outdated) Flash Image Tool was bugged on the Z420’s Patsburg platform and did not do the workaround.

Flash the attached (hopefully) fixed SPI image with the programmer, hold it with the clip (nice idea btw ), do “fptw -closemnf” and then “fptw -greset”. Afterwards, check if ICC has valid OEM data.

J61_0392_ME.rar (5.76 MB)

Still has ‘No valid OEM data, ICC not programmed’ after the new flash.

What I did notice is that when running “fptw -greset” the command prints in yellow ‘Could not set the GlobalReset bit’ but finishes of with ‘FPT Operation Passed’ in green writing.

Try a manual greset by removing all power (AC, RTC not needed) for 1 minute and press the power button 2-3 times while you wait.

Didn’t change anything.

I’ve been looking at setting up ICC profiles in the bring up guides and it looks too complicated so I think I’m going to try an old bios like 1.14 and see if that changes anything, if not I need a Z420 or Z620 bios dump.

Ah if you have kept such older BIOS then great. At the HP site I couldn’t find anything old enough (same wrongfully upgraded ME firmware). Finding another dump won’t help because we might not be able to clean it due to the FIT 8.1.40 bug with C600 SKUs. And yes, there is no point in trying to mess with ICC as it’s very complicated.