ME N/A at Z97 ASUS Maximus Hero VII

Hi Sorry to revive a old thread. I recently purchased a secondhand motherboard Z97 asus maximus hero vii and can not install the ime drivers.In bios there is no me version just N/A. can i update the me via this method ?
CPU is a 4770k if any other info is needed please ask. Could you please link to the tool download etc as i have never had to do this or a video ,instructions on doing it.
Thank you for any help


Check if you have read/write access to the SPI/BIOS chip by reading [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing.

ME firmware N/A is a clear sign of a corrupted bios. The only way is to try to unlock flash descriptors following @plutomaniac tips and try to reprogram eeprom.

The best thing should be the use of an external eeprom programmer (CH341A for example).

So do this to check ?
Intel’s Flash Programming Tool from the Engine CS(ME)/CS(TXE) System Tool packages by running the command "fpt -d spi.bin". If it completes successfully, by dumping the entire contents of the SPI chip, your FD is unlocked. However, if you encounter any CPU/BIOS Access or similar errors, your FD is locked for system security purposes, as per Intel recommendation
Which download is it ?
Sorry for the noob questions never played with ime or these utilities
Also what info is it dumping ?

Extract the attachment and run Flash Programming Tool with command “fptw -rewrite -me -f MAXIMUS-VII-HERO-ASUS-3503_me.bin” followed by “fptw -greset”. After the reboot, check if your ME firmware is healthy again.

MAXIMUS-VII-HERO-ASUS-3503_me.rar (1.01 MB)

nothing in your link

You need to download the attachment above, it is clearly there.

ok thanks worked 3rd time round ,downloaded so thats the bin file Can you please link to the flash tool ?

so tried v9.1 and 10 it opens the flash tool but as i go to type the command it closes , why is that ?

Section C, then C2 - Intel Management Engine: Drivers, Firmware & System Tools
Download version 9.1 Intel system tools, then fptw will be in Intel Flash Programming tool folder in win or win32

Put BIOS file inside that same folder with fptw.exe.

Hold shift, then right click the win or win32 folder, then choose “Open command window here” Then run commands

both win32 and win64 fptw crash once open
do i need to put the file in the tool folder before opening ?

First, yes put BIOS file into the win32 folder. Then see my edit above about how to use/open a command prompt at that location. The command prompt window will stay open that way

ok so entered both commands in powershell window from win32 folder . should it manually restart or do i force a restart ?

I am unsure if that works in powershell, no one mentioned using that? You’ll have to wait for someone else to reply, from command prompt that greset would have rebooted you I think, so it may not have worked properly yet?

Unless you meant command prompt (black box), not powershell (blue box). If yes at black box and it didn’t auto reboot, then go ahead and reboot.
If you ran it from powershell in blue box I do not know, you will have to wait for others to reply, or reboot and see if changes happened or not, if not do again in command prompt as mentioned.

There is no option for command window only powershell with shift key held down

You have to use the Command Prompt (as administrator) in order to properly use FPTW64 (or FPT if you’re using a 32 bit system).

Reboot and see if it took effect or not, if not then you need to do again in command prompt, as mentioned
Is that some win10 crap, no open command prompt here with Shift+Right click? -
Nope, I fired up win10, and I get "Open command prompt here" when holding shift and right clicking a folder -


im on win10 64bit system ill try restarting but dont think it worked

no good so for the above system should i be in win 32 or 64 ?
i also figured out how to get cmd up click on folder so your in it then in the top bar type cmd and it opens ,silly win10

System 32/64 does not matter, FPT tool version 32/64 does not matter, although I do suggest not matter what system you are in to use the win32 version fptw