ME version broke the HDCP 2.2

Hi, can someone please help me with the BIOS modding of the Asrock fatalyz1 z220 gaming itx/ac board? When I updated the BIOS to 2.50 it broke the HDCP 2.2 and now I can’t watch a 4k bluray movie. I need to know how to fix it. I really need step by step what to do cause I’ve never done BIOS modding. Thanks alot.

Did you modify the BIOS you flashed? If not, flash back to the previous version that worked OK

Hi, I upgraded to 2.50 and it broke the HDCP 2.2 and so I downgraded to 2.30 but it’s still broken. It keeps the same version of ME. I need to change ME versions to fix it. How do I do it?

Which BIOS were you using before, was it 2.30? I will check this for you. I assume you meant Fatal1ty Z270 Gaming ITX/AC correct?…ITXac/index.asp

yes to both. thanks so much.

You cannot backflash ME using the firmware update tool or normal BIOS flashing due to lower SVN/VCN, but you might be able to fix with FPT. In order to see if you can use FPT, we need to check to see if your FD is unlocked and if you can write to ME or not
Please download Intel CSME System Tools v11 r14 package from this thread - Intel Management Engine: Drivers, Firmware & System Tools

From within that package please run the one or three commands shown in this thread, from section “D” from command prompt and upload them as a zip or rar file to any file host and put link here
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

Use the FPT inside Flash Programming Tool >> WIN (Hold shift, and right click on this WIN folder, then choose open command prompt here, then do as below)

Those commands are as follows - first run fptw -d spi.bin". If it completes successfully, by dumping the entire contents of the SPI chip, your FD is unlocked and you can stop here. However, if you encounter any CPU/BIOS Access or similar errors, your FD is locked for system security purposes, as per Intel recommendations.

Note: If you encounter any BIOS related errors while trying to dump the system’s SPI chip, relating to Protected Range Registers or similar, then your FD might still be unlocked but certain OEM/ODM BIOS protections do not allow you to dump that specific region, which is protected on its own and not FD-related.
In such cases, try to dump the individual SPI regions that you want to update/service/re-flash only and look for any access errors there. For example “fptw -me -d me.bin” for Engine region, “fptw -desc -d desc.bin” for FD etc.

Did I get all that correct above @plutomaniac thanks Trying to absorb

OR First, before the above, try this BIOS. Flash this 2.30 BIOS via instant flash from within the BIOS

I am unsure if this modification allows ME flash backwards due to the above restrictions or not, we shall see and it will help me learn if this is option in these instances or not.
If asked, or is an option, choose full flash/full update etc.

sorry, where is section D?

Section D is in the thread I linked right under that sentence.

Did you try the BIOS I posted? Please do, it may fix it all for you right now.

k, it asks for a credit card in order to download, I was trying to find it somewhere else, but haven’t yet. I will go ahead with the card entering if you think it will be okay?

nevermind, I got it downloaded. fixing to try it. pray it works please.

sorry, just ran it and no change to the HDCP 2.2.

Credit card? Sounds like you need an adblocker installed, sorry for that. No need to credit card anything! If you need me to upload to another host let me know.

Did it change your ME version or not? Check in BIOS where it shows ME, or with meinfowin from the above mentioned Intel Tools package.

Intel Management Engine: Drivers, Firmware & System Tools (273)

I had already enabled ME-Reflash in the above BIOS, that’s why I wanted to verify if it actually flashed back the older version ME or not @Duggyhow
Now thanks to @plutomaniac for linking us to read all that, it confirms that method of BIOS mod allows this type of flash backwards

So, even though you can flash back now to the older ME version, with the above linked BIOS in post #6, you are going to need to contact Asrock and link them to the above discussion, pointing them to discussion between user crown_nick and plutomaniac from 30th November 2017 up until 5th December 2017 (Page 235-241)
Or try to re-explain all this to them in your own way, and still pointing them to the fixed BIOS given by their team in page 239 @ post 3595 on Dec 5th

This is something only Asrock can fix. You can address ME changes as covered above, but that will not correct the HDCP issue.

Hi, Lost in BIos. so sorry, I went to sleep. I will work on this some more now. Thanks.

oic, would it be something I would have to send the motherboard to them to fix?

I have sent them to the thread yesterday morning but they never got back with me as of yet. I will see if they do today. Would I need an updated motherboard to keep this from happening again?

I explained to you at the (CS)ME thread that this is a BIOS firmware issue. A new BIOS will fix it. Contact the OEM and ask for support by explaining your issue. There is no need to link them here, they should know what to do.

k, as of yet, their haven’t got back with me. We will see. If they don’t get back with me, would a replacement BIOS chip for my motherboard fix the problem? When they wrote me last week they ignored the HDCP 2.2 issue and was telling me to update all drivers. Well, I had already done all that. SGX is also saying it’s unavailable and it did that before that before the BIOS update. I suspect it is Windows 10 update that messed up SGX. I have it enabled in the BIOS.

That’s why I mentioned to link this thread, and mention exact issue already solved by their team for another customer, because often either they ignore some/all of your request info (As you mentioned), or don’t think you don’t really need what you’re asking for.
You have to be brief, explain issue, tell them already solved for customer on another model, and you need same specific fix for your model motherboard.

Only they can fix this, and the fix is only with a new BIOS from them. And no, you don’t have to send in the motherboard, only keep pestering them until they send you a fixed BIOS
Keep on them, how I mentioned above, and eventually one of their team will help. It may also help if they have a dedicated forum that has actual staff helping, not just end-user to end-user in the forum, they may help there too.
Facebook or Twitter post may help speed things up too.

You would only need this fix again if you mod the BIOS. You wouldn’t need to ask them for a fix again, only to reflash the BIOS they eventually send you from this request.