[Modding] VAIO AMI BIOS Features Unlocking and Updating

Hi guys,

I had an old SONY VAIO PCG-61412M Series Laptop and it has AMI Aptio IV BIOS,
From last few weeks I was trying to unlock the Advanced(BIOS has two Advanced Tabs and only the Second Advanced tab is Hidden) and Chipset tabs of my Bios to get access to SATA and Temperature Related Menus.

And After browsing various threads for several weeks I tried ‘AMIBCP’ method to set access from ‘Default’ to ‘USER’ of the hidden menus and also Search for HEX “01010000010101” according to my Menus Order(Attached File) but I did not find the HEX in the Setup Module, instead I found “01010101010101” so it seem like all were enabled from start.
The only thing I was able to accomplish by using AMIBCP was to unlock some features in the first Advanced Tab and Boot Tab but they are not of much importance as compared to options available in Advanced(Second Tab) and Chipset Tab.

Untouched BIOS ROM and its Menu Pictures - https://www.mediafire.com/folder/c17bj6x183hue/ (Update.zip contain ROM Extracted from Latest Update Available)
also Stock BIOS Download page - https://www.sony.co.uk/electronics/suppo…nloads/Z0000750

INFO: I have a SPI Programmer, so there is no risk of bricking anything

Thanks! in advance…
Happy Modding…

Objectives :
1> Unlock Advanced Tab - Researching
2> Unlock Chipset Tab - Researching
3> Microcode Update - Done
4> Update to latest ME Firmware - Done
6> Thermal issues - Fixed
7> Still thinking

setup IFR - Stock BIOS.txt (321 KB)

@nonid - Is this stock unedited dump? If not, please upload a dump you have not modified at all yet. And, how did you create this dump, what program?

Also, what is the exact full model name, and please link to stock BIOS download page if you can, thanks

Also, please zip some images of your BIOS, one showing all visible tabs/sections, and then one each at root (main entry) of each section Main, Advanced, Boot, Security, Save and Exit

Please also download this package, run 32 and 64 bit command from each version folder, if any NVRAM.txt created, leave in place so we know which versions work, and then zip up and upload for me to look at
http://s000.tinyupload.com/index.php?fil…550522360949555


@Lost_N_BIOS I had updated the Main Post for Stock BIOS ROMs & Pictures (https://www.mediafire.com/folder/c17bj6x183hue/) and I had also attached the file as requested after running all commands as @Lost_N_BIOS said, also take a look at the Output.txt and Screenshot.png in the Zip File…

SCEWIN-NoWr.zip (1.2 MB)

Thanks @nonid - I don’t need anything extracted, can do myself, and have limited bandwidth so try to download as little as possible whenever I can. Can you please zip the images, thanks.
Can you answer my question about the BIOS.rom please, that you previously had linked here, is it from stock BIOS dumped from system, has it been edited by you etc, and how was it created/dumped?
On SCEWin, it’s only something to try when possible, looks like none work on your system thanks for checking.

Have you verified your flashing method is working, not just looks like it’s flashing? You can do this by updating the in-use CPU microcode, then check after flash update if it works.
I’m curious on this to see if the stock flasher method is letting you update or not, or are you simply using the AFUWinx64 directly to update instead?

Does your system have Intel ME installed, I checked the download pages, but no Intel ME drivers listed but at lot of those files are not named what they actually are but simply “Vaio Update” and non-descript details when checking.
Can you please check with HWinfo64, in the large window on the left, expand motherboard section and see if you see ME and if yes go to it and find ME FW version.
You may first need to install ME Drivers, check this thread and way down at section D4 try ME 6 and ME 5 drivers both (Specifically v6.2.50.1062 (ME 6) / v5.2.20.1030 (ME 5)) 1.5 and 5MB versions if included in the download folders
Intel Management Engine: Drivers, Firmware & System Tools

If you did not see ME FW in HWInfo before, and one of those driver packages install for you, reboot and then check again.


@Lost_N_BIOS , Images are Zipped (http://www.mediafire.com/file/c6x554z2am…Images.zip/file)


Sorry for stating the file as DUMPED BIOS but it was Pure, extracted from update program.





Yes, I can flash Bios using AFUWINx64.EXE with command “Afuwinx64.exe BIOS.rom /p /b /n /d26” and yes I had successfully updated the microcode of my CPU using this method. Also I can Flash and DUMP my BIOS using AFUWINGUIx64.EXE(Graphics One) too.
Note: All AMI Aptio 4 Programs work on my system for flashing, dumping and editing BIOS Images…


No Intel ME installed on system, I tried installing ME 6 and ME 5 drivers but both of them gave me error(image attached) at time of installing drivers. I tried checking HWInfo but found nothing related to "ME FW".

Screenshot (17).png

Screenshot (16).png

@nonid - initial “BIOS.ROM” you had attached is just R0170Y7.rom from the EXE? Answered myself, via hex comparison Thanks for clearing that up anyway

Thanks for the BIOS images, will be checking them and then looking at getting this sorted out for you. Why are they all cropped off, I need to see what is there by default, with the stock non-edited BIOS flashed into the board?
Please retake these images with stock BIOS used and show the root of all those pages so I can see settings, thanks

I see you edited your first post now, with numbered summary, @ #5 unlocked FD << how did you write this unlocked FD to the BIOS?
Can you download and run this, and see if BIOS it backs up is larger than 2MB - https://www.majorgeeks.com/files/details…up_toolkit.html

If it is larger than 2MB, please upload. Looking for a 4MB dump, and your unlocked FD caught my eye, if it’s unlocked we can dump it all, but unsure how since you cannot find ME version or ME at all, so I don’t think any FPT version will work.
This is Intel chipset (PM55 if I remember from looking earlier correctly) and there is ME drivers for your chipset too, so not sure why ME5/6 drivers didn’t work above.
However, we really only need to edit the BIOS region we have anyway, but it’s easier to flash back modified BIOS with FPT if/when we can.
*Edit - I see from your BIOS images, ME Version 6.0.20.1185! So, now we can do this a better/safer way, AFU is not very reliable, so I always try to use FPT when possible.

Please download this Intel ME System Tools V6 IBX package - https://mega.nz/#!rVt3jJCC!-l2IP-MnuK993…pxzSkz78XBCXfwU
First we’ll try windows, if that fails DOS. Inside you will find Flash Programming Tool folder, then inside that DOS/Windows. Select the windows folder, hold shift and press right click, choose open command window here.
Then run the following commands, and then zip and send me both files created (If this fails, do same at DOS instead, with fpt.exe)
FPTw.exe -d bios.bin << This will only work if you have actually unlocked the FD, otherwise permissions/error
FPTw.exe -bios -d biosreg.bin

If neither of those work, in DOS or in windows, then try this package instead, same actions but I think above is correct one
CCK V6 - https://mega.nz/#!fUkkBYBD!8jD334vWra6Ty…ZQTnhbtd9gKkkR4

On your AFU commands, what is the /d26 flag? I see this in the default batch, but wondered if you knew what it actually means


@Lost_N_BIOS Yes these(http://www.mediafire.com/file/c6x554z2am…Images.zip/file) Images are Stock Bios images without any modification to the BIOS. I just enabled Virtual Technology in advance Tab…


Using Flash Image Tool–>Master Access section–>CPU/BIOS,ME,GbeLan–>allread,write access to 0xFF and -->MERegion–>Binaryfileinput to newversion(6.0.3.119)…, and if I run https://www.majorgeeks.com/files/details…up_toolkit.html then I get only 2Mb file…instead of 4Mb or say full firmware.
Note: I used my SPI programmer tool to dump and flash the whole 4MB Firmware after editing it with FIT.


Well I had updated ME Version to 6.0.3.1199(Working Proff Attached) using FIT and SPI Programmer. And here is the Full Image(ME Updated and Unlocked FD) I flashed(http://www.mediafire.com/file/a68novuh06…ME-MOD.bin/file).
Also I can use my SPI Programmer anytime so we can play with BIOS in any way we want to…


Results attached… which shows correctly that I still cannot access ME Region…
Note: During boot my laptop says “Intel Me ignition firmware will boot from the factory default image” just before booting Windows, is this error causing ME to not boot or something else??
EDIT* I successfully modded my bios to remove ME Firmware but after flashing the laptop won’t boot and only show green light and no display, fan spins at very low speed…Here is the modded image after removing ME firmware(http://www.mediafire.com/file/x2rdh4alk5hqa1z/Image.zip/file) and I had also attached some images related to its modding process…


No, this program will not work since my ME firmwware is Ignition IBX, not CCK…


Well since I use the afuwinx64.exe extracted from the Stock Update Program, so I use the same command for flashing which is used by Original BIOS Update, well I can use normal afuwinguix64 to flash the bios too.
Note : I figured that the afuwinx64.exe of my OEM BIOS is different than the normal leaked afuwinx64.exe found on the internet and the /d26 flag is used in place of /R /X flags in this OEM version or also to restrict the modification of bios data to a certain leve or percentage.

Screenshot (20).png

mod.jpg

Screenshot (21).png

error.jpg

Screenshot (24).png

@nonid - Please then, redo the BIOS images and do not crop the images, I need to see the entire BIOS pages.

To unlock FD, you have to write the entire BIOS image with unlocked FD to the BIOS, or at least re-write the FD with programmer.
Sounds like you did that, so Intel FPTw.exe -d BIOS.bin should give you full 4MB dump, correct?

It’s good you have programmer, that makes flashing or recovery no problem! Sounds like you did not unlock FD, if you cannot dump ME region (FPTw.exe -me -d mereg.bin), or dump entire BIOS (FPTw.exe -d bios.bin)
Ohh, I see FPRR (Flash Protected Range Registers) is set on some areas, that needs edited in assembly/hex, but not really necessary since you have programmer, but I can try to find and unlock for you, will look into that tonight/
But since you have programmer our main focus needs to be unlocking the BIOS first and then we can fix all this unrelated stuff last if needed.
That was my main reason for mentioning ME, so we could get FPT working, so you could give me BIOS region dump to edit for menu unlocking. I didn’t realize you have a programmer!

We do not want ME removed, and what you mention sounds like you maybe messed up something in the ME when you updated it. Best to flash back to stock BIOS original backup with programmer
Please attach original unedited BIOS dump from when you first took a valid backup with your programmer, I will update ME for you again in case you missed something. You did not have that ME error before this correct?

on /D26 - I asked thinking maybe you researched and found the actual answer. /d usually means to verify the file without flashing it, obviously this can’t be that or related, since it’s flashing
Best we stick to FPT and or programmer anyway, AFU should really only be used when you can’t use one of these tools instead.


@Lost_N_BIOS , ok I will upload full fresh images without cropping.


No, it only give BIOS Region - 2Mb file.


No, actually I was testing if I can remove ME firmware completely from BIOS but it was unsuccessful.


Here(https://www.mediafire.com/file/x2rdh4alk…/Image.zip/file) is the first DUMP from programmer which I made just before messing with anything in the BIOS(AND also I set BIOS to default settings just before dumping it). And the ME error I mentioned was not actually error, it was some sort of message appears only one time when I flash my BIOS(mainly due to resetting of NV items).

Since FD is unlocked and FPT can’t dump full BIOS still, it must be due to the FPRR lock, I will see if I can remove for you. This initial BIOS dump you linked above does not have ME region?
Should we maybe move forward using >> Full-BIOS_ME-MOD - 4MB Bin? Which BIOS were you using when you ran the FPTw.exe -I that you gave image for above?
And, for the FPRR, since you have flash programmer, we don’t need to remove anyway (I know I can remove FlockDN bit setting, but unsure about the rest without having system in hand)
I can send you a BIOS to test and see if it’s all removed by bypassing this, but unsure if it’s that easy from my end.

Waiting on the BIOS images, thanks


@Lost_N_BIOS Here<http://www.mediafire.com/file/uviu5o3vsvb050l/BIOS-DUMP-4MB.zip/file> is the Dump which I used for every command in FPTw.exe and also you can start using this DUMP for further BIOS modding purposes.
NOTE: Only the ME Version is Updated in this DUMP and 0xFF for Read and Write Access of CPU/BIOS, Manageability Engine (ME) and Gbe LAN.


Sorry for being late but I had to compress jpeg’s to reduce file size…<http://www.mediafire.com/file/js9dr4c4yfwnv9t/BIOS-Menu_Images.zip/file>.
NOTE: These images are of same DUMP I uploaded above and the BIOS section in that dump is totally untouched.


Waiting for BIOS…

OK, thanks, I will use that one then moving forward. Thanks for uncropped images too.

First I will send you BIOS with unlock FPRR test, after programming see if you can write to BIOS from windows using both command below (I will include full and region only files for that test)
FPTw.exe -f biosname.bin
FPTw.exe -bios -f biosregionname.bin

Sorry it’s too late for me to redo now, just heading off here, I’ll get to this first thing tomorrow for you.

@Lost_N_BIOS Thanks! a lot for your help…Also, Please upload files to this File Drop Folder(http://www.mediafire.com/filedrop/filedr…346c0b77a430e8e) because my ISP block nearly all of the other File Sharing Sites or either upload them as attachments in your posts.

You’re welcome @nonid - Here is FPRR test, please program DUMPIDA.bin to the board with programmer, then test both files using below commands (It’s same file, only testing writing to BIOS differently with FPT)
FPTw.exe -f DUMPIDA.bin
FPTw.exe -bios -f DUMPBIOSreg.bin

http://s000.tinyupload.com/index.php?fil…027459324915154
Tonight I will get into seeing if we can unlock the menu’s, apologies for the delays.

If you can’t download, try this proxy - https://www.kproxy.com/
I can’t upload to mediafire it always errors on me, and already uploaded to above before I saw your message. If you end up not being able to get file, I will attach here tonight when I get back.

How did FPRR test go with above files and commands? Back in your BIOS again now, posting short reply so you didn’t think you were buried in here

@Lost_N_BIOS I had attached the result of the command “FPTw.exe -f DUMPIDA.bin” after flashing the BIOS using Programmer but as seen, the output of the command states that the SPI full region permission is still locked. Well it is not a Problem, I still can flash the BIOS using the PROGRAMMER so Please dont waste your time on that patch…(Well If you wanted to then…)

Screenshot (30).png

That doesn’t look like you were using file I sent, unless you renamed the file? How about BIOS region flash command, fail too? >> FPTw.exe -bios -f DUMPBIOSreg.bin
But yes, as you mentioned, you have programmer so this isn’t really an issue, except for having to have the system taken apart to use the programmer.
I’m done working on that the other day, it either works or not, I can’t make any other changes on my end for that, have to has direct system access to change the rest that may need changed.

@Lost_N_BIOS Sorry but I had renamed the file for easy flashing purposes…And for command "FPTw.exe -bios -f DUMPBIOSreg.bin" results are attached.Well, the only access I need is BIOS region because I had already updated the ME firmware…Should I try hardware mod(Data from Motherboard Datasheet Attached)…

Screenshot (32).png

Screenshot (34).png

That’s all you had to say about the rename, I only meant to check to be sure you used correct file
So, I was thinking you couldn’t even write BIOS region before via FPTw.exe -bios -f file.bin, but looking back I see you could already, so this test was waste of time on the BIOS region. FPRR unlock, fail on all levels
No need for hardware mod or pinmod etc, you have programmer so you can write anytime you want, and FD is already unlocked and that’s all that will override anyway.

Quick test, method check. Please program this BIOS, check Advanced page, do you see new setting option “BIOS Update”? Never mind! I guess you can use FPT!! >> FPTw.exe -bios -f SingleSetting.bin
http://s000.tinyupload.com/index.php?fil…667399862922303

If no new setting there, please do these to confirm it’s not method being used to put BIOS back that’s causing the settings fail
FPTw.exe -rewrite -bios -f SingleSetting.bin

And then if still same, program in that BIOS as final confirmation. Also, after all of these, clear CMOS and load defaults once done, then check for setting.

@Lost_N_BIOS No I even tried flashing the BIOS using programmer but result attached…Also if I open this file with AMIBCP then it gets crashed…

IMG_20181219.jpg