modding X99 gaming strix bios

Hey,
i have found this forum recently, and got interested in this topic. I would like to enable avx instruction offset in my lastest bios 2101 (using i7-5820k & asus gaming strix x99),
so i made changes according to this topic: [REQUEST] AVX Offset for ASUS X99-E WS & Haswell
it should be doable, because there is this option, but it is probably just hidden.

So i have modded STXX99.CAP and i have tried to flash it through usb bios flashback, but no success. Not sure if it is damaged board, or what, because that button just does nothing, not even blink. I have tried all usb ports.

I would prefer to flash it through EZ flash utility in bios, but there is error "selected file is not a proper bios. From what i read, it is probably protected to normal flashing and needs to be done through UBU?
anyway, i prefer to ask before damaging my new board, so there is my modded file: http://s000.tinyupload.com/index.php?fil…517438553785633

appreciate any help guys

@trackmehard - Mod BIOS can only be flashed with USB Flashback. For USB Flashback to work, USB stick must be 2.0, FAT32 and BIOS file must be on root of SB (not in folder).
Also, smaller/older/cheaper is best, like 128MB-2GB, sometimes new/large one will work if you partition it down to 1GB. And of course you have to use the designated USB Port, check your manual to see which it should be.

Probably your mod BIOS has broken capsule signature, I will check that and fix or you * Nope, this is not the issue, it’s just bad mod (missing (x2) non-UEFI Pad files from stock BIOS + missing a padding file above microcode volume too)
I gave info on how to do the mod in general on page #1 post #8 of the thread you linked. AMIBCP is not used at all for this mod, unless you meant to simply enable the setting without making it visible?
If that was your goal, then maybe it’s possible, unless AMIBCP is what broke the BIOS, then if it is you’d have to make the same changes manually instead (To AMITSE/SetupData module - like this - [Request]Maximus XI Hero - Unlock AMIBCP)

In order to not break this BIOS, mod needs to be done in a special way, not how I described at link above. Well the mod itself is done same, but process to edit the BIOS is not same at all, this BIOS requires special dance for this edit.
Extract body from capsule. Then setup extract uncompressed with MMTool 5.02, do the edit, then replace with MMTool, then fix FIT Table (extract original padding that contains FIT, replace in mod, with UEFITool 25). Then replace final mod BIOS body back into stock capsule.

Here is properly modified BIOS with AVX OFFSET setting visible - http://s000.tinyupload.com/index.php?fil…131049138396933

If that will not flash, then something in your USB Flashback setup is not compatible or not being done correctly. Confirm this by renaming stock BIOS to flashback name and try to flash stock BIOS via USB Flashback, once you find USB that works on then the above file will work too

Really thanks for help with this . Anyway, it seems i am still unable to flash your file trough EZ flash in bios, there is still message “selected file is not a proper bios”.
Unless i solve my problems with usb bios flashback, is there any option to make this working?
I tried AI SUITE III EZ bios update, selected your file, and it was done in second without any error, just prompt to restart pc and then pc turned off. But i am really not sure if something happened or not, because in bios nothing changed, none avx offset was visible.

In your opinion, it is possible that haswell (even tough it has avx/avx2 instructions) does not have this option? Maybe it is exclusive only for broadwell, but in that case it should not be present in that bios … ?

@trackmehard - You’re welcome!

You can’t see any message on screen in USB Flashback, so it’s not the BIOS I posted for you that’s the issue, it’s how you are trying to use it.
You can ONLY flash mod BIOS with USB Flashback, if you can’t get that to work with any USB Sticks you own (as mentioned, try with stock BIOS first until you figure it out and see it succeed)
Tthen we can do FPT instead but I will need to walk you through using that and giving me your FPT dump so you don’t brick the board.

As to your questions at the end, even if CPU does not support this, how I enabled it in BIOS would make it appear. And others have already been using these options on this chipset, so we know it works. You just have to flash the mod BIOS properly is all.

If you can’t get with USB Flashback, here’s what we do next.
Follow carefully, exactly, and do not stray from what I write here[ (maybe following something you read in another thread or another forum etc)
You can brick your board in one click with FPT so pay attention and do only what is mentioned here then stop and wait!

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do get error STOP, show me image of the command entered and the error given and do nothing else but wait >> FPTw.exe -bios -f biosreg.bin
^^ This is important step, don’t forget ^^ Also, be sure you are exact in what command you use, as I’ve written above ONLY and only once


If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required
http://s000.tinyupload.com/index.php?fil…134606820377175

@Lost_N_BIOS

Many thanks for your help (again), to be honest i was little worried to use that FPT stuff at first, so i have managed to get to work usb biosflashback in advanced/apm configuration i had enabled S4+S5 ErP, so that is why it could not work. But in case of failure of this method, i appreciate that FPT guide too.

I have flashed your modded BIOS file and everything looks good! AVX instruction offset is there, so you have prolonged life of my X99 platform i guess (Im running 4.4 ghz watercooled, bud when it comes to AVX it is unstable on that frequency and it will BSOD immediately, so downclock to last AVX stable profile is only good option for me).

If it does not bother you too much, can you specify more (step by step) how to mod this bios? You said there is a different procedure, so when asus release another update in future it would be nice to know how to mod it on my own.

// tested that feature, and it looks like it does nothing, tried negative offset 1-5 and core frequency remains still same in hwmonitor, also tested prime v26.6 without avx where is OC stable, and then tested in 29.8 with AVX with offset 5, which should downlock to 3.9 ghz but it didnt happen, immediately BSOD with any offset as without. Maybe asus had some reason to disable this?